locked
acpi.sys causing high cpu usage (System Interrupts) RRS feed

  • Question

  • This started happening a little while back, i was gaming and noticed my fps drop dramatically, checked my cpu usage and it was at like 40-50%, 20-30% of that usage being system interrupts. So ive been doing tons of research for the past 3 days trying to figure out what could possibly be causing this.

    I found out acpi.sys was the issue so i did more research on that, I did some registry hotfixes, and other suggested things but nothing has seemed to work.

    In process explorer the thread is named "ACPI.Sys+0x1af7c"

    I've changed the acpi settings in bios, then reset them back to default, that did nothing.

    I have literally ran out of ideas,

    SPECS:

    i7 920 @ 2.6ghz

    9gb ram

    XFX 5870 1gb

    Windows 7 64bit Ultimate.

    Any ideas at all?

    Monday, November 19, 2012 11:35 PM

Answers

  • You can get them at ebay and best buy amongst other places like 8-20 bucks. Also consider getting a manual tester if you want real accurate readings but it is far more complx than just pluggin it into a device and looking for a green light.


    Tom

    • Proposed as answer by MS_Guru_Tom Wednesday, November 28, 2012 4:10 PM
    • Marked as answer by Kim Zhou Friday, November 30, 2012 2:54 AM
    Wednesday, November 28, 2012 4:10 PM

All replies

  • Hi,


    You may try to boot into Clean Boot for a test.

    http://support.microsoft.com/kb/929135


    Kim Zhou

    TechNet Community Support

    Wednesday, November 21, 2012 6:30 AM
  • Run LatencyMon.

    http://www.resplendence.com/latencymon

    //Daniel

    Wednesday, November 21, 2012 6:08 PM
  • I have run Latencymon, thats how i found out that acpi.sys was the problem.

    @ Kim, ill give the clean boot a try

    Thursday, November 22, 2012 10:46 PM
  • Clean boot didnt help, ive noticed though when the computer is off for a long time and then turned back on, the system interrupts dont come back for a few hours.

    Any ideas??

    Tuesday, November 27, 2012 5:26 PM
  • Hi,

    Heres a suggestion, Try drivermax and see if it finds the driver out of date. (I like the software) It may find more driver issues on your pc to, free users only get 2 drivers a day though. (You can disable it on start up through msconfig so you can start it every 24 hours and get free drivers)

    You could also get a psu tester and check your psu if it is going bad it would drive this driver nuts and make your fps output on the gpu lower. But always test before you buy.

    I wouldn't recomend disabling acpi though, it manages things with your psu, like sleep wake ect.

    Just a suggestion do what you like :)


    Tom

    • Proposed as answer by MS_Guru_Tom Tuesday, November 27, 2012 6:54 PM
    Tuesday, November 27, 2012 6:53 PM
  • Where could i find a psu tester? would best buy sell them?

    I'm thinking this has to be a hardware issue because ive re-done everything as far as drivers can go. The only next thing would be a re install of my OS.

    I'm probably due for a new psu anyways, its about 2 years old.


    mbutler

    EDIT: i've come to the conclusion it must be hardware based, i just re-formatted and actually installed Windows 8. First thing i did was bring up the process manager, system interrupts still using 30% of my cpu on idle.

    I'll take a look into that psu tester

    • Edited by Mbutler183 Wednesday, November 28, 2012 7:50 AM
    Wednesday, November 28, 2012 4:57 AM
  • You can get them at ebay and best buy amongst other places like 8-20 bucks. Also consider getting a manual tester if you want real accurate readings but it is far more complx than just pluggin it into a device and looking for a green light.


    Tom

    • Proposed as answer by MS_Guru_Tom Wednesday, November 28, 2012 4:10 PM
    • Marked as answer by Kim Zhou Friday, November 30, 2012 2:54 AM
    Wednesday, November 28, 2012 4:10 PM
  • ive got the same problem and  it is getting very annoying, acpi.sys is my problem ive researched everywhere and still no answer, but there is a (apparently) a way to fix it, WHICH NO ONE WILL MAKE CLEAR!! 
    i have a lot of experience with technical problems and this is the only one that i cant resolve.
    please helpp!!
    Note: i also think my problem is my usb drivers... 
    Saturday, April 6, 2013 10:38 AM
  • Hello guys i have had the same problem till i dont remember his/her name but took an advice from an another user. sleep first waken then :) i tried a lot of things but just put your computer at the sleep state first then power up again . It worked for me i dont know why :)

    Sunday, September 29, 2013 12:12 PM
  • Well I've been suffering with this for a while - PC would never sleep or even go to screen saver. So I put it to sleep manually.

    The bad new is that I got a BSOD when I woke it using the mouse. The error was BAD_POOL_HEADER and was associated with the NDIS drivers.

    The good news is that it cured the excessive CPU for ACPI


    You may have speed - but I have momentum...

    Friday, July 4, 2014 10:50 AM
  • Thank you so much. It works for me.
    Sunday, March 20, 2016 7:53 PM
  • This fixed it for me: https://support.microsoft.com/en-us/kb/834631
    Friday, September 16, 2016 12:05 PM