locked
OOA and Address Book issues after Mailbox Move exchange 2007 RRS feed

  • Question

  • Recently my single mail store for staff was running out of space, So from within exchange I created a new mail store on the same server but a different drive. All the administrative mailboxes were moved successfully. 

    However now everyone that moved cannot access their out of office assistant through outlook and they're no longer getting a fully updated address book. However both are working normally in OWA.

    When I test email autoconfiguration it fails. Users on this new store are working normally otherwise. I'm not sure if there's a setting I'm missing here or what. I didn't think there would be any issues since the new database is on the same server. What am I missing?

     

    Tuesday, October 11, 2011 2:27 PM

All replies

    1. What does it fail on?
    2. Are the users in cache mode or online mode, test both
    3. Run the ExchBPA and check event logs for any errors
    4. See if this is relevant and helps. - http://www.msexchange.org/articles_tutorials/exchange-server-2007/tools/troubleshooting-out-of-office.html

    Sukh
    Tuesday, October 11, 2011 10:50 PM
  • 1)  In the log i've got errors like 12029

    Returned if connection to the server failed.  and Errors like 12007  under getlasterror=

    2) Cache Mode

    3)Running that now

    4) Most stuff I've found isn't relevant because OOF and address book work normally when accessed VIA OWA. Also users who are still on the old staff mailstore work normally in all aspects. It's simply users that migrated to the new database, on the same server that aren't working. So it's not like any URL's changed  since everything is still pointing back to the same server, the database is just in a new location.

    Wednesday, October 12, 2011 4:05 PM
    1. Can you post the exact event ID
    2. Try online mode
    3. Create a new profile and test

    Sukh
    Wednesday, October 12, 2011 7:40 PM
  • Recently my single mail store for staff was running out of space, So from within exchange I created a new mail store on the same server but a different drive. All the administrative mailboxes were moved successfully. 

    However now everyone that moved cannot access their out of office assistant through outlook and they're no longer getting a fully updated address book. However both are working normally in OWA.

    When I test email autoconfiguration it fails. Users on this new store are working normally otherwise. I'm not sure if there's a setting I'm missing here or what. I didn't think there would be any issues since the new database is on the same server. What am I missing?

     


    Hi,

     

    My guess is that the autodiscover for the problematic user is failed. Please run "Test Email Autoconfiguration" to see what error message has be reported:

     

    http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx

     

    Besides, switch to Log tab in “Test Email Autoconfiguration" box, and test the SCP URL in IE broswer in the problematic client. (you may also compare the test result with other normal users to see if there is any difference). The expected result is error code 600.

     

    Regarding the OAB, it depends on autodiscover service; besides the test above, please also check the new mailbox database properties, by default it is associated with the “Default address book”. If you use another OAB file, please change it accordingly.

     


    Fiona
    Thursday, October 13, 2011 4:32 AM
  • 1) Here are the Autoconfiguration test results.

     

    SMTP=Myaddress@XXX.k12.ny.us
    Attempting URL https://owa.XXX.k12/Autodiscover.Autodiscover.xml found through SCP
    Autodiscover to https://owa.XXX.k12/Autodiscover.xml starting
    GetLastError=12029, httpstatus=0.
    Autodiscover to https://owa.XXX.k12/Autodiscover/Autodiscover.xml FAILED (0x800c8203)
    Autodiscover to https://XXX.k12.ny.us/autodiscover/autodiscover.xml starting
    GetLastError=12007, httpstatus=0
    Autodiscover to https://XXX.k12.ny.us/autodiscover/autodiscover.xml FAILED (0x800c8203)
    Autodiscover to https://autodiscover.XXX.k12.ny.us/autodiscover/autodiscover.xml starting
    GetLastError=12007, httpstatus=0
    Autodiscover to https://autodiscover.XXX.k12.ny.us/autodiscover/autodiscover.xml FAILED (0x800c8203)
    local autodiscover for XXX.k12.ny.us starting
    local autodiscover for XXX.k12.ny.us FAILED (0x8004010F)
    Redirect check to http://autodiscover.XXX.k12.ny.us/autodiscover/autodiscover.xml starting
    Redirect check to http://autodiscover.XXX.k12.ny.us/autodiscover/autodiscover.xml FAILED (0x80072EE7)
    srv Record lookup for XXX.k12.ny.us starting
    srv Record lookup for XXX.k12.ny.us FAILED (0x8004010F)
    2)Online mode seems to work as far as address book updating properly, but the Out of office assistant still fails.
    3)Anything I make on the new database has this issue, even with a completely new computer with a fresh image.

     

    Thursday, October 13, 2011 12:13 PM
  • Oh, the 2nd line of my Autoconfiguration test should read  

    Attempting URL https://owa.XXX.k12/Autodiscover\Autodiscover.xml found through SCP

    I miss typed it from the error log.

    Thursday, October 13, 2011 12:15 PM
  • Ok, when I go to my autodiscover URL (https://owa.XXX.k12/Autodiscover/Autodiscover.xml) I get this... 

    SSL connection error

    Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.
    However when I remove the s, from https I get the error code 600 you mentioned, In retrospect we do not use https, to access owa.
    Where exactly do I change that autodiscover address to read 
    http://owa.XXX.k12/Autodiscover/Autodiscover.xml, which should work.

    Thursday, October 13, 2011 12:19 PM
  • go into the Emc and set the url correctly and try to remove SSL from the owa directory in IIS
    Sukh
    Thursday, October 13, 2011 12:37 PM
  • What's the correct set command for that? 
    Thursday, October 13, 2011 2:29 PM