locked
Analytic Chart is wrong when Filter Applied RRS feed

  • Question

  • This one is a little difficult to explain but I’ll try my best.

    I have a SSAS Cube that I am using as the base for my dashboard. I have applied a “Display Condition” to my Scorecard so when I click a KPI, the appropriate Analytic Chart is displayed. This works fine.

    However, if I try to apply a filter to the Analytic Chart, it’s getting the wrong values from the cube. I have two values, an Average and a SUM of the same measure. The Analytic Chart was created using the Average value yet when I plug the filter in; it uses the SUM value instead. Nowhere in my Dashboard do I refer to the SUM value – Where is this coming from and how to I force the filter to use the Avg instead of the SUM?

    I’ve applied the same filter to the scorecard and this works fine.

    Thanks for any help.


    Ron...
    Monday, June 15, 2009 1:00 PM

All replies

  • Hi Ron,

    Please enable the AS Profiler Trace while the Analytic Chart is launched.   The trace will provide MDX information which is been sent to AS Cube for your investigation.

    Thank you,
    Sundar - MSFT
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 15, 2009 7:13 PM
  • Thanks Sundar.

    Funny how I alwasy forget the Profiler Trace - Thanks for shaking me up.

    That being said though, the MDX query being sent out seems to be pointing to the right measure (AvgSize) yet the chart being created is using SUM (Size) for some odd reason and that is not being shown in the MDX Query being provided by the Trace.

    Any other useful tips/pointers for me to look at? I'm the only one in my company that knows how to spell PerformancePoint let alone use it, so local help resources are less than scarce. The course I was scheduled to be on this week got cancelled due to lack of interest (I was the only one).

    Thanks in advance.
    Ron...
    Tuesday, June 16, 2009 1:53 PM