locked
Lync DPI Scaling Broken RRS feed

  • Question

  • I'm having an issue where Lync DPI scaling is simply not working. I've got a Surface Pro 2, latest drivers, using a 27" WQHD monitor (primary) and the Surface display (secondary). Using the "recommended" scaling setting the primary display appears to be at 100% DPI scaling and the Surface display appears to be at 120%.

    Every other program that I use respects the DPI scaling, and this includes all of the other Office applications. See below for pictures of the apps running on the primary and secondary screens.

    Edit: MS's verification for me for this forum is broken. I've uploaded the screens to Imgur

    Primary: i.imgur.com/q1i1XQx.png

    Secondary (notice how the Outlook text is all fuzzy but Lync is still sharp; that's bad, I can barely read the text in Lync): i.imgur.com/uOCQZiW.png

    Wednesday, January 8, 2014 1:29 AM

Answers

  • Check you have installed the latest update for Lync Windows Store App. If not, install the latest update.

    If the problem persists, try to disable scaling for the app.

    You can also try to reduce scaling for windows.

    For the details, you can check https://www.microsoft.com/surface/en-sg/support/apps-and-windows-store/app-display-issues

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Lisa Zheng
    TechNet Community Support

    • Proposed as answer by Lisa.zheng Monday, January 13, 2014 7:25 AM
    • Marked as answer by Lisa.zheng Sunday, January 19, 2014 5:41 AM
    Thursday, January 9, 2014 2:29 AM

All replies

  • Check you have installed the latest update for Lync Windows Store App. If not, install the latest update.

    If the problem persists, try to disable scaling for the app.

    You can also try to reduce scaling for windows.

    For the details, you can check https://www.microsoft.com/surface/en-sg/support/apps-and-windows-store/app-display-issues

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Lisa Zheng
    TechNet Community Support

    • Proposed as answer by Lisa.zheng Monday, January 13, 2014 7:25 AM
    • Marked as answer by Lisa.zheng Sunday, January 19, 2014 5:41 AM
    Thursday, January 9, 2014 2:29 AM
  • I'm having the same issue with Lync 2013 (Office 365 Click-to-run install) on Windows 8.1 on a Surface Pro 3.  All Office desktop applications scale correctly on different monitors except for Lync, which doesn't respect the display scaling settings of the individual screens.

    Thursday, December 4, 2014 2:56 PM
  • Same issue for me! Using Win10 and Skype for Business. It only works well on the primary screen where I have a 150% scaling (high res 12-inch laptop screen) but for the extended screen, with 100% scaling, the windows becomes massive. Is it supposed to look like that?
    Thursday, September 3, 2015 8:22 AM
  • Win10 + Lync with QFHD doesn't get scaled and looks mega-tiny so it's unusable. Shame on M$.
    Monday, September 7, 2015 9:30 AM
  • Has this been resolved? I am using win10 + Skype for Business and it behaves just like everyone is describing.
    Tuesday, December 22, 2015 7:05 PM
  • More and more of our exec's were taking on the Surface Pro 3's and it was getting too hard to explain why Lync/Skype was behaving the way it was. We finally found a solution to the Lync scaling problem. It's called Jabber.
    Wednesday, March 9, 2016 3:16 PM
  • Still the same problems almost 3 years later....

    Good job! The DPI scale is completly broken

    Monday, October 3, 2016 3:10 PM