none
Can no longer login to Win7 VM from Win10 Host RRS feed

  • Question

  • I have a Windows 7 VM running an old application, because the application will not run on Windows 10. I have been RDP into it for months, and now it is giving me this error:

    "Your password may have expired or the remote PC might not accept blank passwords"

    Here's my environment:

    Windows 2008r2 DC

    Windows 7 & 10 Pro PC's

    VM is on Win10 Pro PC, Workgroup

    Like I said, worked a month ago.

    I attempted to RDP from another Win7 Pro PC on network and received the same message. But the old RDP gives you more information, and I saw that I was trying to login as a domain user, instead of a local user. Changed the login to login as a local user and the Win 7 PC connected connected right away.

    I then tried to change the login on the Win10 PC to a local login and it still gives me the same error (I can login from Hyper-V Manager). Is the format of local login (Machinename\Username) different on the new RDP?

    Any help would be greatly appreciated..




    • Edited by aroner Tuesday, January 29, 2019 6:13 PM
    Monday, January 28, 2019 10:49 PM

All replies

  • hi
    (0)do win7 and win10(hype -v host ) physical machine in domain ?
        do win7(hype-v guest ) in workgroup ?

    (1) can you logon win7 VM through hyper-v manager console ?
    If you can,you can try to do below steps on win7 VM
    0 enter windows+r ,enter lusrmgr.msc
    1  click "Local Users and Groups"
    2  click "Users"
    3 A list of users will show in the right panel of the application.
    4 Find the user that looks like your Microsoft account. It won't say Microsoft account on it, but look for the account that has the same user name.
    5 Right-click on that account which is used for remote.
    6 Reset the password for local account which is used for remote session on win7 vm.
    7 A "Properties" window will pop-up
    8 The "General" tab should be showing
    9 Un-check the box "User must change password at next login".
    10 Check the box "Password never expires".
    11  Make sure the other boxes are NOT checked.
    12 Click "Okay".
    13 Try to set the following policy to disabled
    Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Accounts: Limit local account use of blank passwords to console logon only

    14 uncheck "allow me to save credentials" in RDC on win10 host
    15 enter computer name in computer list box ,enter username (not require computername\username)  in username box

    (2) can you remote your win7 vm by ip address ?







    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.





    Wednesday, January 30, 2019 7:59 AM
  • Well Shoot, I thought you were on to something.

    Thanks for the reply.

    I can login thru Hyper-V Manager. And I can Login from another PC running Win7PRO.

    13 Try to set the following policy to disabled
    Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Accounts: Limit local account use of blank passwords to console logon only

    Disabled that policy.. Same Error

    I reset the password, same error.

    I when a step further and created another user, and got a different result. But got the "We couldn't connect to remote PC. You might not have permission to sign in remotely" error. I added the new user to the admin group and I got the same error I'm getting with the original user. I even reset the password for the Admin user.

    I've tried using the IP address, and just the Username without Computername. Without success. But if I login from the Win7 PC, I have to use the computername\username and it signs in.

    Any other ideas? Why would I have the same problem when I add new user to admin group? I'm beginning to think it's Win10 RD... I'm wondering if there is an update on it.
    Wednesday, January 30, 2019 6:26 PM