locked
vob files won't open by double click RRS feed

  • Question

  •    My problem is not adding .vob filles to the library. My problem is I am unable to open a .vob file by double clicking it. Not even Open With will open it in WMP 12. Everything else plays fine. I can even change it to .mpg and open it by double clicking it, but that isn't the issue. I know I used to open my .vob files in WMP 12 by double clicking them. Please help me get this back to working properly. I like using WMP 12 in Windows 7x64. I have tried un installing and re installing WMP by using Programs & Features/Turn windows features on or off. I tried file associations. I tried just about all the most common solutions. I hope you can help.
    Wednesday, September 5, 2012 4:54 PM

All replies

  • WIndows media player doesn't support vob fiels use vlc player http://www.videolan.org/vlc/index.html


    Justin | http://patchmypc.net | Please remember to mark as helpful/answer if this helped you

    Wednesday, September 5, 2012 5:02 PM
  •    Who told you WMP doesn't support .vob's? I can play .vob's if I use the WMP12 interface, but I don't want to go that route. I prefer just being able to double click the .vob and have it open. I am noot really keen on VLC but if I can't solve this I might have to go that route.
    Wednesday, September 5, 2012 5:08 PM
  • Hi,

    I would like suggest you try the following suggestions:

      • Right click a .vob files
      • Open With>Choose Default Programs
      • Click the Windows Media Player’s icon, then check under "Always use the selected program to open this kind of file".
      • OK

    Hope this helps.


    Spencer

    TechNet Community Support

    Friday, September 7, 2012 4:57 AM
  •    No can do. There has to be some problem in the registry that is preventing my .vob files from opening with a double click or "Open With". They open no problem with Nero or VLC, but I choose to use WMP and somehow there has to be a fix for this problem. These files are supposed to open without even a codec being installed in Windows 7 and I can't get them to open at all with or without codecs. I have a felling that using these 3rd party players in the past somehow screwed this up. I hope someone has a fix for this somewhere. I'm getting desperate. As you can see I ran the media troubleshooter and I got this back. Sounds sstrange because I've used a codec with this and it still didn't work.

    • Edited by Julio99 Friday, September 7, 2012 2:59 PM
    Friday, September 7, 2012 2:42 PM