none
Windows 10 WSUS feature update to 1709 error 0x80244019 RRS feed

  • Question

  • Hello

    I can't figure out why is that happening. Other little security updates work just fine, but when I want to upgrade
    one of many Windows 10 Pro machines to the next main build version it doesn't work.
    Upgrades form 1607 to 1703 worked fine.

    On my test group with just 1 Win10Pro (15063.850) machine I have tried :

    net stop bits
    net stop wuauserv
    net stop appidsvc
    net stop cryptsvc
    ren C:\Windows\SoftwareDistribution SoftwareDistribution.old
    ren C:\Windows\System32\catroot2 catroot2.old
    net start bits
    net start wuauserv
    net start appidsvc
    net start cryptsvc

    and it didn't work.

    Then I tried
    WindowsUpdate.diagcab

    And WU still comes back to haunt me with an error which indicates problems witch connecting to WSUS service?
    WSUS works fine on this machine and 40 other (Defender updates, security patches, etc.)

    Inside SoftwareDistribution folder, in Download all I see is "state" and "WindowsUpdateBox.exe".
    So the download of 1709 hasn't even started.

    ReportingEvents.log inside SoftwareDistribution folder shows Windows Failed to install the following update with error 0x8024200d (consumer edition - I don't really know why why that one, but I've also approved business edition just in case,
    WSUS chose consumer edition for me somehow)

    That WSUS configuration is bypassing WU, because that group is disconnected from the Internet.

    Does anyone have an idea how to solve this?

    Tuesday, February 13, 2018 6:23 PM

All replies

  • Hi,

    Yep, this error indicates that there is a problem with the download and that its files are corrupted or missing.

    Since it's the only PC, please try to exit the Domain and re-join the domain for this PC to check the results.

    Also, this issue can be caused by corrupted Windows update components on this PC, please try suggestions in this guide to reset Windows update components:

    https://support.microsoft.com/en-in/help/971058/how-do-i-reset-windows-update-components


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 14, 2018 7:14 AM
    Owner
  • Rejoined Domain. It didn't help.

    While using this guide https://support.microsoft.com/en-in/help/971058/how-do-i-reset-windows-update-components I must say that half of those dlls weren't there.
    Did it anyway.
    SFC/scannow showed no problems.
    WSUS download mode is "bypass" (100 - BITS only) in GPO, default port 8530.
    Gpresult shows no denied settings. WSUS should work and it works
    for Defender updates, and other (eg. 2018-02 Security Update for Adobe Flash Player
    KB4074595) were downloaded and installed from the same WSUS server just fine.

    Feature update to 1709 is THE ONLY THING which doesn't work correctly.
    Does this "special update/upgrade Windows 10 consumer edition"
    try to use some other method of delivery which is turned off in my environment?
    Just noticed - there are no Pro, no Education, no N editions now in that WSUS category for Windows 1709? Only business and consumer editions now integrated in just 2 downloads? Or maybe Pro is not out yet and that's why I get those error trying to install Win10Home over Pro...

    Wednesday, February 14, 2018 12:33 PM