locked
Error 1392 received after modifying the Microsoft.Exchange.Monitoring.CorrelationEngine.exe.config file to change the AutoResolveAlerts value. RRS feed

  • Question

  • Recently, I found an article that the "AutoResolveAlerts" value in the MicrosoftExchange.Monitoring.CorrelationEngine.exe.config had to be changed from "true" to "false" so that SCOM could properly discover Exchange mailbox servers.

    The service will not start after making changes and I receive "Error 1392: The file or directory is corrupted and unreadable.

    I have removed the Exchange 2010 MP's, rebooted and even attempted to manually remove the Microsoft Exchange Monitoring Correlation service.

    Thank you in advance for any assistance.

    Tuesday, March 24, 2015 10:35 PM

Answers

  • Hi,

    Did you follow the article below:

    Optional Configurations

    https://technet.microsoft.com/en-us/library/ee758052%28v=exchg.140%29.aspx

    After disable the Automatic Alert Resolution Feature in the Correlation Engine, have you restart the Microsoft Exchange Monitoring Correlation Engine service?

    I assume you missed something when you edit the config file.

    You may change it back and then check the result.

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Yan Li_ Wednesday, April 1, 2015 2:36 AM
    • Marked as answer by Yan Li_ Tuesday, April 7, 2015 7:48 AM
    Thursday, March 26, 2015 5:39 AM