none
Cannot delete or move emails in OWA RRS feed

  • Question

  • Ever since I upgraded to SP1 for Exchange server 2010, I cannot delete or move emails. When I go into the event viewer to see the logs, it shows this error everytime I try to delete or move an email.

     "Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "404"."

    I have been searching for hours trying to fix this. I have found many solutions that work for other people, but does not work for me.

    Wednesday, July 13, 2011 3:29 PM

Answers

  • Hello,

     

    You can also try rebuilding the EWS VDir to reset it to a default settings by t he following steps:

     

    [Rebuild Web Services VD]

    ===================

     

    a.  Remove the EWS virtual directory in client access server. (Note: If needed, please change the “Default Web Site” to your IIS site name.)

    Open Exchange Management Shell. Run the command below:

     

    Remove-WebServicesVirtualDirectory “YYZ-MAIL-1\EWS (Default Web Site)”

     

    If you get the confirm information, please type “Y” 

     

    b.  Create a new EWS virtual directory.

    Run the command below in Exchange Management Shell:

     

    New-WebServicesVirtualDirectory –WebSiteName “Default Web Site”

     

             c.   Do an IISreset /noforce

     

    Thanks,

    Simon

    Monday, July 18, 2011 1:57 AM
    Moderator

All replies

  • I also noticed that I get another error also whenever I try to change a setting in OWA. This is the error that I recieve.

    WebHost failed to process a request.

     

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/56242772

     

    Exception: System.ServiceModel.ServiceActivationException: The service '/ecp/Customize/RegionalSettings.svc' cannot be activated due to an exception during compilation. The exception message is: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

     

    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

     

    Parameter name: item

     

    at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)

     

    at System.Collections.Generic.SynchronizedCollection`1.Add(T item)

     

    at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)

     

    at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)

     

    at Microsoft.Exchange.Management.ControlPanel.EcpServiceHostBase..ctor(Type serviceType, Uri[] baseAddresses)

     

    at Microsoft.Exchange.Management.ControlPanel.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)

     

    at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)

     

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)

     

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

     

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

     

    --- End of inner exception stack trace ---

     

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

     

    at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

     

    Process Name: w3wp

     

    Process ID: 5300

    Wednesday, July 13, 2011 5:31 PM
    1. Seems like your settings have been overwritten/changed after the update.  As you've gone to SP1, you may as well apply the latest rollup why youre at it.  The test.
    2. If it fails, try creating the  OWA directory again.
    3. 1. Use the Exchange Management shell and run the following:
      a. Get-OwaVirtualDirectory -Server <hub/client access server name> to check the settings
      in my case it was Get-OwaVirtualDirectory -Server exhub01
      b. Remove-OwaVirtualDirectory -Identity <VirtualDirectoryIdParameter>
      in my case it was Remove-OwaVirtualDirectory -Identity "exhub01\owa (default folder)"
      c. New-OWAVirtualDirectory -Name "owa (default folder)"

      then restart IIS using iisreset /noforce

    Sukh
    Wednesday, July 13, 2011 7:05 PM
  • I'm not sure if this would have anything to do with the problem, but, the sub domain that I use for the exchange server will not load in a web browser on the local machine. The subdomain will work when I am on another machine though. For example, if I go to exchange.access.domain.com on a client computer, it will load fine. If I go to the same domain on the server which the website is hosted, the page doesn't load. Do you know what might be causing that problem?
    Wednesday, July 13, 2011 7:20 PM
  • Has your first issue been resolved?
    Sukh
    Wednesday, July 13, 2011 9:10 PM
  • No, it hasn't been resolved yet. I just thought that part of the reason could of been because I can't access my exchange server url from a web browser from the server itself, but I can from any other computers.
    Thursday, July 14, 2011 3:46 AM
  • I'm still getting this error everytime I try to move or delete an email in OWA.

    Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "404".

    Friday, July 15, 2011 12:15 AM
  • Hello,

     

    1. Changed authentication on EWS vdir to Anonymous and Windows (Reference: http://msexchangeteam.com/archive/2010/09/23/456396.aspx Default settings for Exchange-related virtual directories in Exchange Server 2010)

    2. Did iisreset.

     

    Thanks,

    Simon

    Friday, July 15, 2011 9:05 AM
    Moderator
  • After setting the correct permissions, I am still getting the same error when I try to move or elete emails.

     

    Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "404".


    Friday, July 15, 2011 9:43 PM
    1. Check the binding in IIS for the default website, see if there are more than one http binding there.  If there's more than one and some seem odd, then remove them.
    2. Also, when you try to delete a message, doesn anything show up in the event logs on the exch server and IIS logs for that connection?

    Sukh
    Saturday, July 16, 2011 1:46 PM
  • I've checked the binding, and everything is the same as it was before I ungraded to SP1. Ever since I upgraded to SP1 , I have had this problem. Is there an easy fix for this SP1 problem?
    Saturday, July 16, 2011 10:46 PM
  • Hello,

     

    You can also try rebuilding the EWS VDir to reset it to a default settings by t he following steps:

     

    [Rebuild Web Services VD]

    ===================

     

    a.  Remove the EWS virtual directory in client access server. (Note: If needed, please change the “Default Web Site” to your IIS site name.)

    Open Exchange Management Shell. Run the command below:

     

    Remove-WebServicesVirtualDirectory “YYZ-MAIL-1\EWS (Default Web Site)”

     

    If you get the confirm information, please type “Y” 

     

    b.  Create a new EWS virtual directory.

    Run the command below in Exchange Management Shell:

     

    New-WebServicesVirtualDirectory –WebSiteName “Default Web Site”

     

             c.   Do an IISreset /noforce

     

    Thanks,

    Simon

    Monday, July 18, 2011 1:57 AM
    Moderator
  • In my case it was misconfiguration of bindings of the default web site. It should handle all requests regardless of domain name. The above named request returned in my case HTTP status 584 with text "Ews is not found on OWA server". The server receives OWA request, and than uses HTTP to proxy this request to EWS. Which it probably does without a hostname.

    Monday, November 4, 2013 9:23 AM