locked
'File is already' open error in Excel, recent problem with ddeexec RRS feed

  • Question

  • We are getting an increasing frequency of errors when opening Excel files at my company.  Our employees all use W7 SP1 32-bit and Office 2010 Pro Plus.  We store files on a Windows 2008 R2 SP1 File server.  The errors have occurred a lot in the last 2-3 weeks, but weren't a problem before then as far as we know.

    The error we are seeing is when you double-click to open an Excel file, you get the following message: "<file name> is already open.  Reopening will cause any changes you made to be discarded.  Do you want to reopen <file name>?"

    • When you open Excel first and then open the Excel file, the error message does not occur. 
    • If you have Excel open and double-click the file to open it, the error message does not occur. 

    This only occurs when Excel is closed and you double-click the file to open it.  There appears to be an issue with 'dde'

    If you click 'Yes' to the error, the file will reopen and you can make edits normally & save changes.  This error doesn't happen with all Excel files on our network.  I think it may have to do with linked data.  Some of these Excel files look up to data on an Access database, for example.  The database itself isn't 'open' by any user and neither is the Excel file.  This isn't a 'file in use' problem.

    I can hack the registry (see below) to get the error to go away (removing dde), but I'm looking for a more sustainable fix.  How do I get these errors to stop popping up? 
    I have tried Repair install of Office on a few machines with no success.  When the issue occurs on a particular file, you can reproduce it on a different client.  That is, it doesn't seem to be client-specific although you can 'fix' it by changing how files open on the client machine.  Again, this has been an error we are seeing a lot in the last 2-3 weeks.

    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open]
    @="&Open"
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\Office14\\EXCEL.EXE\" /e \"%1\""
    "command"=-
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec]

    Friday, December 20, 2013 6:26 PM

All replies

  • Hi

    Perform the following steps to check the issue:

    • Click the File tab, and then click Options.
    • Click Advanced, scroll down to the General section, and then clear the Ignore other applications that use Dynamic Data Exchange (DDE) check box in the General area.
    • Click OK.

    In addition go to My Computer, Tools, Folder Options, File Types, found XLS, clicked Advanced, selected Open and clicked Edit. You would find a "%1" at the end of the "Application used..." command line. If so, remove it.

    Tylor Wang
    TechNet Community Support

    Monday, December 23, 2013 7:28 AM
  • The "Ignore applications that use DDE" checkbox was already cleared.  Just to see what would happen, I tried selecting it and it gives this error when I try to open the file:

    There was a problem sending the command to the program.

    That is, if the "Ignore apps that use DDE" checkbox is selected, the file doesn't try to open twice, but it gives the above error and opens once. 

    (I know this isn't what you asked me to do, but I wanted to give you this information in case it was of any help.)

    ---------

    I am using Windows 7 and the File Types tab from Folder Options does not exist in W7.  I did dig into the registry and adjusted the Open command for .xlsx files and removed "%1" as a test.  This allowed me to open the file with no errors.

    Working registry entry:

    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]

    @="\"C:\\Program Files\\Microsoft Office\\Office14\\EXCEL.EXE\""


    I also tried replacing "%1" with /dde.  This also allowed me to open the file with no errors.

    Alternative working registry entry:

    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\Office14\\EXCEL.EXE\" /dde"

    This still doesn't fix the root of the problem.  This only started happening 3-4 weeks ago and the only fixes we've found so far are registry edits.  I'd rather not have to push out these registry hacks to the entire company.  The root problem needs to be addressed! 


    UPDATE:  the /dde didn't appear to permanently fix anything > Excel reverted back to having %1 at the end of the registry key
    Thursday, December 26, 2013 5:30 PM
  • I tested opening the file from a backup from before the issue was reported.  The issue still occurs.  So, the changes that make this a recent issue must have been updates to our systems / file servers. 

    Any ideas, or am I going to have to deploy the registry hack via GPO?

    Tuesday, January 7, 2014 10:34 PM
  • Any news on that problem?

    We experience the same errors in our company. We have a file server on win srv 2012. we had opened a case with microsoft and they gave a solution on the client side registry. It seems that resolved the problem for some time but not permanently because new pc's have the same problem.

    What did you do in your case to resolve the problem? Did you only implemented the registry edit you mentioned?

    thank you 

    Friday, June 3, 2016 11:03 AM