none
dpm 2010 exchange 2010 backups are failing RRS feed

  • Question

  • Hi, I'm getting an error which does not seem to match in the DPM 2010 ID codes. Randomly, I have backups of an exchange 2010 DAG that are failing. The backup will run for a short time (5mints..up to 10minuts) and then will fail with the following error:

    Type: Recovery point
    Status: Failed
    Description: Backup failed as another copy of 'user' database is currently being backed up. (ID 32628 Details: Internal error code: 0x80990D51)
     More information
    End time: 4/25/2011 10:37:27 PM
    Start time: 4/25/2011 10:26:55 PM
    Time elapsed: 00:10:31
    Data transferred: 0 MB
    Cluster node -
    Recovery Point Type Incremental Sync
    Source details: 06001
    Protection group: EXCH2010 - 06001

    I've tried restarting the DPM server to troubleshoot. I say this happens randomly because I've had some backups successfully complete against the same exchange server. The only other item that seems odd is when creating protection groups against the DAG, the intial lookup seems to take forever. Not sure what to try next. 

    • Moved by MarcReynolds Tuesday, April 26, 2011 12:37 PM (From:Data Protection Manager)
    Tuesday, April 26, 2011 7:02 AM

Answers

  • Hello,

    As DPM relies on the exchange writer to take the snapshot for the backup, if the backupinprogress flag is set to true and it does not seem get out of this state even when there is no actual backup in place, then at this point DPM is the victim.

    As far as I am aware the only way is to clear that flag is to:
    a.) Reboot the exchange server
    or
    b.) Restart the information store

    In some cases even:
    1.) Either Activate all other databases on another Node except for the Problem Database, and Dismount the Problem database temporarily
    Or:
    1.)Dismount all Databases on this Node including the problem database
    2.)Restart the Exchange Information Store Service.
    3.)Mount any dismounted databases

    You may want to redirect this question below to the exchange 2010 forum of:

    "if the backupinprogress is set to true when it should be set to false as there really is no backup being taken, then how can I reset it without having to perform:
    a.) reboot of exchange
    b.) restart of the information store"

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/threads


    Regards, Shane. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 9, 2012 1:05 PM
    Moderator

All replies

  • Hello John,

    When this happens, if you go to the exchange server and from within the exchange management shell type: Get-MailboxDatabase 'DBName' -Status |fl
    Does this show the "BackupInProgress" flag set to true or false?


    http://technet.microsoft.com/en-us/library/bb124924.aspx

    Thanks
    Shane

    Tuesday, April 26, 2011 2:01 PM
    Moderator
  • Yes, on the backups that have failed it shows that "BackupInProgress" flag is set to "True". On backups that seem to be working the "BackupInProgress" flag is set to "False"

     

     

    Tuesday, April 26, 2011 4:59 PM
  • RESOLVED.

    I ended up rebooting the exchange nodes to resolve the issue. This changed the "BackupInProgress" flag to false. Thanks for your help!


    Wednesday, April 27, 2011 1:00 AM
  • Is there a better solution than rebooting or restarting the information store?  Can I force the flag to false?

    Also in addition to a few databases, I always seem to get an error with System State backup at the same time.

    "DPM cannot create a backup because Windows Server Backup (WSB) on the protected computer encountered an error (WSB Event ID: 521, WSB Error Code:  0x807800A1). (ID 30229 Details: Internal error code: 0x809909FB)"

    Thanks

    Gary

    Tuesday, May 24, 2011 2:36 PM
  • Hi there,

    I'm also experiencing the same issue and rebooting the exchanger server is not ideal.

    Is there a way to change the backup flag status from True to False without rebooting or restarting the information store?

    thanks in Advance,

    Russ

    Thursday, March 8, 2012 11:14 AM
  • Hello,

    As DPM relies on the exchange writer to take the snapshot for the backup, if the backupinprogress flag is set to true and it does not seem get out of this state even when there is no actual backup in place, then at this point DPM is the victim.

    As far as I am aware the only way is to clear that flag is to:
    a.) Reboot the exchange server
    or
    b.) Restart the information store

    In some cases even:
    1.) Either Activate all other databases on another Node except for the Problem Database, and Dismount the Problem database temporarily
    Or:
    1.)Dismount all Databases on this Node including the problem database
    2.)Restart the Exchange Information Store Service.
    3.)Mount any dismounted databases

    You may want to redirect this question below to the exchange 2010 forum of:

    "if the backupinprogress is set to true when it should be set to false as there really is no backup being taken, then how can I reset it without having to perform:
    a.) reboot of exchange
    b.) restart of the information store"

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/threads


    Regards, Shane. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 9, 2012 1:05 PM
    Moderator
  • This is a new answer to an old post, but I've found that performing a switchover to another copy of the DB in the DAG clears the issue for me and DPM starts running again.

    This is with Exchange 2010 SP1 UR6.

    • Edited by ChrisinSF1 Thursday, August 2, 2012 2:56 PM
    Thursday, August 2, 2012 2:55 PM
  • I had this problem once and i solve it by restarting DPMRA service on the DPM server.

    Please check that and get back to me.

    ___________________________________________

    If you found this helpful please mark it as an answer


    ITLAAL

    Tuesday, August 7, 2012 12:35 PM
  • A solution which does not require a restart and it works.

    Use Windows Server Backup and start a backup of the Exchange database file. Once the backup starts cancel it this will set the BackupInProgress to false. Now use your regular backup software and run the backup job again.

    • Proposed as answer by Allowishes8 Thursday, October 3, 2013 4:22 AM
    Thursday, September 5, 2013 11:17 AM
  • Can you elaborate, like with which options you chose to do this? and how long you waited to cancel.
    Monday, December 16, 2013 7:55 PM
  • Hi

    Perhaps I have been slightly stupid (although I was following a guide), in that I have configured a protection group that protects my DAG (consisting of two multirole mailbox and cas servers) hosting one mailbox database between them.

    I have a full backup on one and a copy backup on another and also a 4 hourly sync job running on the DAG with a night full express backup that occurs at 20:00pm.  Would this conflict with the 4 hourly syncs, one of which would also run at 20:00pm and cause this error too? The guide recommended I set my Exchange DAG protection group up in this way and as I am new to Exchange I did not question this at the time!

    Any opinions would be greatly appreciated.

    Wednesday, February 26, 2014 5:44 PM
  • Hi There,

    No need to reboot exchange server, Activate secondary copy of database , this will automatically set the "BackupInProgresss to false". And rerun your backup jobs .

    regards,

    Sandeep KM

    Friday, September 12, 2014 7:42 AM
  • A solution which does not require a restart and it works.

    Use Windows Server Backup and start a backup of the Exchange database file. Once the backup starts cancel it this will set the BackupInProgress to false. Now use your regular backup software and run the backup job again.

    Thanks for this advice.  I know this is an old post, however we ran into this and Narayan's suggestion was quick, easy and it worked.  Nice little trick and avoids any downtime.
    Thursday, November 6, 2014 6:18 PM
  • Hi There,

    No need to reboot exchange server, Activate secondary copy of database , this will automatically set the "BackupInProgresss to false". And rerun your backup jobs .

    regards,

    Sandeep KM

    I know this is an old post, but I came across it having encountered this issue very recently. 

    Sandeep's suggestion above worked for me, and meant no need to reboot the exchange server.  Our exchange guy to switch the DB to a different server, and this cleared the issue and backup ran ok.

    Thursday, August 20, 2015 10:18 AM