none
FAST Search document preview wont work RRS feed

  • Question

  • We have the following:

    1. SharePoint 2010 Application Server

    2. FAST Search 2010 Server

    We have had Office Web Apps installed on Application server prior to setup of FAST Search server and it works fine. When searching in FAST, we get View In Browser link under results links. We also have enabled Enable Document Preview for Powerpoint and Enable Thumbnail Preview for Word under Search Core Results web part.

    Still no document previews in results. Are we missing something? Do we need to install Office Web Apps on FAST Search server as well?

    Any help is well appreciated.

    • Moved by hsalviMicrosoft employee, Moderator Wednesday, August 11, 2010 6:48 PM Moving to right Product Forum (From:SharePoint 2010 - Setup, Upgrade, Administration and Operation)
    Tuesday, August 10, 2010 3:03 PM

Answers

All replies

  • I assume that you also have SilverLight installed on your client machine as well?

    Twitter: @michalpisarek
    Tuesday, August 10, 2010 10:30 PM
  • Yep, we do. We can also edit docs online so we know that Office Web Apps are installed and working just fine. Do we need to re-run anything on the SharePoint 2010 sever itself after installing FAST Search server?
    Tuesday, August 10, 2010 10:37 PM
  • In the same boat.  I hope someone can answer this.  I have installed FAST previously and did not have this problem.

    Thanks,

    Craig

    Wednesday, August 11, 2010 6:10 PM
  • Hello Zgembo,

    If you click on View on Browser link does document opens in Browser?


    Reagrds,

    Hiran
    Microsoft Online Community Support

    Wednesday, August 11, 2010 9:32 PM
    Moderator
  • Yes it does. I can also edit it and save it.
    Wednesday, August 11, 2010 9:44 PM
  • Did you ever find a solution to this?  If so, could you post the solution?  I am still struggling with the same problem.

     

    Tuesday, August 17, 2010 3:43 PM
  • I don't know what the issue is but I've gotten this to work on several installs (knock on wood). What I did was I installed SP 2010 and when I got to the wizard at the end, I closed it. I then installed office web apps and ran the wizard at the end of that install instead.

    I also had to activate the office web apps feature in all my FAST search center sites.

    Sometimes it takes a while for the previews to pop up. It appears to be asynchronous from everything else.

    Tuesday, August 17, 2010 7:28 PM
  • So does anyone recommend running SharePoint 2010 Products Configuration Wizard once more on a production "farm"? So far that is the only thing that we have NOT tried. Please advise.
    Thursday, August 19, 2010 1:24 AM
  • You shouldn't have to do that. That's just what's recommended with a new install and that's what I did.

    I'm pretty sure you can activate it after installing SP 2010, you may just have to do some extra steps. I remember reading something on a MS site about how to set it up with an existing SP 2010 install. I don't have the link handy.

    Thursday, August 19, 2010 12:47 PM
  • Hi Zgembo,

    If you have not run configuration wizrad after installing Office Web Apps I would Recommend you to run them. also make sure that you have service application's Created for Word & Powerpoint Services. also verify that you have Service Application Proxy associated with Web application where you have Fast Search Center Created.

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Thursday, August 19, 2010 1:55 PM
    Moderator
  • Although this isn't my thread, I am having what appears to be the exact problem as Zgembo.

    I have rerun both wizards, the Sharepont configuration wizard and the Farm configuration wizard.

    OWA has been installed and everything appears to be working EXCEPT the document preview.  Search core results web part have the Powerpoint and Word preview properties enabled.

    http://yfrog.com/f/5cemnp/

    From the screenshot below, you can see that View in browser is being displayed and works correctly (displays in browser), but the previews for powerpoint and word are not showing.

    Help!

    Thursday, August 19, 2010 6:21 PM
  • I have the same problem as well on my FAST install.  I guess I will try running the configuration wizard as well, but it sounds like that may not help.
    Corey Roth blog: www.dotnetmafia.com twitter: @coreyroth
    Wednesday, August 25, 2010 4:33 AM
  • I would also try to Recreate Fast Search Center after ensuring that Office Web Applications is installed and working as expected to see if that makes any diffrence.
    Reagrds,

    Hiran
    Microsoft Online Community Support
    Saturday, August 28, 2010 7:18 PM
    Moderator
  • Here is a weird thing, dang thing just started working on its own. Well, not fully...it only shows document previews from one particular collection and not others. Really, I have no clue what made it work...nor do I have any clue why only results from one site collection are showing.

    Its a nice feature but there should really be some documentation that explains how thumbnails are created or how to troubleshooting if it does not work. Here are few questions for people familiar with this subject:

    What triggers creation of thumbnails?

    Why do document previews only show for results from one particular collection?

    Any ideas?

    Monday, August 30, 2010 2:42 PM
  • To get mine to work I opened one of the documents in the browser, clicked Edit in Browser then File - Close. Previews then started appearing.
    Wednesday, September 1, 2010 3:58 AM
  • Are you using HTTPS on any of the web applications? If so you'll need to add the SSL cert to SharePoint via Central Admin > Manage Trust.
    Tuesday, November 2, 2010 6:06 AM
  • I would like to add that I am experiencing the same issues.

    I am currently able to open and edit PowerPoint/Word documents within the browser, however, I do not see thumbnails in my search results.

    I have checked the Search Core Results Web Part and have enabled both options:

    • Enable Document Preview for PowerPoint
    • Enable Document Preview for Word

    I've also re-run the Configuration Wizard and have re-indexed and re-ran a full crawl several times.

    Upon close examination with Fiddler, I noticed that I get the following error when the client tries to load the preview image from /_vti_bin/wacproxy.ashx:

    ('ERROR:603:WebException - The remote server returned an error: (401) Unauthorized.');

    I have given the FAST Search Query service account farm-level priveleges and still nothing.

    Can someone please assist?

    Tuesday, January 18, 2011 12:00 AM
  • The steps below will assist in identifying why Document preview/thumbnails do not appear:

     Check the following if/when Document Preview/Thumbnails not appearing in search.

    1.                   WAC is installed and working on WFE servers

    2.                   Content has been crawled from a WAC-enabled farm

    3.                   Confirm that the managed property/field “serverredirectedurl” has the correct value. Use a qrserver search to retrieve value from "serverredirectedurl" field then paste value in a web browser. Document should render/view in browser)

    4.                   Validate that “view in browser” links on the result page

    5.                   Check the ULS logs on server running SharePoint Search Service (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS), for any information related to ”wacproxy”.

    6.                   Use fiddler (http debugger) utility to validate that all requests for wacproxy.ashx have  HTTP status 200 (OK)

    7.                   Verify that these two services are running on all the sharepoint servers

    a.                   Word Viewing Service

    b.                   PowerPoint Service

    8.                   Verify that doc preview and/or thumbnail  preview is enabled in the core results webpart on the search result page.

    9.                   Validate that under “configure service application associations”, the FAST SSA , the word and powerpoint service application are associated to the web application.

    10.        Validate that search site is not using HTTPS (Note: for sites using https there is a known bug that has been fixed in the December Cumulative Update) http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2459257

    -Brent

    Brent Groom | Microsoft Enterprise Search

    FAST Search Server 2010 for SharePoint - Survival Guide | FAST Search for SharePoint Forum

     

    Wednesday, March 16, 2011 4:42 PM
    Moderator
  • Dear Brent:

           I have same problem.

           I follow your guide.In step 6, I find wacproxy.ashx have HTTP status 401. How to solve the problem?

           Thank you.

    Tuesday, March 22, 2011 1:03 PM
  • Hi Brent,

     

    Thanks for these helpful steps.  When I get to step 6, I see a bunch of 401 and 302 statuses for requests to wacproxy.ashx. The 302 seems to refer to "Object reference not found" error page.  I have disabled loopback check on the WFE and App servers and all other aspects of OWA work e.g. View in Browser etc.

     

    Any ideas?

    Augustine

    Tuesday, March 22, 2011 5:04 PM
  • Hello Augustine and Tommy,

    What is the result of steps 7,8,9, and 10?

    Thanks,

    Brent

    Brent Groom | Microsoft Enterprise Search

    FAST Search Server 2010 for SharePoint - Survival Guide | FAST Search for SharePoint Forum

    Wednesday, March 23, 2011 11:02 PM
    Moderator
  • I'm sure step 7,8,9 are right.

    step 10 ,my site not use https.

    thanks.

    Thursday, March 24, 2011 3:14 AM
  • Hey guys, just wanted to throw this out there.  We have the same issue you are having, we are also on for the last few days with the senior Microsoft FAST Search escalation team trying to fix it.

    We are now looking at the NLB, as a possible cause and testing through it today.

    If we find anything we will make sure we post it here.

    Thanks,

    Chuck

    Thursday, March 24, 2011 1:41 PM
  • Thank you for the reply Chuck. I would recommend that as the next step as well for Augustine and Tommy. Please open a support ticket and work with one of the escalation engineers.

    Thanks,

    Brent

    Brent Groom | Microsoft Enterprise Search

    FAST Search Server 2010 for SharePoint - Survival Guide | FAST Search for SharePoint Forum

    Thursday, March 24, 2011 3:53 PM
    Moderator
  • We have the same results as Tommy (7-10 have validated as expected).  We also opened a support ticket.  Hopefully our engineers are collaborating with each other ;)
    Thursday, March 24, 2011 7:45 PM
  • Thank you Brent and Chuck.
    Friday, March 25, 2011 3:24 AM
  • We are also having this issue. Went through the steps described by Brent, but still no previews.

    In the ULS Log on the web front end server I get the error message below:

    System.Data.SqlClient.SqlException: Procedure or function 'proc_putSiteMap' expects parameter '@Path', which was not supplied.
    at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
    at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
    at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
    at System.Data.SqlClient.SqlDataReader.ConsumeMetaData()
    at System.Data.SqlClient.SqlDataReader.get_MetaData()
    at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
    at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
    at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
    at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)
    at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)
    at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior)
    at Microsoft.SharePoint.Utilities.SqlSession.ExecuteReader(SqlCommand command, CommandBehavior behavior, SqlQueryData monitoringData, Boolean retryForDeadLock)

    followed by:

    The cache for the SPWebApplication 'OCI Documents' (http://documents-t.ocinitrogen.com/) could not be created due to an internal error. Performance will be degraded until this issue is resolved. Error: (System.NullReferenceException) Object reference not set to an instance of an object.

    Seems that procedure is called without a parameter, preventing the cache to be populated. This could be a cause of the previews not showing.
    Have you encountered this error message as well?

    Monday, March 28, 2011 11:24 AM
  • Ok, after a lot of tagging back and forth I was with the head of the Microsoft Escalation Team, and we all finally figured it out together.

    Disable Loopback was the key; http://support.microsoft.com/kb/896861

    We applied Method 2, and it fixed our issue.

    Let me know if this works for you.

    Chuck


    Monday, March 28, 2011 12:35 PM
  • I have loopbackcheck already disabled.
    So for me this KB is not the solution to the problem.

    See my previous post in this threat for the error message I get.

    Monday, March 28, 2011 12:39 PM
  • Are you 100% that it is method 2 and not 1?
    Monday, March 28, 2011 12:51 PM
  • Yes , I'm 100% sure.
    Checked the registry before posting my response.

    Chuck, did you see the error in the ULS Log as i've described?

    Monday, March 28, 2011 12:53 PM
  • Can you lay out your environment, and how much customizations have been done in your environment?
    Monday, March 28, 2011 1:09 PM
  • I'm testing SharePoint with Test on a test environment.

    1 Hyper-V server, hosting 1 SQL Server, 1 SharerPoint Application server and 1 Web front End.
    All server are on the same network subnet, and in the same Domain.
    For Testing purpose , FAST and Office Web Apps are installed on the application server.

    Servers are running Windows 2008 Server R2.
    SQL Server is SQL Server 2008 R2 Enterprise.
    SharePoint is 2010 Server Enterprise.

    the servers form 1 SharePoint Farm, no customizations other than layout.

    All functionality of Fast & office Web Apps is working fine, it's just the previews that are not working.

     


    • Edited by M. Sogelee Monday, March 28, 2011 1:44 PM Added Server OS
    Monday, March 28, 2011 1:20 PM
  • Ok, you know that FAST Search should be running on its own server correct.

    Also is this for SSL Enabled Communication, and is this Kerbros or NTLM?

    And finally, can you run through how your FAST Search Certificates were installed?

    Was your FAST Search set up as a Admin or Single Node?

    Is this something simular to how you set yours up; http://blogs.msdn.com/b/spses/archive/2010/04/09/installation-and-configuration-of-fast-search-server-for-sharepoint-2010.aspx

    Monday, March 28, 2011 3:51 PM
  • Just as an update with our MS Support ticket, they think there may be a product bug when you've applied the February CU and are using claims-based authentication.  When we set up a separate web app using classic NTLM authentication, the previews popped right up.  We had already disabled loopback (per Chuck's fix) and it did not fix our problems.
    Monday, March 28, 2011 5:31 PM
  • It's right. I had try two ways.

    Preview can work using classic NTLM,but not work using claims.

    Tuesday, March 29, 2011 6:56 AM
  • I know that FAST should run on its own server.
    Due to hardware limitations im forced to test it this way.

    Authentication is done using Kerberos, and no SSL Communications between SharePoint and FAST.
    FAST is installed as a single node.

    Loopbackcheck has been disabled on both SharePoint servers.

    I've have enabled a team site to use NTLM instead of Kerberos, but still not previes.
    The FAST Search Center web application is also reconfigured to use NTLM.
    But still no previews.


    Tuesday, March 29, 2011 12:51 PM
  • Having this run on the SharePoint 2010 Server is not supported as per the hardware & software requirements.  From everyone I have talked to said it will not work in this configuration.

    http://technet.microsoft.com/en-us/library/ff381239.aspx

     

    Tuesday, March 29, 2011 1:46 PM
  • Hi,

    I have also an issue with SSL enabled :

    • The document preview appears very rapidly and on all Word and PowerPoint documents without SSL.
    • Once i configure the SSL on the search page, the preview works also but they appears very very slowly and only for some documents. When i'm doing a page refresh, the previews appears on other document, very randomly.

    Is anyone have similar issue ?

    (My front-ends are behind an big-ip F5 in load-balancing mode)

    Best regards,

    Thursday, April 14, 2011 7:34 AM
  • Hi Raphael

    I recommend that you start a new thread, rather than tacking on to an already very long one. Instead, include a url to this thread, to indicate you've tried all the steps here.

    Anyway, to your question: You have applied the December 2010 CU?

    http://social.technet.microsoft.com/wiki/contents/articles/fast-search-for-sharepoint-cumulative-updates.aspx

     

    Regards


    Thomas Svensen | Microsoft Enterprise Search Practice
    Thursday, April 14, 2011 12:46 PM
    Moderator
  • Make sure that the OWS Service Accoun has access to the content databses that contain the content you indexed.  This is the most common resolution to his problem.

    Chris Givens


    Chris Givens CEO, Architecting Connected Systems Blog Twitter
    Saturday, June 4, 2011 9:35 PM
  • Chuck, disabling loopback could be ok for dev environment but it's highly recommended not to do it on production. how do you handle this on the production server? thanks
    Wednesday, October 26, 2011 6:58 PM
  • is this the final solution for this? again it's not recommended on production environment. I'll appreciate if you share the knowledge
    Wednesday, October 26, 2011 7:05 PM
  • is this the final solution for this? again it's not recommended on production environment. I'll appreciate if you share the knowledge

    some body started the Word Viewing Service and PowerPoint Service on the WFEs but didn't help in my case.
    Wednesday, October 26, 2011 8:39 PM
  • Hello,

     

    This was an issue we experienced at several clients and one of our environments. In all cases the web applications which the previews did not work on were SSL-Enabled (HTTPS).  In one case we were dealing with claims auth as well, which seemed to add to the problem.

     

    Long story short, this was a known issue (had to open a case with MS). The issue was resolved in SharePoint 2010 SP1 . Please try downloading the service pack from here: http://support.microsoft.com/kb/2460045 . Ensure that you also download and install at least the June 30 2011 cumulative update as well (also found in that link).

     

    Thursday, October 27, 2011 2:50 PM
  • Hi All,

    Am using claims authentication, browser is IE 9, Search core web part is enabled with required settings, the fast search is giving results but not with the features such as view in browser,thumbnail,doc preview etc)

    Regards,

    Ananth.R.


    Ananth

    Friday, December 28, 2012 10:38 AM
  • In continuation to my previous details...the OWA is installed after fast searching is working fine, recrawled etc.

    Ananth

    Friday, December 28, 2012 10:39 AM