none
MDT - The network path was not found RRS feed

  • Question

  • Hi guys,

    So basically for the past 3/4 weeks I have been struggling to resolve this error, and I really need help to find a solution for it.

    I am using Windows Server 2008 R2. 

    I am using Microsoft Development Toolkit (MDT) along with Windows Deployment Services (WDS) and using these I am trying to PXE boot PC's to deploy Windows 7 OS's. 

    Now, when I PXE boot the PC, this is successful as it picks up my servers ip address and assigns the PC with an IP address of its own through the scope I created within DHCP. However, the problem starts to occur when the PXE boot gets to the Win PE screen. 

    This is where I am promoted to enter the user credentials which are the user, password and domain name related to the Deploymentshare. When I try enter the credentials I am given the error:
    Invalid Credentials: Network path was not found

    In WinPE if I press the F8 and bring up command prompt, I am unable to ping the ip address where my deployment share is, and the ip address shown from WinPE is incorrect, so i am getting pretty confused on why this is happening. 

    Furthermore, all this is done using VMWare, when I add a network card and connect the machine to my host internet connection, then when entering the same user credentials I am able to get past this error, but this is not what I want as I shouldn't have to connect to the host connection to get past this.

    Does anyone have any ideas or solutions please, I really need to solve this!

    Thank you,

    Danyaal

    Saturday, February 25, 2017 11:52 PM

Answers

  • Hi Danyaal,

    You say "my own network configuration" and "my host PC internet connection",  are you deploying to a virtual machine on your PC?   

    If the Deployment share's default gateway or server doesn't know that the route to "my own network configuration" is via your PC's IP address then the packets from the deployment share to target machine won't get there.

    If your PC is on the same subnet as the deployment share's machine, adding the appropriate route directly on the deployment share's server will be a quick and dirty fix/test.

    Better is that your virtual machine present as a second mac address on the same interface as your host PC so that your Ethernet has two IP addresses on the same subnet (one for the host and one for the virtual).   No network changes required :-)

    • Marked as answer by Danyaal1996 Friday, March 3, 2017 3:10 PM
    Friday, March 3, 2017 12:38 AM

All replies

  • Hi

    Your problem seems like a network related issue.

    Do you get a real IP or a 169.x.x.x ??

    Do you have a firewall between your client and server?

    Do you have any clients that are working?

    Kind regards
    Per Larsen
    Microsoft MVP - Enterprise Mobility
    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Sunday, February 26, 2017 8:17 AM
  • Try the long version of your domain name (FQDN) rather than the short version (NetBIOS).

    i.e. MyDomain.com or MyDomain.local rather than MyDomain

    My speculation: might be NetBIOS no longer enabled by default in WinPE? or Routing issue (ip-helper address) in your network.



    • Edited by GregAtBass Monday, February 27, 2017 1:13 AM
    Monday, February 27, 2017 1:09 AM
  • Hi

    Your problem seems like a network related issue.

    Do you get a real IP or a 169.x.x.x ??

    Do you have a firewall between your client and server?

    Do you have any clients that are working?

    Kind regards
    Per Larsen
    Microsoft MVP - Enterprise Mobility
    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Hi Per, 

    Thanks for your response. I am not getting a real IP address its usually a 192.xx..xx.. however its not one that I have seen on my host connection or anywhere else, sometimes when I have tried a /release /renew command I also get a 169.xx.xx ip address

    In terms of the firewall, I have turned them all off. 

    I have one client which successfully deployed but this was only because I used my host internet connection, I'm assuming because my internal VMWare connection within MDT isnt an active internet connection this could be an issue? 

    Any further ideas would be greatly appreciated guys :)

    Monday, February 27, 2017 9:36 PM
  • Try the long version of your domain name (FQDN) rather than the short version (NetBIOS).

    i.e. MyDomain.com or MyDomain.local rather than MyDomain

    My speculation: might be NetBIOS no longer enabled by default in WinPE? or Routing issue (ip-helper address) in your network.



    Do you mean entering the FQDN in the bootstrap.ini file or in the user credential screen on Win PE when I'm trying to PXE Boot, if so I have tried both those and still getting the same issue. 
    Monday, February 27, 2017 9:39 PM
  • I had a second look at your original post and paid more attention this time. :-)

    It definitely looks like a DHCP/Network/Routing/Helper-ip address issue.

    Per is on the right track.

    Can a prebuilt machine get a dhcp address and mount the share on that VMware switch/subnet?

     You will need to be able to mount the deployment share by hand at the prompt

    I.e.  net use * \\server\share /user:username

    Monday, February 27, 2017 10:25 PM
  • I meant at the user credential screen, but see my post above and ignore the following until you are sure the network configuration is sorted.

    If I am following you correctly, adding the following to customesettings.ini (aka rules) should pre-populate the domain, all you should need to add is the username and password.

    Joindomain=Mydomain.com.au

    In Deployment Workbench, check the general tab on the properties of your share.  Make sure there is no typo in "Network (UNC) path" field.  

    You should also "Update the deployment share".
    It will generate a boot file that will be in the boot directory of your deployment share.
    Search deployment share for *.wim and sort by modified date to find it.
    Replace your current WDS boot file with the resulting WinPE "WIM" file (possibly LiteTouchPE_x??.wim)

    Monday, February 27, 2017 10:27 PM
  • Hi Greg, 

    Upon creating a new VM with no OS installed, during the PXE boot it CAN obtain the dhcp from the scope I have set on my domain controller, HOWEVER once it gets to the Win PE screen I have tried the new use command in the prompt and I got the error message of 'network path was not found'. 

    -----------------------------------------------------------------------------------------------------------------------------------------

    In terms of your second reply, 

    Do you mean the UNC path should be left blank? As I believe I have also tried this and got the same result, I have completely regenerated the share before when making changes to the workbench properties and adding the latest boot file which is the LiteTouchPE as you

    I really don't understand the problem anymore and I've been trying for 3/4 weeks now, could it be to do with not having an internet connection as I don't have one, just static ip address and a subnet which I manually assigned to my domain controller. 

     

    Tuesday, February 28, 2017 2:01 PM
  • Maybe try using the IP address instead of the domain name in the net use command? Perhaps DNS is not setup properly. 

    Also, what adapter type are you using in vmware? vmxnet3 or E1000?

    Regards,

    DLofstedt

    Tuesday, February 28, 2017 7:31 PM
  • You need to ensure network connectivity as step number 1.  Ping may be blocked by firewall, but if you can't mount the deployment share at the winPE stage, you won't get anywhere.

    Try connecting to an admin share  e.g. C$ of the server with the deployment share on it.  Can you do something like the following when breaking out to the dos prompt? 

    PS C:\> net use * \\192.168.44.30\c$
    The password is invalid for \\192.168.44.30\c$.
    Enter the user name for '192.168.44.30': bass\admin-greg
    Enter the password for 192.168.44.30:
    Drive Z: is now connected to \\192.168.44.13\c$.
    The command completed successfully.
    PS C:\>

    Note: Domain, IP addresses and login details altered in example.

    Tuesday, February 28, 2017 10:03 PM
  • Maybe try using the IP address instead of the domain name in the net use command? Perhaps DNS is not setup properly. 

    Also, what adapter type are you using in vmware? vmxnet3 or E1000?

    Regards,

    DLofstedt

    Hi,

    Thanks for your reply, I have just tried using ip address instead of domain name in the net use command however no luck, still cannot mount the deployment and winPE won't recognise a path.

    My network adapter is showing up as Intel(R) Pro /1000 MT, so im assuming this is the E1000? 

    Wednesday, March 1, 2017 2:17 PM
  • You need to ensure network connectivity as step number 1.  Ping may be blocked by firewall, but if you can't mount the deployment share at the winPE stage, you won't get anywhere.

    Try connecting to an admin share  e.g. C$ of the server with the deployment share on it.  Can you do something like the following when breaking out to the dos prompt? 

    PS C:\> net use * \\192.168.44.30\c$
    The password is invalid for \\192.168.44.30\c$.
    Enter the user name for '192.168.44.30': bass\admin-greg
    Enter the password for 192.168.44.30:
    Drive Z: is now connected to \\192.168.44.13\c$.
    The command completed successfully.
    PS C:\>

    Note: Domain, IP addresses and login details altered in example.

    Hi Greg, 

    No luck unfortunately, soon as I tried the first line of the command  net use * \\192.168.44.30\c$

    I got the same error, 'The network path was not found'. 
    I was just wondering.... I have managed to get the deployment to work when using 2 network adaptors, one with my own network configuration, and one with my host pc internet connection. Upon PXE boot, it gets the DHCP from the correct scope and loads into WinPE like it should, and this way it even gets past the user credentials section, I have managed to successfully deploy like this, and in DHCP setting the correct ip address has shown up. Which suggests to be that, maybe I am unable to find the network path due to not having an internet connection on my main network config (one I manually set). 

    Wednesday, March 1, 2017 2:33 PM
  • Hi Danyaal,

    You say "my own network configuration" and "my host PC internet connection",  are you deploying to a virtual machine on your PC?   

    If the Deployment share's default gateway or server doesn't know that the route to "my own network configuration" is via your PC's IP address then the packets from the deployment share to target machine won't get there.

    If your PC is on the same subnet as the deployment share's machine, adding the appropriate route directly on the deployment share's server will be a quick and dirty fix/test.

    Better is that your virtual machine present as a second mac address on the same interface as your host PC so that your Ethernet has two IP addresses on the same subnet (one for the host and one for the virtual).   No network changes required :-)

    • Marked as answer by Danyaal1996 Friday, March 3, 2017 3:10 PM
    Friday, March 3, 2017 12:38 AM
  • Hi Danyaal,

    You say "my own network configuration" and "my host PC internet connection",  are you deploying to a virtual machine on your PC?   

    If the Deployment share's default gateway or server doesn't know that the route to "my own network configuration" is via your PC's IP address then the packets from the deployment share to target machine won't get there.

    If your PC is on the same subnet as the deployment share's machine, adding the appropriate route directly on the deployment share's server will be a quick and dirty fix/test.

    Better is that your virtual machine present as a second mac address on the same interface as your host PC so that your Ethernet has two IP addresses on the same subnet (one for the host and one for the virtual).   No network changes required :-)

    Wicked! :) 

    No network changes required then as I've seemed to have deployed a couple of machines successfully, connect them to my domain and they show up with correct network settings *thumps up*

    Now moving onto deploying applications, and looking into KMS :)

    Thanks for the help Greg!

    Friday, March 3, 2017 3:10 PM