locked
Word 2010 - Proofing (Thesaurus not installing) RRS feed

  • Question

  • Good Day

    After Deploying Office 2010 Professional Plus on a single client machine, when attempting to review a Word Document using the Proofing Tools, specifically the Thesaurus (English UK or English US), it does not appear to be installed in the Research Bar. 

    When clicking on the pull down arrow to select either the "All Reference Books" or "All Reseach Sites" options, nothing is displayed, as if the Proofing Tools have not been installed. I have attempted to Add/Remove features by uninstalling and reinstalling the All Proofing Tools, repairing Office, uninstalling and reinstalling Office 2010, no joy. The client is running Windows 7 Enterprise Edition.

    The client which is a notebook has a clean installation of both Windows and Office.

    Any comments and assistance would be gladly appreciated.

     

    Thursday, August 12, 2010 12:21 PM

Answers

  • Hi,

    There are several reasons why this issue may occur:

    • The add-in Speller EN-US is disabled.
    • The following entry is in the registry: HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\ProofingTools\1.0\Override\en-US
    • The 'Do not check spelling or grammar' check box is selected.
    • The proofing tools are not installed.

    First, Install the proofing tools.

    1. Click Start->Control Panel->Programs and Features;
    2. Click Microsoft Office 2010, and then click Change.
    3. Click Add or Remove Features, and then click Continue.
    4. Expand Office Shared Features, click the icon to the left of Proofing Tools, and then click Run all from My Computer.

    Second, Enable the Speller EN-US add-in using these steps:

    1. Click File->Options->Add-Ins.
    2. At the bottom, see Manage: COM Add-ins. Click on COM Add-ins and then from the drop down menu select Disabled items. Then click on Go.
    3. In the Disabled Items window, the Addin: Speller EN-US (nlsdata0009.dll) would be listed.
    4. Click on it, then click the Enable button.

    Third, Remove the following registry key from the registry:

    1. Click the Start button, then click Run.
    2. In the open box type REGEDIT, then press the enter key.
    3. Navigate to "HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override"
    4. Delete this key.
    5. Exit the registry editor.
    6. Exit and restart Word

    Forth, Clear the 'Do not check spelling or grammar' check box using these steps:

    1. Click the Review Tab, then click the Set Language button, to the right of Thesaurus.
    2. If there's a check mark next to the option 'Do not check spelling or grammar' , click to clear it.

    Hope it helps.

    • Marked as answer by Jennifer Zhan Friday, August 20, 2010 6:15 AM
    Monday, August 16, 2010 6:34 AM

All replies

  • Hi,

    There are several reasons why this issue may occur:

    • The add-in Speller EN-US is disabled.
    • The following entry is in the registry: HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\ProofingTools\1.0\Override\en-US
    • The 'Do not check spelling or grammar' check box is selected.
    • The proofing tools are not installed.

    First, Install the proofing tools.

    1. Click Start->Control Panel->Programs and Features;
    2. Click Microsoft Office 2010, and then click Change.
    3. Click Add or Remove Features, and then click Continue.
    4. Expand Office Shared Features, click the icon to the left of Proofing Tools, and then click Run all from My Computer.

    Second, Enable the Speller EN-US add-in using these steps:

    1. Click File->Options->Add-Ins.
    2. At the bottom, see Manage: COM Add-ins. Click on COM Add-ins and then from the drop down menu select Disabled items. Then click on Go.
    3. In the Disabled Items window, the Addin: Speller EN-US (nlsdata0009.dll) would be listed.
    4. Click on it, then click the Enable button.

    Third, Remove the following registry key from the registry:

    1. Click the Start button, then click Run.
    2. In the open box type REGEDIT, then press the enter key.
    3. Navigate to "HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override"
    4. Delete this key.
    5. Exit the registry editor.
    6. Exit and restart Word

    Forth, Clear the 'Do not check spelling or grammar' check box using these steps:

    1. Click the Review Tab, then click the Set Language button, to the right of Thesaurus.
    2. If there's a check mark next to the option 'Do not check spelling or grammar' , click to clear it.

    Hope it helps.

    • Marked as answer by Jennifer Zhan Friday, August 20, 2010 6:15 AM
    Monday, August 16, 2010 6:34 AM
  • Hi Jennifer

    Thank you kindly for your responds to my issue and apologies for the delay on my reply.

    I followed all your steps with no joy.

    The Speller EN-US add-in was not even listed under disabled ADD-INNS.

    The registry entry , specifically the Override key did not exist.

    The  'Do not check spelling or grammar' check box is not checked.

    I attempted to reinstall the Proofing Tools once again, no joy. As previously mentioned, it shows as if it is not installed at all.

    Kind Regards

     

    Robin

    Saturday, August 21, 2010 10:19 AM
  • Hi Jennifer

    Thank you kindly for your responds to my issue and apologies for the delay on my reply.

    I followed all your steps with no joy.

    The Speller EN-US add-in was not even listed under disabled ADD-INNS.

    The registry entry , specifically the Override key did not exist.

    The  'Do not check spelling or grammar' check box is not checked.

    I attempted to reinstall the Proofing Tools once again, no joy. As previously mentioned, it shows as if it is not installed at all.

    Kind Regards

     

    Robin

    I have this same problem.  My system did have Office 2007 on it.  After upgrading to Office 2010 spell check will not work and its not related to the configuration options, an addin, or the language settings.  I tried to add nlsdata0009.dll  by hand and I got an error that it wasn't a valid add-in.  I've tried to reinstall office 2010 cleanly and that didn't fix it.  I did a repair installation and it complained that it couldn't find the proof.cab files.  I pointed the installer to the cab files and it stated it was an invalid location.  There's something up with Office 2010 proofing.

     

    Dom

    Friday, March 25, 2011 7:40 PM
  • Hi all,

    I've got the same problem.. proofing tools installed, no plugins disabled,no registry key ,  not working....

     


    x86 office, x64 win7
    Sunday, May 1, 2011 7:00 PM
  • Excuse me but this should not be marked as answered since this solution does not work for this issue! I am facing exactly the same issue and none of these steps helped. Can someone please provide more information on this as I have 10 users who expect Proofing Tools to be installed (for Greek) and there is no explanation or support from Microsoft on why the Greek language Proofing Tools keep appearing as "Not Installed" even after adding it via the Control Panel.

     

    Thank you

    Tuesday, July 5, 2011 8:22 AM
  • Thank you Jennifer. 

    I followed the steps. although some were already completed (step 2,3 &4).. i'm assuming Step 1 was the one that fixed my problem. thanks again

    Tuesday, September 11, 2012 2:45 PM
  • Unfortunately the 4 fixes provided by Jennifer do not work for me either. Running Word as part of Office 2010 (non-commercial version) with Windows 7 Home Premium, 64-bit version. The spelling and grammar checks are fine -- but any word I enter into the Thesaurus returns "No results found. Please search again."

    Is there anything else I can try, other than reinstalling Office?

    Thanks -- Neil.

    • Proposed as answer by PRO V 1 Monday, October 8, 2012 9:30 PM
    • Unproposed as answer by PRO V 1 Monday, October 8, 2012 9:36 PM
    Thursday, October 4, 2012 5:00 PM
  • I had the same issue with windows 7 64 bit. The fix for me was as simple as going into control panal-->Programs--->Programs and features--->Microsoft office prof plus 2010 (right click on it)--->change--->add remove features.--->Expand office shared features---expand proofing tools----> expand english proofing tools--->click the thesaurus dropdown and select run from my computer. When it is complete close it all out and startup word and give it a try.

    Hope it helps

    • Proposed as answer by PRO V 1 Monday, October 8, 2012 9:36 PM
    Monday, October 8, 2012 9:35 PM
  • This worked for me! Thank you much.
    Wednesday, November 13, 2013 7:55 PM
  • It didn't work for me because I already had Thesaurus installed and enabled. However...when I installed "spelling and grammar checkers" suddenly everything is perfect! Make sure to exit and restart open Office applications.

    PCC

    • Proposed as answer by PC Chris Thursday, December 12, 2013 10:27 PM
    Thursday, December 12, 2013 10:26 PM