none
How to enable users to access windows 2012 through remote desktop client on windows XP SP3

    Question

  • Hi I have just installed Windows Server 2012 and trying to give access to the users. The users are on windows XP Pro SP3 remote desktop client (Shell and control version 6.1.7600 with Remote Desktop Protocol 7.0 support). 

    I have enabled the windows server 2012 remote desktop users through "control panel -> systems and security ->  Remote access" for the users. When I try to connect to the windows server as administrator, it is getting connected. But when I try to connect as other users I get the following message.

    "To sign in remotely, you need the right to sign in through Remote Desktop Services. By default members of the Administrators group have this right. If the group you're in does not have the right, or  if the right has been removed from the Administrators group, you need to be granted the right manually."

    Is there any other setting to be done to eanble the Remote Desktop for the users.

    Thursday, February 28, 2013 2:36 PM

Answers

  • Hi I have just installed Windows Server 2012 and trying to give access to the users. The users are on windows XP Pro SP3 remote desktop client (Shell and control version 6.1.7600 with Remote Desktop Protocol 7.0 support). 

    I have enabled the windows server 2012 remote desktop users through "control panel -> systems and security ->  Remote access" for the users. When I try to connect to the windows server as administrator, it is getting connected. But when I try to connect as other users I get the following message.

    "To sign in remotely, you need the right to sign in through Remote Desktop Services. By default members of the Administrators group have this right. If the group you're in does not have the right, or  if the right has been removed from the Administrators group, you need to be granted the right manually."

    Is there any other setting to be done to eanble the Remote Desktop for the users.

    Have you tried adding those users to the "Remote Desktop Users" group? It's in Active Directory Users and Computers and it's a Built-In group. Might want to give that a try ...

    - JJ

    Thursday, February 28, 2013 5:34 PM

All replies

  • Hi I have just installed Windows Server 2012 and trying to give access to the users. The users are on windows XP Pro SP3 remote desktop client (Shell and control version 6.1.7600 with Remote Desktop Protocol 7.0 support). 

    I have enabled the windows server 2012 remote desktop users through "control panel -> systems and security ->  Remote access" for the users. When I try to connect to the windows server as administrator, it is getting connected. But when I try to connect as other users I get the following message.

    "To sign in remotely, you need the right to sign in through Remote Desktop Services. By default members of the Administrators group have this right. If the group you're in does not have the right, or  if the right has been removed from the Administrators group, you need to be granted the right manually."

    Is there any other setting to be done to eanble the Remote Desktop for the users.

    Have you tried adding those users to the "Remote Desktop Users" group? It's in Active Directory Users and Computers and it's a Built-In group. Might want to give that a try ...

    - JJ

    Thursday, February 28, 2013 5:34 PM
  • For more information please see:

    Configure Permissions for Remote Desktop Services Connections

    http://technet.microsoft.com/en-us/library/cc753032.aspx


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, March 06, 2013 6:13 AM
    Moderator
  • I had the same issue. I tried all the ideas I found on the web, including adding users to the remote desktop group. I found that the server manages the users that remote in, and when you try to add the users in the local machine, the users can't be found. In the location section you can't choose the server as the location when attempting to add users. So what I did on the computer I wanted to remote into (mine is windows 7 pro) was go to control panel, user accounts, clicked on User Accounts again, manage user accounts, add. Then I entered the Username and Domain into the boxes. I set the user up as Admin on that computer. Now remote access works for users that are not administrators on the server. I checked and the users set as admin on the local machine can't access the dashboard/server. I didn't try setting the users up on the local machine as standard users. I may try that later.
    Thursday, January 23, 2014 12:45 AM
  • I had the same problem. I installed the role Remote Desktop Service and it began to work with the people in the Remote Desktop policy. My only doubt is if a need to maintain the RD Licensing service and if it has a cost.
    • Proposed as answer by Đàm Thìn Tuesday, February 10, 2015 7:49 AM
    Sunday, May 25, 2014 3:36 PM
  • On the remote machine, go to the Local Group Policy Editor and add the necessary user/group to:

    Computer Configuration/Windows Settings/Security Settings/Local Policies/User Rights Assignment/Allow log on through Remote Desktop Services.

     

    Dan Visan

    • Proposed as answer by Keith Mason Wednesday, September 10, 2014 7:35 PM
    Sunday, July 13, 2014 5:00 PM
  • I am the Enterprise admin. Have been able to login remotely no problemo until Sillysoft decided to update and break it again. Have been logging in with no bigger problems from Win 7 and Win 8 pro PCs until the recent update. Sorry MS cannot handle it anymore. I am going Linux. How much time am I expected to waste per week because of MS created issues?

    Alex Goodside


    Wednesday, September 03, 2014 12:47 PM
  • The group I expected to be here was Remote Desktop Users.  Adding that worked!
    • Proposed as answer by jobianzca Friday, March 20, 2015 2:28 AM
    Wednesday, September 10, 2014 7:36 PM
  • you just try to open RDP as Administrator and try to connect, this will work out.
    Thursday, September 11, 2014 8:28 AM
  • Nice...Thank you Dan!
    Wednesday, December 17, 2014 3:12 PM
  • Yup, this does the trick. If you're using Group Policy Objects to set this, don't forget to restart the target server or to run the following as an admin: gpupdate /force

    Had me guessing for a minute!

    Monday, February 23, 2015 3:35 AM
  • This works!!! Thanks a lot.
    Tuesday, March 17, 2015 4:07 PM
  • hi keith,

    thank you for your help, yes adding the user to remote desktop users on the server helped.

    the user was a domain user ( no local admin or domain admin etc )

    thx for help

    cheers

    raj

    Friday, March 20, 2015 2:30 AM
  • Hi All,

    I Have a lab setup in hyper-v to demo RDS. 1 DC, 1 RDS and 1 8.1 client are running in my lab. I did initially have the issue above however the advice resolved this problem. I did however encounter a new issue.

    When i shut down the VMs and restarted the next day, I found that I got this error upon signing in, even as an administrator on my server machines. Quite frustrating but by accident, on the login prompt i pressed the back button twice then the window closed, opened again with the message 'connecting to Windows...' and the lock screen was presented this time. i clicked and then entered the admin password and it works!! this is exactly the same for the other server VM and also the client machine where i use a normal domain user account.

    I'm not sure if this is unique to hyper-v because i cant find anything else on this issue on the net. I've already applied the GP to allow users to connect through RDS. any ideas?

    regards,

    infoAdmin

    Friday, July 31, 2015 8:40 AM
  • THX, muchas gracias.
    Saturday, August 01, 2015 7:45 PM
  • Hitting this year old thread because this answer was the most correct for my issue, is voted the highest, but is somehow not marked as the correct answer. Thanks, Dan. My problem was:

    • Server 2012 R2 with Remote Access and Remote Desktop Services Roles installed and configured with no errors indicated
    • Firewall configured to pass ports 80, 443 and 3389 to Server 2012
    • Certificate(s) properly bound
    • User permissions set correctly
    • RDP sessions using admin credentials work with no issues
    • RDP sessions with user credentials fail with error message "To sign in remotely, you need the right to sign in through Remote Desktop Services. By default members of the Administrators group have this right. If the group you're in does not have the right, or  if the right has been removed from the Administrators group, you need to be granted the right manually."

    Following Dan's advice, I did the following:

    • ran gpedit.msc on the 2012 Server R2 machine
    • navigated to Computer Configuration/Windows Settings/Security Settings/Local Policies/User Rights Assignment/Allow log on through Remote Desktop Services
    • added the built-in group WseRemoteAccessUsers

    All users with remote access permissions can now log in via RDP without issue. Thanks again Dan - I probably spent six hours on this before I ran across your answer.

    Thursday, August 06, 2015 7:53 PM
  • Hi! There´s a simple tutorial that shows how do you grant access for some users. Check it out

    http://www.orbitsit.co.uk/2014/03/unable-remote-desktop-server-2012-adding-user-remote-desktop-users-group/

    Thursday, August 13, 2015 12:58 PM
  • I expected that Remote Desktop Users would be in that list.

    Adding that group to this list, followed by a forced update, solves it.

    Thanks Dan.

    Saturday, January 16, 2016 6:36 PM
  • Hello I tried this step, however I am unable to add user or group as it is greyed out and am not sure how to proceed. Please help
    Saturday, April 02, 2016 3:24 AM
  • Thank you!

    Very helpful... I did need to modify the last line "added the built-in group WseRemoteAccessUsers" and instead added the built-in group "Remote Desktop Users".   Then it all began to work...  <

    Thanks for laying it all out in very clear steps!

    Friday, April 08, 2016 4:05 PM
  • I've tried all of these steps and it still will NOT work properly.  Windows 10 desktops in a Windows 2012R2 domain. Users are all members of the domain\remote desktop users group, the GPO has Allow Logon through Remote Desktop Services, I have checked the individual workstations local policies and the Allow Logon policy is being pushed correctly but I continually get "the connection was denied because the user account is not authorized for remote login". I even added the specific user IDs to the Remote Desktop users group and those show up in the local policy and it STILL refuses to allow remote login.  I can login fine as the domain administrator, just not as the domain user... I'm pulling my hair out... what could be causing this?
    Thursday, June 02, 2016 2:40 PM
  • Luptona - I also have the same issue.. No matter what I try, I continue to get "the connection was denied because the user account is not authorized for remote login".  I use our Admin account. All admins on my team use the same account ID. This is a production web server (Windows 12). I use the same admin account for a our Test server and that remote login works fine. For some reason, I cannot log in to this production account.

    I was able to login using my own ID and change Users in the Remote Login area. When I did this and tried to login again with the admin account - the admin login then bypasses the "connection was denied.." pop-up but instead comes up with "To sign in remotely, you need the right to sign in through Remote Desktop Services. By default members of the Administrators group have this right. If the group you're in does not have the right, or  if the right has been removed from the Administrators group, you need to be granted the right manually." 

    At one time - I had no issues with logging in. But over the past month - I cannot log in anymore.  Security at my company is dumbfounded by this as well as the rest of my team.  We are all scratching our heads.  This makes no sense.  Perhaps there is a setting in my own windows 7 system that is causing an abrasion?

    Friday, September 09, 2016 3:36 PM
  • You have to allow the "Remote Desktop Users" group to login remotely. It sounds silly that it is not the case by default but even if you assign the user that group you need to do this step to allow the group to login remotely.

    https://www.orbitsit.co.uk/2014/03/unable-remote-desktop-server-2012-adding-user-remote-desktop-users-group/


    Looking forward to tommorow

    Thursday, October 13, 2016 3:43 AM
  • Solution, here's what I found especially if you are trying to allow RDP for a user other than the Administrator account on a Windows 2012 R2 Domain Controller

    Allow RDP step-by-step guide

    1. RDP into the appropriate using the Administrator account
    2. Open up Group Policy Management (Start > Administrator Tools > Group Policy)
    3. Navigate to Group Policy Objects, edit the Default Domain Controllers Policy
    4. In GP Editor, navigate to Computer Configuration> Policies > Windows Settings > Security Settings > Local Policies > User Rights Assignment
    5. Double-click Allow log on through Remote Desktop Services, add the the appropriate account (i.e PITG), click Browse, locate the user account
    6. Close the Editor

    Monday, October 31, 2016 3:11 PM
  • You have to allow the "Remote Desktop Users" group to login remotely. It sounds silly that it is not the case by default but even if you assign the user that group you need to do this step to allow the group to login remotely.

    https://www.orbitsit.co.uk/2014/03/unable-remote-desktop-server-2012-adding-user-remote-desktop-users-group/


    Looking forward to tommorow

    This is the one that worked for me.  However, I found it was unnecessary in the end.  The main issue (found because it was only happening on 1 server out of 4) was that the Authenticated Users group was missing from that key.  Once I added that back in, it worked without needing to specify Remote Desktop Users.

    Steve

    Monday, February 13, 2017 11:21 PM
  • This worked for me. Thanks Dan!
    Friday, July 14, 2017 11:53 AM
  • Dane right on the nail ;-)
    Saturday, December 16, 2017 12:52 AM
  • For anyone else with the issue, I needed a different solution. I set up Server 2016 from scratch and after turning on Remote Desktop, checking the firewall, and adding the groups in Allow Logon through Remote Desktop Services, I was still encountering the same message. Turns out, there is another policy in User Rights Assignment called Deny Logon Through Remote Desktop Services which for some reason had Everyone in it. After clearing that group I got right in.
    Monday, March 12, 2018 2:50 PM
  • This is the solution, it is effective, thanks a lot
    Thursday, May 17, 2018 2:59 AM
  • Thank you, able to login now.
    Friday, May 18, 2018 5:42 PM