DPM Console crashes when trying to view reports RRS feed

  • Question

  • Have performed the following actions so far:

    - Tried opening reports in the DPM console with another user to exclude Windows profile problems.

    - Updated DPM 2012 R2 to CU8

    - Rebooted the DPM Server

    - Have examined all steps in the "Guided Walkthrough for Troubleshooting Data Protection Manager console issues", 

    After the crash, there is to following entry in the Eventlog:

    The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    An unexpected error caused a failure for process 'mmc'.  Restart the DPM process 'mmc'.

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>0</Seq><TimeCreated>23.12.2015 08:54:15</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>InvalidCastException</ExceptionType><ExceptionMessage>Specified cast is not valid.</ExceptionMessage><ExceptionDetails>System.InvalidCastException: Specified cast is not valid.
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.Library.Reporting.Reporter.GetDPSInstallTime()
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ReportingPage.ViewReport..ctor(Report report, Boolean flagNewReport)
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ReportingPage.Reporting.OpenViewReportForm(Boolean flagNewReport)
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ReportingPage.Reporting.listViewTileReports_DoubleClick(Object sender, EventArgs e)
       at System.Windows.Forms.ListView.WndProc(Message&amp; m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)</ExceptionDetails></FatalServiceError>

    the message resource is present but the message is not found in the string/message table

    Thank you in advance for any help.


    • Edited by FranzSchenk Wednesday, December 23, 2015 9:32 AM
    Wednesday, December 23, 2015 9:30 AM


    • Marked as answer by FranzSchenk Thursday, December 24, 2015 8:10 AM
    Wednesday, December 23, 2015 9:54 AM
  • Thank you for the links! The third Link, Step 4 solved finally the problem.

    We had executed "dpmsync -sync" and that solved the reporting problem.

    But after that, all Recovery Points where out of sync. Have then executed "dpmsync -ReallocateReplica", but it didn't help. Had then to perform a consistency check on all protected ressources which took several hours to complete.

    Have only found a very old Technet article from 2005 that describes that dpmsync should be used for DPM database restores ( It would easier for us if Microsoft would maintain only a little documentation for newer DPM versions.

    Does anybody knows about a document that describes dpmsync, and when it has to be used, and what is the impact of using it?


    • Marked as answer by FranzSchenk Thursday, December 24, 2015 8:10 AM
    Thursday, December 24, 2015 8:10 AM

All replies