none
LiteTouchPE_x64.wim vs LiteTouchPE_x86.wim RRS feed

  • Question

  • All,

    Here is my issue.  I have the Dell E7470 laptops and there is a known issue where the NIC is missing and the laptop crashes with

    "A connection to the deployment share MDT 2013 Production Share$ could not be made. The following networking device did not have a driver installed. PCI\VEN_8086&dev_156f&subsys_06dc1028&rev_21 Retry: Try again to connect to the deployment share. Cancel: Give up, cancelling any in-progress task sequence"

    But this post is not about that right now.  What I tried yesterday was booting from the "LIteTouchPE_86.WIM instead of the X64 and it worked.  My questions are as follows:

    1.  Why does one work and not the other?
    2.  What is the difference?
    3.  I booted from the x86 and was able to load an image on to the E7470 from a captured image.  Is it okay to continue to use the X86 WIM?

    Thank you !


    Tuesday, September 27, 2016 12:02 PM

All replies

  • Concerning the difference between LiteTouchPE_x86 and _x64:  x86 can be used for deploying both 32 bit and 64 bit OSes.  x86 requires using 32bit drivers, x64 requires 64 bit drivers.

    Concerning your E7470 issue, this sounds similar: https://social.technet.microsoft.com/Forums/en-US/120fbd34-03b9-4d7a-b52b-fd497ebfd5ee/deployment-fail-cause-fo-missing-nic-driver-mdt-deployment-share-properties-drivers-and-patches?forum=mdt

    Tuesday, September 27, 2016 1:29 PM
  • More on the x86 vs x64.  I understand the logic behind the bits, but even when I use the x86 wim, I'm still loading the x64 bit image successfully on the laptop.  This was was from a capture earlier.

    Is it a moot point about which wim I connect with?

    THANK YOU FOR TAKING TIME TO HELP !!


    Michael Agee

    Tuesday, September 27, 2016 2:04 PM
  • You can install x86 or x64 from x86 media if you aren't using UEFI.  If you are using UEFI you need to match x64 with x64.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Tuesday, September 27, 2016 6:38 PM
    Moderator
  • As Ty mentioned you must boot from x64 if you intend to make use of UEFI. If you're getting your Dell drivers from the CAB packs and run into the issue of "losing" your network connection, then it's possible you may need updated drivers directly from Dell's site for example the E7470. Once in a while I've had that happen. Recently I took to disabling Windows 10's automatic driver updates in the reference image and then at the end of the task sequence I enable it.

    To enable it add a "run command line" with the following:

    cmd.exe /c reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\DriverSearching" /v SearchOrderConfig /t REG_DWORD /d 1 /f


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, September 29, 2016 3:15 PM