none
ifm63x64.sys missing or corrupt during OSD RRS feed

  • Question

  • We are getting new model ultrabooks here at work and I have been assigned the task of building our golden image.  I got everything configured the way I wanted and when I went to capture the image I got an error after reboot that said Windows failed to start. The file ifm63x64.sys was missing or corrupt.

    After banging my head against the wall and searching Google I found a solution, in the driver package on the deployment share there were 2 SCSI drivers that were imported with the NIC driver.  I removed those 2 drivers and updated the share completely regenerating the boot images and was able to get a sucessful capture.  Now when I go to deploy the .WIM file that I captured I'm getting the same error.  It will go through all the motions of installing the OS and goes to reboot the first time and it hangs giving the file ifm63x64.sys is missing or corrupt. 

    I have created a new share just for this model machine and only imported LAN drivers from the manufacturer, but still got this error.  I deleted all of those drivers and imported LAN only drivers from Intel and no go.  Go back into the drivers list and see the SCSI drivers are there so I deleted them and still get the error. 

    From what I have been reading on the internet it has affected different manufacturers and different model machines, none of which are the Lenovo 20A8 I have.

    Any help or insight would be very much appreciated.

    Thanks,

    Leigh

    Monday, April 14, 2014 6:34 PM

All replies

  • Looks nasty. haven't had the need to use this driver.

    IF you didn't remove the driver from the deployment share, then it *could* have been injected back into the winpe wim.

    Do you have *separate* deployment shares for Image creation and image deployment? if so you will also need to regenerate the image deployment winpe image.


    Keith Garner - keithga.wordpress.com

    Tuesday, April 15, 2014 6:28 AM
    Moderator
  • Keith,

    I do have 2 deployment shares right now, one is our main share that has all our previous model deployment images and it is working correctly, the other is our testing share for when we get a new model machine and get it setup correctly so I don't hose our deployment server.

    I have tried to send the deployment with and without the SCSI drivers loaded into the share and still get the same error.  One thing I did notice is that particular file isn't in the drivers folder.  In my unpacked drivers I see the file IFM63x64.sys along with .inf and .cat but when I choose to import drivers from that extracted folder, the only thing that adds are the 2 SCSI drivers.  One of them says Intel SCSIAdapter ifm63x64.inf 1.18.12.0.  It shows a x64 platform and my OS is x64.  The other SCSI driver that was imported is Intel SCSIAdapter ifcoemp.inf 1.18.12.0 also a x64 platform.

    If I can't get this to work is there any other suggestions on how to deploy this image through the network?

    Thanks,

    Leigh

    EDIT:  I have gone into the task sequence and disabled the inject drivers both in the preinstall and in the install phase, and it will get to the point where it is applying image via DISM.exe and reboots and I come back to that error.

    • Edited by leighweems Tuesday, April 15, 2014 4:57 PM Update
    Tuesday, April 15, 2014 1:38 PM