locked
Error when Default Web Site is browsed after installing UAG SP1 RRS feed

  • Question

  • Hi,

    After installing UAG SP1, when the Default Web Site is clicked, the error "HTTP Error 403.14 – Forbidden. The Web server is configured to not list the contents of this directory." is displayed. This happens only after SP1 is installed. Pre-SP1 it works fine. I can see the IIS welcome page. There is no error if the Directory Browsing property is enabled. But the welcom page is not displayed. Just the files/directories are listed.

    Thanks,

    Christopher

    Thursday, January 13, 2011 10:29 AM

Answers

  • Hi Christopher and Jason,

    I do not have an official statement, but I can tell you that this is not necessarily a valid check. In any case, the fact that, when you do browse the Default Web Site (http://localhost:6001) and receive the “HTTP Error 403.14 – Forbidden” page, this *is* an indication that IIS is running, which is what you were looking for.

     

    Directory browsing is indeed disabled in IIS, both in UAG SP1 and in previous versions.

    The configured Default Document files are the regular ones, but none of them exists. Pre-SP1, one such file existed  - iisstart.htm, in the /intepub/wwwroot folder. In UAG SP1, this file is there, but renamed to iisstart.htm.bak, hence IIS does not have what to show and displays the 403 Forbidden error.

     

    BTW, if you really want to see one of the UAG files being returned by IIS, you can browse to one of the GIF files in the /InternalSite/images folder, for example: http://localhost:6001/InternalSite/images/true.gif

     

    Regards,


    -Ran
    • Marked as answer by ChristopherJC Saturday, January 15, 2011 9:47 AM
    Friday, January 14, 2011 6:34 PM

All replies

  • Hi Christopher,

    Do you mean the Default Web Site on the IIS Server running on the UAG box? Why do you need to browse this site? This site is not just a "simple web site", it implements all kind of functionalities needed by the UAG itself, and it is accessed via a UAG trunk, and, in some cases, via the UAG Management console.

    Regards,


    -Ran
    Thursday, January 13, 2011 10:45 AM
  • Hi Ran,

    Yes. But doesn't it have to display the default welcome page when browsed. I can see the IIS welcome page if SP1 is not installed.

    Thanks,

    Christopher

    Friday, January 14, 2011 2:39 AM
  • Why would you ever browse that site though? Why do you think that is necessary?
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, January 14, 2011 10:40 AM
  • This was just to make sure everything works fine after SP1 installation. There was a case where after SP1 was installed, we couldn't access the portal.  To troubleshoot that we tried to access the default web site to make sure IIS is working. I guess that may be due to some other issue. But, just want to make sure this does not cause any problems. The only concern is that you can access the page when SP1 is not installed. If this is by design then no issues. But if you try to uninstall SP1, you cannot access the page even if SP1 is uninstalled successfully!!

    Friday, January 14, 2011 11:07 AM
  • Ran, do you have official line on this?
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, January 14, 2011 11:18 AM
  • Hi Christopher and Jason,

    I do not have an official statement, but I can tell you that this is not necessarily a valid check. In any case, the fact that, when you do browse the Default Web Site (http://localhost:6001) and receive the “HTTP Error 403.14 – Forbidden” page, this *is* an indication that IIS is running, which is what you were looking for.

     

    Directory browsing is indeed disabled in IIS, both in UAG SP1 and in previous versions.

    The configured Default Document files are the regular ones, but none of them exists. Pre-SP1, one such file existed  - iisstart.htm, in the /intepub/wwwroot folder. In UAG SP1, this file is there, but renamed to iisstart.htm.bak, hence IIS does not have what to show and displays the 403 Forbidden error.

     

    BTW, if you really want to see one of the UAG files being returned by IIS, you can browse to one of the GIF files in the /InternalSite/images folder, for example: http://localhost:6001/InternalSite/images/true.gif

     

    Regards,


    -Ran
    • Marked as answer by ChristopherJC Saturday, January 15, 2011 9:47 AM
    Friday, January 14, 2011 6:34 PM
  • Thanks Ran :)
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, January 14, 2011 9:22 PM
  • Thanks a lot Ran. This really helps.
    Saturday, January 15, 2011 9:47 AM