none
Group Policy Issues RRS feed

  • Question

  • Hello,

    I am currently having trouble with 5 workstations we upgraded to Windows 10. Previously 3 of the machines were on Windows 7, the other two are fresh installs. I have three domain controllers and I have tried pushing updates from all three of them (two 08 servers, one 2012). Out of the 150 computers on the network only 5 are unable to get the remote pushes. Those 5 are Windows 10 machines.

    These settings have been in place for a few years now and I have never had any problems with them. I even setup a Windows 8.1 for fun and it worked right off the bat. It only occurs with Windows 10.

    Things I have tried, leaving the domain, reconnecting to the domain, restarting computer.

    Stopping and starting RPC and WMIMgnt.

    Disabled anti-virus and firewalls,

    Manually added services/ports.

    Nothing seems to work. I can ping the machines, they are able to access all the normal aspects of our domain. On the machines I can run gpupdate.exe it says successful. I've run gpresult /r to on the devices to see what they show and they are only showing "user settings" and applied group policies. When I run the the command on any other computer that works they show "computer settings" and the applied group policies. 

    Does anyone have a few for this? Ive read about disabling TPM inside bios, but I dont find that to be a viable solution. I have users who want to upgrade to windows 10 and the licenses are already purchased. But if my group policies dont work I cant update. 

    Any info/insight is much appreciated. 

    Wednesday, September 16, 2015 1:26 PM

All replies

  • Hi Mike,

    Have we configured any group policy template settings?

    Have we downloaded and installed the Windows 10 ADMX?

    Windows 10 Group Policy (.ADMX) Templates now available for download

    http://blogs.technet.com/b/askds/archive/2015/08/07/windows-10-group-policy-admx-templates-now-available-for-download.aspx

    Regarding group policy troubleshooting, we may follow the guide below:

    Group Policy Analysis and Troubleshooting Overview

    https://technet.microsoft.com/en-us/library/jj134223.aspx

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, September 17, 2015 7:54 AM
    Moderator
  • Hello thanks for the reply.

    My group policies have been in place for a few years now. I rarely need to configure anything in it. The problem I am having is my Windows 10 client workstations are not getting my Windows update from Group Policy.

    I see you are recommended downloading some new amdx files but this is where my confusion comes in. I have three domain controllers and a 4th coming up soon. Do I download these files and place them on all my DC's? Can I just place them on one DC and will it replicate to the others? I guess I dont understand how to install these files or where they are installed to. My network consists of Windows 7, 8.1 and 10, my DC's are 2008r2 and 2012r2. 

    Monday, September 21, 2015 6:19 PM
  • update.

    I updated the amdx files on the central store but my windows 10 computers are still kicking ranrom errors when pushing the group policy out.

    One error is: The system cannot find the file specified.

    Second error is : The remote procedre call was cancelled.

    These were all working prior to updating the computers to Windows 10. Also some of the computers are fresh installs.

    Monday, September 21, 2015 7:36 PM
  • Update.

    I installed AMDX files and they are now in a central locaton as suggested. But my Windows 10 computers are still receiving "the system cannot find the file specified". I tried looking up the error but not finding anything regarding Windows 10.

    Monday, September 21, 2015 9:44 PM
  • New update.

    I tried a few more tests. Using cmd i did gpresult /r to see what policies were in place on the client machine. It only showed client policies nothing for computer. I ran gpupdate, and then ran gpresult again, same thing.

    I then open cmd as admin ran gpresult, still just user. Then I ran gpupdate, then gpresult again which now accepted the computer policies. The main problem is I neeed to make these policies work, since I dont have the time to remote into every computer on our network that has Windows 10. We are also about to setup a second location and I dont want to try and explain or remote into other computers. What am I missing here?

    Tuesday, September 22, 2015 12:30 PM
  • Anyone able to suggest trying anything else before I just scrap the entire Windows 10 experience?
    Wednesday, September 23, 2015 6:08 PM
  • Well Mike,

    Apologize for the late reply.

    Have we tried the group policy loopback?

    Check to see the computer policy is not configured for special OUs, if yes, make sure Windows 10 machine is added.

    Another thing is to check the Rsop settings on Windows 10 and the other machines which have the GPO worked, compare them and check the differences.

    Check the event log and take a further troubleshooting, follow the guide below:

    https://technet.microsoft.com/en-us/library/cc749336(v=ws.10).aspx

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, September 24, 2015 2:10 AM
    Moderator
  • Thanks for the reply. As suggested I checked the Rsop on working machines and non working ones. They show the same settings being applied. This is confusing me, since they show the policy I assume they are getting the updates as normal.

    But when I go on my DC and go into GPMC and push the update from the my 2012 server I get a pretty big list of failed computers.

    The main eror description is "the remote procedure call was cancelled" and "the system cannot find the file specified". 

    Monday, September 28, 2015 2:45 PM
  • Update

    After forcing the update on the WIndows 10 machines the gpresult /r showed my expected results. I know the service refreshes every so often so I went back to a Windows 10 box to check the settings, and long behold after running gpresult /r no computer settings were found. 

    Monday, September 28, 2015 8:49 PM
  • Hi Mike,

    Thank for the update.

    What if we run the gpupdate /force again?

    If that would work again, we may consider to create a gpupdate /force scripts to force the sync on Windows 10 machines, currently.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, October 5, 2015 5:24 AM
    Moderator