locked
Windows 2008 R2 File and Folder Copy Paste very slow over 1000 MB/s LAN

    Question

  • Hi Guys,

    Recently we have implemented Windows 2008 R2 Remote Desktop Server and its configuration as per below mention configuration.....

    1:- CPU Quad Core 2 GHz
    2:- Memory 12 GB
    3:- Raid 5 146*3
    4:- LAN 1000 MB/s

    We have also one HP NAS box which having OS Windows 2008 Storage Server.

    Now whenever i am trying to copy file or folder from one my Windows 2008 R2 Server to Windows 2008 Storage Server its giving me throughput 1 MB/s to 2 MB/s meanwhile if i am trying to copy from XP machine to XP machine there is no any issue and its giving me throughput 70 MB/s.


    Hence i have gone through lot of article and there is no any solution for Windows 2008 R2.

    Is there any bug on Windows 2008 R2 server? If yes then i would like to request to Microsoft that please provide me any hotfix or patch for Slow copy.

    I think its Microsoft Windows 2008 R2 BUG.

    Dear Microsoft kindly look this bug..




    Subhash Tiwari |MCA|MCSE|MCSA|MCDBA|MCTS | Blog-> http://subhashtiwari.spaces.live.com
    Tuesday, December 15, 2009 5:59 AM

All replies

  • Hi Guys,

    I have tested below mention steps but still problem continue to resolve the copy paste issue from Windows XP /2003/ 2008 server to Windows 2008 R2 server......

    1:- By Changing the swith port.

    2:- By Changing the switch.

    3:- By Updated the network card driver also tried by network card replacement.

    4:- netsh int tcp set global RSS=disabled
    5:- netsh int tcp set global Chimney=disabled
    6:- netsh int tcp set global Autotuninglevel=Highlyrestricted also by disabled

    7:- disabled IPV4 Checksum offload from network card.
    8:- disabled IPv4 Large Send Offload from network card.
    9:- disabled IPv6 Checksum Offload from network card.
    10:- disabled IPv6 Large Send Offload from network card.
    11:- disabled TCP Connection Offload (IPv4).
    12:- disabled TCP Connection Offload (IPv6).

    13:- Disabled the SMB2 from  registry.

    14:- By disabled the IPv6 from network card also from registry.

    15:- HKLM\System\CurrentControlSet\Services\TCPIP\Parameter EnableTCPA  (Enable 1 and disable 0) tested both.

     


    Observation for 160 MB file copy paste  on 100 MB/s Local LAN

    Windows XP to Windows XP copy speed = 22 Second

    Windows XP to Windows 2008 Copy speed = 1 Minute

    Windows XP to Windows 2008 R2 Copy speed = 2 Minute 30 Second

    Windows 2008 to Windows 2008 R2 Copy speed = 2 Minute 30 Second 

     

    Observation for inside server copy speed from C Drive to D Drive

    Windows 2008 R2 450 MB file from C drive to D  Drive copy speed average 100 MB/s

    Windows 2008 Storage Server 450 MB file copy from C Drive to D Drive speed average 15 MB/s


    If some one have any other method to resolve this issue please provide it to me.


    Cheers


    Subhash Tiwari |MCA|MCSE|MCSA|MCDBA|MCTS | Blog-> http://subhashtiwari.spaces.live.com
    Thursday, December 24, 2009 6:47 AM
  • Provide the Netmon logs for better understanding the issue.

    Use netmon between source and destination machine to check the network traffic.

    Try to disable the SMB2 on both the servers and monitor the speed.

    To disable SMB2 :

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Check if there is any improvement.

    Suggesting this to you because the network devices between the Win2k8 servers may not be aware of the SMB2.

    Regards,
    Rajesh
    Tuesday, December 29, 2009 1:30 PM
  • Hi Rajesh,


    There is no need to disable SMB2 protocol because file copy between windows 2008 - windows 2008 uses SMB2 and doesnt fall back to SMB 1 version.

    Disabling SMB2 holds good when copying files between windows 2008 to windows xp , windows 2003 or legacy OS .



    @subhash Tiwari :  "Is there any bug on Windows 2008 R2 server?" , file copy involves many components both from microsoft as well as 3rd party

    Disabling the above really doesnt help to resolve the problem , tcp chimney , tcp conneciton offload are meant for different purpose. First and the foremost thing as Rajesh mentioned you need to take a network capture / etheral to understand the delay , prior to that i would like you to check the following

    a) Please provide the  Path involved from source to destination ( hardware involved )

    b) Can you try copy large file to itself ? ( windows 2008 R2 ) and check the performance ?

    c) Restart the server in safe mode with networking and check for the performance

    d) is this issue happening to specific files or any files ?

    e) please perform windows update to make sure your system gets updated to latest binaries.


    f) Another important component involved is NIC drivers which interfaces to the hardware and sends the packet to destination .  Make sure you update the drivers.

    After collecting the netmon trace you need to have the knowledge to understand the SMB dialects if not you might find tons of SMB frames but you would not know where to start reading it .




    Wednesday, December 30, 2009 1:58 AM
    Moderator
  • -Subhash,

    While this suggestion may be a reach it is something that I have worked to resolve in the past.

    Can you review any security settings that are applied to these boxes as a result of Local Policy or GPO?

    More specifically you will be looking for SMB Signing configurations that designate "Always On", for Server and Client of SMB session setup.

    While MS says this should only account for 15 percent added overhead, I have had situations where other network topology factors can result in higher overhead numbers.

    I would also reccomend not using Copy/Paste from the UI, switch to robocopy or use FTP and compare numbers. The UI/Explorer overhead of copy/paste is rediculous.



    Thanks, and good luck.

    -Jordan

    • Edited by Jordan Mackie Wednesday, December 30, 2009 8:34 PM Added more information.
    Wednesday, December 30, 2009 8:32 PM
  • Hello Sainath,

    Thanks for your reply.

    As per above checklist given by you i have tested it in my environment which is as per below....

    a) Please provide the  Path involved from source to destination ( hardware involved )  (Source is Windows XP/2003/Vista/2008 on same LAN and Same Cisco L3 switch ).

    b) Can you try copy large file to itself ? ( windows 2008 R2 ) and check the performance ? (Yes i have already tried it by copying 460 MB file and its copying within 15 to 20 Second and throuput is 100 MB/s.)

    c) Restart the server in safe mode with networking and check for the performance (Same throughput in same mode also)

    d) is this issue happening to specific files or any files ?     (This issue is happeing to any file or folder even if single PST file (160 MB)also.)

    e) please perform windows update to make sure your system gets updated to latest binaries.  (I have already updated my windows 2008 R2 Server OS and all drivers which is included NIC card driver).

    f)
    file copy involves many components both from microsoft as well as 3rd party .  (I have tested it on 5 to 10 servers and 4-5 customer location and all are facing the same issue due to this reason i saying this is a bug. And also for your info. i have tested it without any application installation so doesn't mean 3rd party).

    g) I have also open a case in HP and HP engineer also tested it and he was saying there is no any problem on hardware side.He was saying something wrong from OS side and will have to involve their OS team.


    Now i have last option to open a case in Microsoft and let them to identify from OS side. But actually Microsoft is not giving free support. 

    I know Microsoft can fix this issue by giving some hotfix. Because this issue was also on Vista and 2008 and they have given Hotfix for the same but not for Windows 2008 R2 OS.

    Dear Microsoft US development team please provide me some solution for this BUG.

    Cheers,

    Subhash Tiwari |MCA|MCSE|MCSA|MCDBA|MCTS | Blog-> http://subhashtiwari.spaces.live.com
    Thursday, December 31, 2009 8:24 AM
  • Hi Subhash,

    thanks for the information

    In the point b  you have said the below

    b) Can you try copy large file to itself ? ( windows 2008 R2 ) and check the performance ? (Yes i have already tried it by copying 460 MB file and its copying within 15 to 20 Second and throuput is 100 MB/s.)


    which should be pretty normal 450 MB file copying locally does take 15 seconds which i have tested on multiple machines which also explains there is no problem involved locally.



    But actually Microsoft is not giving free support.
     
    you are correct microsoft will not provide free support and for which you have the technet forums where you get free support from engineers world wide.

    Please understand there is a difference a bug and the performance , i havent personally observed engineers posting performance related problems involved with windows 2008 R2 .


    Please take a netmon trace and analyze the packets of SMB , if you need further assistance in analyzing smb trace do paste the transcript or email me the file for analysis ( sainathss@live.in)

    Thursday, December 31, 2009 12:27 PM
    Moderator
  • Hi!
    I have the same problem with my network and win2008R2. There are several win2008 servers that work without problem, but those with 2008R2 are incredibly slow as soon as network operations are involved.
    Did you find any solution to your problem above?
    thanks!!!
    Tuesday, January 19, 2010 10:33 AM
  • Same problem.  Been working on it for days.  Seemed to resolve it by stopping SMB2.
    Saturday, January 30, 2010 7:42 PM
  • This fixed it for me but you said you already tried that.  Try going into the network adapter driver properties and DISABLE "TCP Connection Offload (IPv4)".  This is generally listed on the advanced tab of the network adapter.
    Sunday, March 14, 2010 8:36 PM
  • Thanks Yellow Boy, This problem has been plaguing me for months, DISABLE "TCP Connection Offload (IPv4)" finally did the trick.

    config --

    2008 R2 server copying from or to a 2008 standard 64, would time out or bluescreen (I believe only bluescreen when I had Antivirus installed)

    Both servers were blades in same blade center  (possibly problem with TCO feature not playing well with virtual nic xfer within the blade chassis.

     

    Thanks again !

     

    Phil

     

    Thursday, March 25, 2010 6:02 PM
  • Iam also facing the same problem please help me..............................
    Sunday, March 28, 2010 5:18 AM
  • Iam also facing the same problem please help me..............................
    Sunday, March 28, 2010 5:18 AM
  • due you find any solution for that iam facing same problem.
    Sunday, March 28, 2010 8:01 AM
  • I have a fix that worked which worked perfectly. I have an HP ML 350 G6 server that was newly installed today and experience the same problem. I noticed that the HP software was not installed as I would have expected on older servers/oses. I downloaded the latest PSP from the HP drivers and downloads, installed it as a proliant server should and voila - the NIC and network worked exactly as it should.

    Before:

    Win 2003 SBS server to Win 2008 Enterprise w SP2 32bit --

     was about 2 minutes for a 22MB folder

    After:

    Now it is literally 1 second !!!

    No tweaking needed - just installed and configured the HP Proliant software to SPEC !!

    Thanks

    Aleks Mednis

    Friday, April 30, 2010 10:59 PM
  • we have something similar - very bad copy performance, arround 18MBytes/sec when copying 1 large files. Strange thing: when we initiate multiple instances of a copy process - say copy the same file from the source computer to different target folders on the server - we DOUBLE the throughput with each new instance. Whats that ... ???
    Wednesday, June 09, 2010 3:06 PM