locked
OData feed first row formatting problem RRS feed

  • Question

  • With the last Power Query update, I am having this issue. The first row isn't displaying properly. It looks like Power Query is trying to treat it as a header row. See attached image.

    Monday, May 26, 2014 8:13 PM

Answers

  • If it's just the feed without any additional processing in Power Query, then there may be a problem with understanding the metadata for the feed. Generally, the feed will produce typed columns and we will set those types when sending the data to Excel. It's when the column-level type information is missing that Excel can produce this kind of result.

    When you highlight the columns in the editor, do they show anything for the "Data Type" in the editor's ribbon?

    Tuesday, May 27, 2014 3:53 PM

All replies

  • I tried adding new queries to this workbook. This first row issue is not present in the new queries. Is there some hidden setting (or not hidden but I can't find it) which would control this first row behaviour?

    Monday, May 26, 2014 8:23 PM
  • Nope. What does the query look like?
    Tuesday, May 27, 2014 3:27 PM
  • Is a custom OData feed. I can post in the OData responses if you want. Like I said, deleting and recreating the query gets rid of the first row formatting issue. And the issue isn't present in the preview. So it seems an Excel formatting issue.
    Tuesday, May 27, 2014 3:34 PM
  • If it's just the feed without any additional processing in Power Query, then there may be a problem with understanding the metadata for the feed. Generally, the feed will produce typed columns and we will set those types when sending the data to Excel. It's when the column-level type information is missing that Excel can produce this kind of result.

    When you highlight the columns in the editor, do they show anything for the "Data Type" in the editor's ribbon?

    Tuesday, May 27, 2014 3:53 PM
  • Since I already deleted and recreated the query, I can't check. But if memory serves me right, the column data type was correct.  If it happens again, I'll revisit this thread. Thanks.

    Sunday, June 1, 2014 10:05 PM