locked
'send-as' permission for Mail Distribution Group RRS feed

  • Question

  • Hi All,

    I have created a mail distribution group as 'IT Monitoring'. I need to send emails from this address as well using 'send-as' permission. I am aware of that fact that I cannot do this from Exchange 2007 EMC. I had to use EMS with following commands and both never worked for me.

    get-distributiongroup ITMonitoring | add-adpermission -user USERNAME -extendedrights
    or
    Set-DistributionGroup "IT Monitoring" -GrantSendOnBehalfTo "USERNAME"

    When I try to change From Field in my outlook than I receive an error that I don't have enough permissions to send from this email address. I checked the active directory and can see my username in security tab of group properties of 'IT Monitoring' and its allowed to 'send-as' .

    Can some please tell me as what I am doign wrong here.

     

    Thanks.

     

     

    Wednesday, October 12, 2011 9:38 AM

Answers

  • Hi,

    Although you have multiple smtp address for one mailbox they are the same one. So the mailbox is always using default smtp address to send message.

    You can create multiple mailbox for different SMTP address and then grant send as permission to them.

    Then you can send the message by using different smtp address


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Jason LJS Wednesday, October 19, 2011 1:04 AM
    • Marked as answer by Jason LJS Thursday, October 20, 2011 12:53 AM
    Monday, October 17, 2011 9:29 AM

All replies

  • Hi trueUser,

    Can some please tell me as what I am doign wrong here.

    How long did you wait? Exchange Cache the pemrissions and you should wait a little bit till they are active:
    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx


    __________________
    Viele Grüße
    Christian

    Wednesday, October 12, 2011 9:48 AM
  • Hi Christian, Thanks for the prompt response,

    I have already waited for more than 12 hours.

     

    Many Thanks

     

     

    Wednesday, October 12, 2011 9:55 AM
  • Hi trueUser,

    Can you double check if the user gets permission:
    Get-DistributionGroup XYZ | Get-ADPermission | where {($_.ExtendedRights -like “*Send-As*”)} | FT -Wrap
    http://exchangeshare.wordpress.com/2008/09/01/how-to-find-all-mailboxes-with-send-as-permission-assigned/


    ____________________
    Viele Grüße
    Christian

    Wednesday, October 12, 2011 10:09 AM
  • Thanks for your response,

     

    Deny=false

    Inherited=false

    Rights=send-as

     

    Many THanks

     

    Wednesday, October 12, 2011 10:23 AM
  • hi,

    is one there?

     

    Regards,

     

    Thursday, October 13, 2011 7:46 AM
  • Hi,

    1. Go to the mail enabled Distribution group in AD Users and Computers  and bring up the properties of the group

    2. Click on the security tab and check the user is in the list and Send As permissions has been checked.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 13, 2011 8:43 AM
  • Hi Jason,

    Thanks for the reply,

     

    I can see my name there as send as,

    One more thing, I created this 'mail distribution group' in EMC and it sends emails to all the peoples added onto it. I am not sure is that mail enabled distribution group or not.

     

    Many Thanks

     

     

     

     

    Thursday, October 13, 2011 9:23 AM
  • Hi All,

    I just found a solution for that as I was making a mistake here. I followed following link

    http://technet.microsoft.com/en-us/library/aa997448%28EXCHG.80%29.aspx

    I created a 'test' distribution group in AD first and then following the steps mentioned in  above link and I can email from that distribution group. I believe it is a mail enabled distribution group.

    Can anyone be kind to tell me how can I enable mail enable Distribution groups on groups created in EMC. As I am unable to see them when I try to 'New Distribution Group>>Existing Group>> Browse".

     

    Thanks for all your help guys,

     

     

    Thursday, October 13, 2011 9:33 AM
  • Hi,

    The scope of group need to be changed to Universal.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 14, 2011 1:27 AM
  • Hi Jason,

     

    I checked them and they already are Universal.

     

    Many THanks

     

     

    Friday, October 14, 2011 8:32 AM
  • Hi All,

    It is getting bit more messier now, I am exactly sure where the problem lies,

    1) I have created a distribution group and put these in 'Properties>Email Addresses' tab customer@contoso.com, customer@contoso.eu, customer@contoso.co.uk and they are forwarding to my email address. I can receive email or alll the above but I can send from only one and it shows the address of the 'primary smtp address'. e.g. someone sent an email to contoso.eu, I received it in my mail box and when I try change from to 'customer@contoso.eu' and send the email it shows the primary smtp address of 'customer@contoso.co.uk'.

    How can I change, like if I receive a mail to 'customer@contoso.co.uk' i can reply from the same address.

     

    Many THanks

     

    Friday, October 14, 2011 9:38 AM
  • Hi,

    Although you have multiple smtp address for one mailbox they are the same one. So the mailbox is always using default smtp address to send message.

    You can create multiple mailbox for different SMTP address and then grant send as permission to them.

    Then you can send the message by using different smtp address


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Jason LJS Wednesday, October 19, 2011 1:04 AM
    • Marked as answer by Jason LJS Thursday, October 20, 2011 12:53 AM
    Monday, October 17, 2011 9:29 AM
  • Try this

    get-distributiongroup "distribution group name" |add-adpermission -user username -accessrights extendedright -extendedrights "send as"

    Monday, September 29, 2014 9:13 PM