locked
Word keep using non default proofing lagnuage RRS feed

  • Question

  • Hello!

    I'm seriously starting to loose my patience with word! This getting extremely frustrating.

    I'm using Word 2016 64-bit and I'm having troubles with proofing language. My display language in Windows as in Word is set to English (Sweden) with an Swedish keyboard. My default proofing language in Word is set to Swedish (Sweden) and "automatically detect language" unticked. Still EVERYTHING I write get formatted as "English (Sweden)". I've checked the styles for the different templates used and they're all formatted with "Swedish (Sweden)" as default proofing language so why in the fricking nutcracker is Word consistently ignoring the default values?

    Please help cause I'm about to loose my shit! xD

    Monday, September 16, 2019 8:07 AM

All replies

  • Hi,

    Regarding to your descriptions, please provide me more information.

    What is your Office 2016 version, MSI or C2R? Please make sure that you have installed the language pack. Would you please provide me a screenshot or a shared link of the Language settings in Word, like the following picture? I will check whether the language pack be installed successfully.

    I do a test and find that, the proofing language follows the keyboard you use to type to change. If you want the proofing language to be Swedish, you might use the Swedish keyboard.


    For existing documents, it’s recommended that select the entire document text (Ctrl + A), then select the Swedish as proofing language.

    If you have any updates, please feel free to let me know.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Tuesday, September 17, 2019 7:51 AM
  • Hello Herb!

    My version is an C2R one and language pack is installed. As for existing documents I've selected everything (CTRL + A) and set proofing language to Swedish (Sweden) on multiple occasions yet every addition to the document is formatted as English (Sweden) and I cannot understand why that is happening.

    Unfortunately I'm not allowed to either attach a screenshot nor post links as my account is so fresh...
    Tuesday, September 17, 2019 9:59 AM
  • Hi,

    Thanks for your response.

    Could you change the Swedish (Sweden) as the display language in Windows?

    As Suzanne S. Barnhill (Microsoft MVP (Word) since 1999) said, “No matter what language you think you have chosen as the default in Word, it may not “stick” unless you have selected the same language as the default in Windows.” You may refer to: How Word’s spelling checker works for more information. I hope it could help you.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    If you need further assistance, feel free to post back.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.




    Friday, September 20, 2019 7:27 AM
  • Which operating system are you running? In my experience, setting the *default proofing language in Office* to something other than the *display language in Windows 10* is unlikely to work properly. If you have the option to switch the Windows display language to Swedish, I recommend that you do so.


    Stefan Blom, Microsoft Word MVP

    Tuesday, September 24, 2019 12:20 PM
  • You have been given good advice. I have macros that could help, but they are sort of a workaround/patch while the advice you've gotten from others may fix the problem. Do read the linked article written by Suzanne Barnhill.


    Charles Kenyon Madison, WI

    Wednesday, September 25, 2019 8:18 PM
  • Hi,

    This thread has been around for a long time. Please remember to mark the replies as answers if they helped. Your action would be helpful to other users who encounter the same issue and read this thread. 

    Thank you for understanding! If you have any questions, or updates, please feel free to let me know.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.


    Tuesday, October 8, 2019 1:27 AM
  • Hi,

    I will provide a summary of your question. I hope it could help other users who encounter the same issue and read this thread.


    ====================

    Request/Expectation:

    Keep using default proofing language in Word for Office 2016, 64bit, Click-to-Run version. But the display language in Windows is English (Sweden), and the proofing language in Word is Swedish (Sweden).

    Suggestions:

    It’s recommended to change the Swedish (Sweden) as the display language in Windows. It means it’s better to set the default proofing language in Office as the display language in Windows.

    Reference Links:

    How Word’s spelling checker works for more information

    (Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_win10-mso_o365b/proofing-language-in-word-2016-seems-to-be/e8cf9421-5be2-4a9e-86ad-d0ac23e4f792?page=1

    ====================

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Friday, October 18, 2019 7:23 AM