locked
I can't choose folder for background slide show in Windows 7 RRS feed

  • Question

  • Hello!

    I don't know when and why it happened, but now I can't choose my own folder with wallpapers for background slideshow. I am talking about Control Panel -> Personalization -> Desktop Background -> Picture Location -> Browse. When choosing my own folder with wallpapers in "Browse" I click OK and... NOTHING HAPPENS. The Browse window just closes and I DO NOT see thumbnails from the selected folder. I just see previous selection of thumbnails.

    Attached please find a screenshot to better understand what I mean.

    Any ideas?
    Thanks!
    Sunday, October 25, 2009 10:43 AM

Answers

  • SOLVED!!!

    Researching the internet for solution, I came across the registry file below which openes wallpapers for all regions. Somehow imporing these registry settings fixed my problem.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Themes\InstalledThemes\MCT]
    "C:\\windows\\Globalization\\MCT\\MCT-AU\\Theme\\AU.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-CA\\Theme\\CA.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-DE\\Theme\\DE.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-GB\\Theme\\GB.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-JP\\Theme\\JP.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-US\\Theme\\US.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-ZA\\Theme\\ZA.theme"=""

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\KnownFolders\0\Windows Wallpapers\MergeFolders]
    "C:\\windows\\Globalization\\MCT\\MCT-AU\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-CA\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-DE\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-GB\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-JP\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-US\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-ZA\\Wallpaper"=""

    • Marked as answer by Linda Yan Monday, October 26, 2009 1:02 AM
    Sunday, October 25, 2009 4:41 PM

All replies

  • Try putting into \Windows\Web\Wallpaper
    Sunday, October 25, 2009 11:31 AM
  • Try putting into \Windows\Web\Wallpaper

    This works, but it's very inconvenient to duplicate hundreds of wallpapers. It's much better just to indicate the folder and let Windows display wallpapers from there as IT WAS DESIGNED AND USED TO WORK.

    Also, do you know where in the registry I can find the location of folders listed under "Picture Location" (see screenshot: http://yautja.headphones.ru/Where.jpg)
    Sunday, October 25, 2009 12:53 PM
  • I have exactly the same problem with Windows 7 64 bit except that it worked once and then wouldn't work again.
    To edit the registry to remove folders/pictures from the non default location have a read here http://www.thewindowsclub.com/remove-wallpaper-location-history-from-personalization-in-windows-7
    Sunday, October 25, 2009 4:03 PM
  • SOLVED!!!

    Researching the internet for solution, I came across the registry file below which openes wallpapers for all regions. Somehow imporing these registry settings fixed my problem.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Themes\InstalledThemes\MCT]
    "C:\\windows\\Globalization\\MCT\\MCT-AU\\Theme\\AU.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-CA\\Theme\\CA.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-DE\\Theme\\DE.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-GB\\Theme\\GB.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-JP\\Theme\\JP.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-US\\Theme\\US.theme"=""
    "C:\\windows\\Globalization\\MCT\\MCT-ZA\\Theme\\ZA.theme"=""

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\KnownFolders\0\Windows Wallpapers\MergeFolders]
    "C:\\windows\\Globalization\\MCT\\MCT-AU\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-CA\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-DE\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-GB\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-JP\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-US\\Wallpaper"=""
    "C:\\windows\\Globalization\\MCT\\MCT-ZA\\Wallpaper"=""

    • Marked as answer by Linda Yan Monday, October 26, 2009 1:02 AM
    Sunday, October 25, 2009 4:41 PM
  • How did that work for you Linda Yan and Yautja Hunter? Importing those registry entries did NOT work for me. I have the exact same problem. No matter WHAT I try, I cannot add new locations to the dropdown located in Personalization > Desktop Background > Picture Location: Browse.

    Wednesday, May 25, 2011 6:35 AM
  • Well, I'm another victim of the browse button not working.  Deleted the registry entry:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\KnownFolders\  but it did not fix the button problem.

    I have another login account for my wife on the computer and her browse button works.

     

    I did have success getting my picture folder to appear by following the advice to:

     

    Try putting into \Windows\Web\Wallpaper

    As Yautja Hunter said: "This works, but it's very inconvenient to duplicate hundreds of wallpapers. It's much better just to indicate the folder and let Windows display wallpapers from there as IT WAS DESIGNED AND USED TO WORK."
    Thursday, February 2, 2012 3:47 PM
  • I just started having the same problem and none of the proposed solutions worked for me (on any user accounts).  Any other ideas? 

    EDIT:  I fixed it!  I right-clicked one of the images I wanted to use and selected "Set as desktop background".  As soon as I did the folder appeared in the Personalize window and all is well again.  Hope this helps anyone else having the problem!

    • Edited by Farlo0 Thursday, June 6, 2013 5:37 PM
    • Proposed as answer by ae.ra Tuesday, July 10, 2018 10:17 AM
    Wednesday, June 5, 2013 8:42 PM
  • Hay THANKS . . . was having the same problem, and nothing I tried fixed it.  but when I tried your fix above ( EDIT:  I fixed it!  I right-clicked one of the images I wanted to use and selected "Set as desktop background".  As soon as I did the folder appeared in the Personalize window and all is well again.  Hope this helps anyone else having the problem!)   . . .  it worked for me ! !  Thanks again ! ! ! for posting your solution ! !

    My only question to Microsoft is. . . . why doesn't the browse button work???


    • Edited by Just a user Monday, June 24, 2013 8:15 AM spell check, duhhh
    Monday, June 24, 2013 8:14 AM