locked
hpqscnvw has stopped working RRS feed

  • Question

  • HP Solution Center (the scanning software that comes with many HP scanners) has a bug in that it crashes if tablet functionality is enabled in Vista.  You do not have to have a TabletPC, as graphics tablets such as Wacom use the same (Microsoft) drivers.

    Getting bounced between HP and Microsoft on this issue, which has still not been acknowledged or resolved after many weeks of escalation.

    More information here: http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1125399
    Friday, September 14, 2007 1:31 AM

Answers

All replies

  • Still getting no response from HP, so an online petition has been started here: http://www.PetitionOnline.com/hpqscnvw/petition.htm

    (Note: This petition is not in the HP forum, because they keep deleting the post to prevent customers from seeing it)
    Wednesday, November 28, 2007 1:03 PM
  • Thanks for the info and for the link to the petition.  I went ahead and signed the petition as well.

    Just as an FYI, you can disable the tablet PC services (temporarily, or permanently if you do not use tablets) in order to perform the scans.  Instructions on how to do so can be found here:

    http://www.extremetech.com/article2/0,1697,2110598,00.asp

    Good luck! & Merry Christmas!
    Tuesday, December 25, 2007 7:31 PM
  • You guyz rock. I spent eight hours last sunday trying to figure out why my hp scanner wasn't working. I tried ever fix on the web site and nothing worked. I googled "hpqscnw has stopped working" and was pointed to this site. Turn off the tablet service in windows and bingo the scanner is working again. Unfortunately the digitizer doesn't work now but on step at a time. Thank you. It all about the right information. So now, how do I gix both the scanner and the bamboo digitizer?

     

    Brandon

     

    Tuesday, January 29, 2008 11:56 PM
  • kudos to you on solving my problem! i've signed the petition as well.
    Wednesday, February 27, 2008 8:00 PM
  • BIG THANKS! It did work. We went to the services, switched off the Tablet services and BINGO. The scanning worked fine. Would be nice if HP would work on a fix. Or at least acknowledge the problem, because it took us some searching before we found your post. Thanks!

     

    Monday, March 10, 2008 1:49 PM
  • The folks on that board identified a permanent patch which worked for me

     

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15179&prodSeriesId=214599&prodNameId=214604&
    swEnvOID=2100&swLang=8&mode=2&taskId=135&swItem=cs-58181-1

     

    no more temporary stopping the tablet services - hurray

    Tuesday, April 1, 2008 1:33 PM
  • Except that there's still no fix for 64-bit Vista, which has the exact same problem...

    Monday, April 14, 2008 8:20 AM
  • I've Vista 64 bit and the patch solved the problem for me ...

    Sunday, April 27, 2008 2:02 PM
  •  

    i've vista ultimate 32 bit and the patch worked very fine, thank you!!!
    Sunday, June 22, 2008 12:33 AM
  • HI,

     

    I think I have a solution to the "hpqscnvw has stopped working" problem.  It is caused by manually using the All-in-One to copy either black and white, or color.

     

    To solve the problem:

     

    Unplug the All-in-One machine.  Turn it off and back on again.

     

    Get the latest driver for your version of HP All-in-One. 

     

    Uninstall every part of HP software.  When you have done this go to Program Files and delete the HP folder, i.e., get rid of all HP files that are left on your computer. 

     

    Turn off your computer and restart it. 

     

    Install the HP All-in-One driver.  Choose the standard installation.  You must register your HP machine, because the software searches the net to check to see if you have a registered version.

     

    You will find that the software will work when you copy with HP Solution Center now.

     

     

    Note!  When you copy manually using the buttons on the HP All-in-One machine always unplug the machine from the tower or laptop.

     

    When you have finished, unplug the All-in-One machine from the mains electricity supply.  Turn off your computer.  Restart it.

     

    Plug the AIO machine back into the mains and plug it into the tower or laptop. 

     

    The software will copy okay from the computer now.

     

    Thursday, November 13, 2008 7:03 AM
  • This Patch also worked for me. I am running 64Bit Vista Ultimate. Thanks for the link stuartjs!!!

    Sunday, November 23, 2008 3:08 AM
  • This patch worked for me too. I am running windows ultimate 64bit. Thanks for the link Stuartjs!

    Sunday, November 23, 2008 3:09 AM
  •  

     If you have to squeeze off a scan... trying going into Paint.exe and then File, Scan.  That worked despite the HP software not functioning. 

     

    I was also told by HP to go In Start>Services> I had to stop HP CUE Device Discovery, then set it to manual. apply, OK. 

     

    Doing the tablet services did nothing for me.

    On the advice of HP I also tried the following.  My printer is a f4180. it used to work fine... must be an update bug.

    HP Patch Link

    http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=cj-64024-1&lc=en&dlc=en&cc=us&product=3192753&os=2093&lang=en

    HP Scanner Diagnostic link

    http://h10025.www1.hp.com/ewfrf/wc/genericSoftwareDownloadIndex?softwareitem=oj-45265-1&cc=us&lc=en&dlc=en 

    Niether of these worked for me... and I was told by HP to uninstall the software, USING the CD to uninstall. and not windows, and reinstall.  I did find an error with the "digital imaging monitor" when I ran the above Scanning diagnostic software applet, but pressing fix and fixing the issue did not fix the problem in the end.

     

    Hope this helps or at least helps you skip a few annoying steps.

     

    Here is a link to the troubleshooting steps:

    http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&dlc=en&cc=us&lang=en&custom_solutionid=rb20020002&docname=c00896190

     

    Cheers

    Thursday, December 4, 2008 3:14 AM
  • Thanks so much! I'm using Windows 7 build 7000 and couldn't get the darn scanner to work. Had to uninstall and re-install. Then set the compatibility to Vista, and run as administrator. However stopping tablet input services worked! Go my scanning done and hope i don't forget in the future to stop the tablet input while i scan.

    Thanks again,
    Bob
    Thursday, March 19, 2009 8:03 PM
  • What did the trick for me was restarting all of the HP services
    Wednesday, April 22, 2009 2:09 PM
  • Thanks very much for the link, IT WORKED!!!!!!, I have spent hours researching the problem to no avail. I am in the UK. I have 64 bit Vista Home Premium, running the HP Officejet L7680 All-in-One on the HP Touchsmart IQ525.............all running like a dream now.........ONCE AGAIN A HUGE THANK-YOU!
    Monday, August 3, 2009 11:49 AM
  • Yay for the benefit of technical forums! Here I am over a year after this thread, reaping the benefit of someone's discourse. I too have Vista 64 and the patch worked for me.
    Tuesday, August 4, 2009 5:06 PM
  • This worked great for me on an X64 Vista machine.

    Turning off the tablet pc service and then trying to scan is a good test to see if you need above patch.
    Wednesday, August 26, 2009 9:21 PM
  • Thanks for the patch! It was really frustrating not to be able to scan anymore.
    Wednesday, October 14, 2009 5:23 PM