none
Project Server 2013: Microsoft Project Site template not available RRS feed

  • Question

  • I hope I'm not just missing something.  I have an on-premise instance with SharePoint permissions, and I am trying to make modifications to the site template.  I go into Site Content / new subsite from within the PWA site, but I cannot see the Microsoft Project Site template (even from the Enterprise tab).  I can create a project using the Enterprise Project EPT, which uses the Project Site site template.  It seems to create it with the Deliverables, Risks, and Issues lists under the Recent link, which is curious.  Am I missing a blog somewhere or did something happen when we created the PWA site?  Project sites seem to be working fine otherwise.

    Thank you in advance for your help.


    Larry Christofaro, PMP, MCITP Tribridge

    Monday, April 15, 2013 3:27 PM

Answers

  • Larry,

    Project Site is listed on Collaboration page.

    Another way is to create dummy project first with Project Site. Delete project plan without deleting Project Site.

    Customize Project Site as desired and save as template.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Monday, April 15, 2013 7:38 PM
    Moderator

All replies

  • Larry,

    Project Site is listed on Collaboration page.

    Another way is to create dummy project first with Project Site. Delete project plan without deleting Project Site.

    Customize Project Site as desired and save as template.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Monday, April 15, 2013 7:38 PM
    Moderator
  • This seems to work from preliminary testing, thank you.  The concern is that it has always been a requirement to create the site template directly from SharePoint and NEVER use a site that was created from a new project.  I don't know the details behind that statement as that is what I've always done.  Thank you again.

    Larry Christofaro, PMP, MCITP Tribridge

    Wednesday, April 17, 2013 1:52 PM
  • Hello, Best practise is to always create a new site from PWA (not an existing site linked to a project), modify it then save it as a template. When you use a site that is already linked to a project that site will have certain properties set in the site property bag, project guid and PWA URL etc. Thanks Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Wednesday, April 17, 2013 3:39 PM
    Moderator
  • Paul,

    Yes, I am aware about this issue, hence recommended to delete the test project plan , so that site will be disassociated from the project plan before saving the site as template


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, April 17, 2013 3:58 PM
    Moderator
  • Yes, which was my concern.  It would be great to understand why I never got a Microsoft Project Site template during the initial install.  Anyway, we will be in testing for some time so we should be able to validate how well it works before production.  Thanks again to both of you.

    Larry Christofaro, PMP, MCITP Tribridge

    Thursday, April 18, 2013 5:03 PM
  • I created a new Project Site on Project Server 2013 using the Project Site Template. Then I customized the site with the intention of making the site a template for use with an Enterprise Project Type. When I tried to save the site as a template on the Site Settings page, there was no option for Save Site as Template. The Publishing Feature is active for the site or the site collection.

    I tested creating a new site with the Project Site template and did not customize it. When I checked Site Settings, the option for Save Site as Template was not available.

    Why is this option not available for the Project Site Template?

    Wednesday, June 11, 2014 4:45 PM
  • Kalomi, you need to deactivate the SharePoint Server Publishing feature in order to save as a template. This feature is what's preventing the Save as a Template option.

    Larry Christofaro, PMP, MCITP

    Wednesday, June 11, 2014 5:15 PM
  • Hi,

    From the site settings, have you activated the Sharepoint Enterprise and standard collection site features? It has to be done for the site collection, not only for the site.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, June 11, 2014 5:28 PM
    Moderator
  • Hi, Guillaume and Larry: I deactivated the SharePoint Server Publishing Infrastructure from the Site Collection Features of the top level SharePoint site collection; however, after refreshing the Project Server and then creating new sub sites, the Save Site As Template option still did not appear. Do I need to wait for a timer job to complete on Project Server? I also checked the PWA Permissions and Save Site Templates is selected.

    Thank you for your help!

    Friday, June 13, 2014 3:45 PM
  • Did you check in the site settings that

    • Sharepoint Enterprise collection site feature
    • Sharepoint standard collection site feature

    are activated?


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Friday, June 13, 2014 3:52 PM
    Moderator
  • Yes, thanks!
    Friday, June 13, 2014 5:43 PM
  • Make sure that publishing is turned off for the site and a site just created from a template.  Can you create a site template from a site created from another template besides the project template (like the Team Site)?  In my opinion it is either your permissions or a feature embedded in the site, unless Guillaume has another thought.

    Larry Christofaro, PMP, MCITP

    Friday, June 13, 2014 6:58 PM
  • I have Farm Admin and Site Collection Admin permissions. Publishing is deactivated for the entire SharePoint site collection as well as the SharePoint site. The SharePoint site collection and the PWA site collection have these settings:

    • SharePoint Server Enterprise Site features - Active
    • SharePoint Server Standard Site features - Active
    • SharePoint Server Publishing - Not Active

    Today in the PWA, I created a new BlogTest site with a SubSiteTest. Both sites have the settings shown above. Neither of the sites show Save Site As Template in their Site Settings.

    Although an MSDN articles states that when setting up an SP 2013 Web App PWA for the first time it doesn't matter what site template is used to create the top-level SharePoint site collection, perhaps we should try to delete our current SharePoint Web Application with PWA and create a new one with a Team Site as the top level site template? Are there any issues with branding this type of template? In SP 2010, it was preferable to use a Publishing Site template for branding. Perhaps with this is no longer true with 2013? Maybe the Save Site As Template option will return.


    • Edited by Kalomi Monday, June 16, 2014 4:53 PM
    Monday, June 16, 2014 4:51 PM