none
Failed to create the OLAP database on the server (2013 on prem) RRS feed

  • Question

  • Hello,

    I'm trying to build the first OLAP Cube on a new instance Project Server 2013. But I get the following error :

    Failed to create OLAP cubes. Error: Failed to create the OLAP database on the server winsrv-FR. The (Analysis Management Objects) client software AMO SQL Server Analysis Services is perhaps not installed on this server. Please install / update the client on the server and try again. The underlying exception was: Could not load file or assembly 'Microsoft.AnalysisServices, Version = 10.0.0.0, Culture = neutral, PublicKeyToken = 89845dcd8080cc91' or one of its dependencies. The specified file was not found.

    I was pretty sure to installed the AMO. How to check if something is missing about the AMO?

    Thanks for your help

    Sunday, October 5, 2014 11:50 AM

All replies

  • do you have a seperate sql server and application server?  If so then AMO might not be installed on both machines.

    Hope that helps

    John

    Sunday, October 5, 2014 12:11 PM
  • Hi,

    You can refer to these articles, it might help you out.

    • http://epiciw.wordpress.com/2011/06/03/sql-analysis-services-cube-still-doesnt-build-after-installing-the-amo-components/
    • http://epmpoint.wordpress.com/2013/05/06/building-the-olap-cube-for-project-server-2013/
    • http://technet.microsoft.com/en-us/library/ee662106.aspx
    • http://blogs.msdn.com/b/brismith/archive/2012/11/12/project-server-2013-requirements-to-build-an-olap-cube.aspx

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, MCP |

    Sunday, October 5, 2014 12:27 PM
    Moderator
  • Hi john,

    That a test install. SQL Server and Application server are on the same machine

    Sunday, October 5, 2014 12:32 PM
  • Hello WLID1966

    What version of SQL Server are you running.  Project Server doesn't like the latest version of AMO.  It wants an other version like in SQL 2008 R2. 

    THe AMO was installed when you installed the pre-requisites.  That's the version it likes. 

    Look in your control panel / Programs and see what is installed. If you see two versions of the AMO, remove the most recent.

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Sunday, October 5, 2014 12:45 PM
    Moderator
  • Hello Michael,

    I'm running SQL Server 2012 and I installed SQL Server 2012 AMO.

    How to uninstall AMO 2012 and Reinstall 2008 R2 ? Not any specific trick ?

    Thanks

    Sunday, October 5, 2014 3:48 PM
  • WLID1966,

    I don't think you have to unsinstall 2012 version. Install 2008 R2 version and make sure that Project application is restarted


    Hrishi Deshpande Senior Consultant

    Monday, October 6, 2014 9:35 PM
    Moderator
  • Hi,

    I had a similar issue and I just wanted to confirm that installing 2008 R2 version helped. And there is no need to uninstall higher versions (e.g. 2012)

    Paul

    Tuesday, October 7, 2014 11:57 AM
  • Hello Paul,

    You can have them both installed. I have sites with both versions of AMO installed.  Apparently Project Server uses a signature to find the one it needs.

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Tuesday, October 14, 2014 3:53 AM
    Moderator