none
Windows update needs your help notofication message RRS feed

  • Question

  • I keep on getting the message:

    Windows update needs your help
    Windows Update hasnt been able to check for new updates for the last 30 days. Go to windows update to resolve this issue.

    I have set the windows update settings to never check for updates... Is there any way that i can disable this message from popping up?
    Saturday, August 3, 2013 3:30 AM

All replies

  • Why do you disable Windows Update?

    "A programmer is just a tool which converts caffeine into code"

    Saturday, August 3, 2013 7:07 AM
    Answerer
  • Im using SCCM to deploy patches as a centralized patch deployment system. I dont want users to be able to install the patch by themselves.
    Saturday, August 3, 2013 8:57 AM
  • Hi,

    If you depoly Windows Update via SCCM, there is no need to disable Windows Update. Please configure the group policy correctly and Windows Update won't check from Internet.

    Configure Automatic Updates by Using Group Policy
    http://technet.microsoft.com/en-us/library/cc720539(v=WS.10).aspx


    Niki Han
    TechNet Community Support

    Tuesday, August 6, 2013 5:05 AM
    Moderator
  • Hi Niki

    We have configured in the group policy correctly and i does not check the updates from internet. What i mean is the message as below screenshot... It will still pop up if updates hasnt been checked for the last 30 days... Anyway to disable it?


    • Edited by Efa77 Tuesday, August 13, 2013 2:54 AM
    Tuesday, August 13, 2013 2:54 AM
  • Anyway to disable the above windows update message?
    Sunday, August 18, 2013 9:28 AM
  • Efa77,

    Did you ever find a solution for this problem? I have the same issue and have not found a way to suppress the popup. Would love to know if you found a way to do so.

    Thanks,

    Bill

    Monday, September 30, 2013 5:39 PM
  • Actually no i havent... Still figuring out how..
    Monday, November 25, 2013 8:50 AM
  • We are running into this as well. Has anyone found a solution in the past couple of months?
    Monday, February 10, 2014 3:25 PM
  • Hi All,

    I'm curious as to the proper configuration to prevent this message from being displayed on Windows 8/8.1 clients as well.

    Thanks!

    -Brian

    Monday, March 3, 2014 7:46 PM
  • I am having the same issue in our organization. We use SCCM to push updates and this msg still pops up. Any answers?
    Wednesday, March 12, 2014 8:23 PM
  • I came across this, please let me know if it helps?

    http://blogs.technet.com/b/senthilkumar/archive/2014/03/11/how-to-disable-quot-windows-update-needs-your-help-quot-pop-up-in-windows-8-8-1-clients.aspx

    I am going to talk with Infrastructure team to see if we can implement this.

    Wednesday, March 12, 2014 8:52 PM
  • nerdyCool,

    We have the 'Configure Automatic Updates' setting already set to 'Disabled' as per the above article and the workstations are still reporting the 30 day message.  It was my understanding that not disabling this could potentially allow SCCM managed clients to restart outside of scheduled maintenance windows (ie. the standard windows update client would install/reboot at a random time as well as display duplicate popups or notifications).

    -Brian

    Wednesday, March 12, 2014 9:06 PM
  • Is there any new information on this?
    Thursday, April 17, 2014 2:40 PM
  • It has to do with the registry key

    hklm:\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\Results\Detect

    and the value LastSuccessTime

    Once it approaches 30 days that message will show up.  This can occur if you may be building systems, then shelving them, but windows update is enabled in your image.  If you don't let SCCM get the policy to manage the system first, you may get that message.  Even so, I think you may get that message even if CCMExec is the callerID for Windows update.

    To remedy, modify the HKLM:\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update Key's NextDetectionTime value to something in the past and restart windows update service (wuauserv).

    Here's some powershell to do the dirty work:
    $Date = (Get-Date -Date (get-date).AddDays(-1) -Format u).tostring().replace("Z","")
    set-itemproperty -path "HKLM:\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" -name NextDetectionTime -value $Date
    restart-service wuauserv


    nick

    (Note:  THe above code will force a detection to windows update.  If you don't have your policy in place to point to your managed wsus environment, the system may go to windows update and update, depending on your policies... just showing that the script will trigger the scan that populates the value that avoids the message.  We chose to have the system scan as we do have a managed environment but aren't currently scanning for updates.  THis just gets rid of the message (we have a DCM in place to detect the age of the scan value and, after 20 days, run as scan just to keep the message from popping up).

    • Edited by nick.aquino Thursday, April 17, 2014 3:21 PM disclaimer
    • Proposed as answer by JustGuy Thursday, January 22, 2015 8:35 PM
    Thursday, April 17, 2014 3:17 PM
  • Hi

    Any update we also have seen this popup on some computers. We use SCCM 2012 R2 and Windows 8.1


    Thomas Z


    • Edited by Thomas Z Thursday, June 26, 2014 1:44 PM
    Thursday, June 26, 2014 1:44 PM
  • Thomas, did you see my note above?  What's the behavior if you modify the registry value? 

    nick

    Thursday, June 26, 2014 3:26 PM
  • We experienced this issue in our environment.  We opened a Microsoft Premier case, spent a ton of time, found a workaround, and maybe a fix.  We are a domain environment with SCCM 2012 managing our software updates.  Our PCs are running Windows 8 Enterprise.

    What we found was, intermittently, "some event" occurs on our PCs that caused the PC to think there was a failed update detection.  These events occurred after the PCs were deployed to users, were not tied to PCs that were off the domain for an extended period of time, and occured on both notebooks and desktops.  The desktops never left the network. 

    This failed detection caused the following registry values to be written.  The FirstDetectionFailureTime was the time stamp of the failed detection event.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
    "FirstDetectionFailureTime"="2014-04-17 08:50:55"
    "ShowUnableToDetectUI"=dword:00000001

    Our PCs are set to check for updates every day.  The issue is even if the next detection was successful, the PC never goes back and automatically cleans up the FirstDetectionFailureTime registry value.  30 days after the FirstDetectionFailureTime, the user will receive the banner.  The PC will continue to display the banner every 30 days while this FirstDetectionFailureTime registry value is there. 

    A user can manually stop the banner from appearing by clicking the "Go to Windows Update" button and choosing check for updates.  The process will delete the registry values above (most importantly, delete the FirstDetectionFailureTime value). The cycle will be stopped until the next event.

    Most of this we found out on our own. Microsoft Premier Support never could see past this article:  http://blogs.technet.com/b/senthilkumar/archive/2014/03/11/how-to-disable-quot-windows-update-needs-your-help-quot-pop-up-in-windows-8-8-1-clients.aspx. Where within this article, they stated the corrective action was to set the following group policy to Disabled.  The interesting thing about this policy, is it is setting a registry value (see below the policy) that the SCCM agent is already setting (as was mentioned above in this thread).  However, Microsoft swore this was the fix in spite of it appearing this was already set on our PCs.

    Computer configuration>Administrative Templates>Windows Components> Windows update> Configure Automatic updates

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000001  

    To workaround the banner displaying, we have intentionally set the following registry value to 0 on all our PCs.  We have proved that this will suppress the banner from displaying even if the FirstDetectionFailureTime value exists.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
    "ShowUnableToDetectUI"=dword:00000000

    We also have configured the following group policy to Disabled, as Microsoft suggested.  We then monitored all of our PCs for new FirstDetectionFailureTime values with timestamps after the group policy change was made.  We found that whatever was causing the FirstDetectionFailureTime registry value to written was still intermittently occuring.  It seemed to randomly occur on different PCs.  The group policy did not make a difference. 

    Computer configuration>Administrative Templates>Windows Components> Windows update> Configure Automatic updates

    What did make a difference was setting the ShowUnableToDetectUI registry value to 0 definitely suppresses the banner from showing.

    Hope this helps!





    • Edited by dagonr Wednesday, March 11, 2015 6:12 PM
    Friday, January 23, 2015 2:49 PM
  • Thank you, dagon4 & Nick Auino, for these suggestions. Unfortunately, they didn't work for me.

    I didn't disable automatic updates, but I added the ShowUnableToDetectUI key (set to 0), which didn't help.

    I've put some screenshots and notes on my web site, here:
    http://geeksalive.com/windows_update_needs_your_help/

    Would either of you be willing to export your (working!) [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update] entry to a .reg file, and post it or send it to me, please?

    My email address is here:
    http://geeksalive.com/email/

    Thanks!


    • Edited by BurtonSys Monday, March 9, 2015 6:39 PM
    Monday, March 9, 2015 6:35 PM
  • Here ya go:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
    "CachedAUOptions"=dword:00000000
    "InstallInProgress"=dword:00000000
    "UpdatesAvailableForDownloadLogon"=dword:00000000
    "UpdatesAvailableForInstallLogon"=dword:00000000
    "UpdatesAvailableWithUiOrEulaLogon"=dword:00000000
    "UpdatesAvailableWithUiLogon"=dword:00000000
    "FirmwareUpdatesNotDownloaded"=dword:00000000
    "FirmwareUpdatesNotInstalled"=dword:00000000
    "NonFirmwareUpdatesAvailableForInstall"=dword:00000000
    "NextDetectionTime"="2015-03-05 06:24:12"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\Power]
    "Firmware-Final"=dword:0000001e
    "OfferInstallAtShutdown-Final"=dword:00000028
    "ContinueInstallAtShutdown-Final"=dword:0000000a
    "FirmwareForcedInstall-Final"=dword:00000023

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\UAS]
    "UpdateCount"=dword:00000000

     


    nick

    Wednesday, March 11, 2015 3:50 PM
  • I updated my post from the original to provide some information based on the last couple months.  Again the workaround we found seems to have suppressed the prompt for us.

    @BurtonSys:

    It may be helpful for you to show your [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update] values.  It sounds like your issue is different than ours.  Is this a SCCM managed system or a system that gets updates from Microsoft or a corporate WSUS?  Have you tried disabling Windows Updates, rebooting, and then renabling?  Do you have the following update installed http://support.microsoft.com/kb/2919355?

    Wednesday, March 11, 2015 6:21 PM