locked
Boot Process Fails after CRCDISK.SYS RRS feed

  • Question

  • Greetings,

    I have the CRCDISK.SYS phenomenon.

    I have a sager 5791 laptop with Vista Ultimate 64 running on it.

    I powered the laptop down in Vista and pulled the power cord.  I did not watch it shut off so there may be a chance that it did not completely shut down and the turned off when the battery ran out.

    At any rate, when I tried to power up again, I got as far as the loading windows phase when the hard drive stopped spinning.  The hard drive indicator will flash approx ever sec.

    Loading in safe mode, I watched the files load until the hard drive stopped and the files stopped loading.  Last file loaded is CRCDISK.SYS.

    I cannot the repair environment via the the installation disk as the computer stops; nor can I install.

    Spinrite test revealed zero errors.

    Researching the issue on the internet reveals nothing except that the causes are presumably rather varied.

    Any ideas on where to go from here?

    If this OT I apologize; point me in the right direction and I will happily go away.

    Thank you,

    Loch

    Saturday, April 5, 2008 5:10 PM

Answers

All replies

  •  

    Hi Loch,

     

    Thanks for posting here!

     

    I understand that the system is not bootable and it stops at CRCDISK.SYS while entering Safe Mode.

     

    Loch, before we go further, I suggest we check the threads below as it has been discussed in the forum before:

     

    Presario C502TU NB stops after loading crcdisk.sys... Sata HDD

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2997327&SiteID=17  

     

    crcdisk.sys causing boot delay

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2867700&SiteID=17

     

    Best regards,

    Monday, April 7, 2008 9:05 AM
    Moderator
  • Sean,

    Thanks for the reponse.

    I did note those threads.  The presario thread was peculiar to the presario; that being said, I gave it a go.  I was able to get into some of the Vista folders by booting into Ultimate Boot Disc 4 Windows (UBCD4Win).  I made the changes recommended but to no avail.  I could extrapolate out and attempt to lock down all of the devices that I have on the computer in the same manner in an attempt to isolate however, I do not know where to go for each device.  It makes sense to give it a go but I am kind of stymied by lack of knowledge.

    The second thread again did not directly translate in that I did not have an external WD drive attached at the time (nor do I have one internally (seagate momentus)).  I did have a USB stick (Sandisk Micro Cruzer) that I had attached until I pulled it out after I thought the box had shut down.  I put the stick back in the port in order to replicate the peripheral environment that existed before shut down but was unable to boot beyond CRCDISK.SYS.  Using the UBCD4Win disk I was able to get into the Vista drive and temporarily renamed the hibernation and page files to no discernible difference.  I tried to get into the System Volume Information folders but could not access them via the XP environment presented by UBCD4Win.

    What I know (or at least am reasonable confident of)
    SP1 is not a factor.  (I had been offline for several days before hand and the box had been operating fine between the time I was last connected and when it started exhibitng these symptoms.  I do not know if there is a way to see if SP1 had been applied WITHOUT having to boot up).

    I had only one peripheral attached to the machine at or around the time that it failed.

    There were no discernible issues before I set the machine to turn off.

    What I suspect:
    The shut down failed, the machine lost its power source, and either just lost power or hibernated ineffectively.

    Counterevidence:
      Safemode would be a new boot occasion; not a situation where Vista would pick up where it was last - at least to some degree.
      Similarly, last known good configuration.
      The fact that I cannot get into repair mode also dramatically suggests that there is something else going on.

    I am making the assumption that the repair mode would actually require the least amount of preexisting information in order to load.  So what would those minimum requirements be?

    I didn't mean to write a dissertation here but I am swimming at the deep end here (at least it is the dep end for me).  I apologize for not having a very specific question to ask but I honestly do not what questions to ask.


    Anyway,

    Thanks for any assistance and for your time,

    Loch

    Tuesday, April 8, 2008 9:57 PM
  •  

    I am really surprised to see the exact same thing happen with my machine. It is an Alienware Area 51 m15x running Windows Vista 32Bit. I distinctly remember that several problems started after the Vista SP1 install. I started seeing the blue screen of death a couple of times but chose to ignore and restart.

     

    Then one fine day, I switch on the machine to see that it never goes beyond the Progress Bar screen- the one with the continually circling progress indicator and Microsoft Corporation on it. I tried safe mode boot and it continues loading files till it reaches CRCDISK.SYS - stops completely after that. Tried popping in the system recovery DVD and booted from that. This takes me to an intermediate screen that says "Windows is loading files" and then goes to the same progress bar screen mentioned before. After that I am greeted with a black screen with no activity.

     

    This happened after a proper shutdown had been performed on the machine. The only peripheral that I had still attached to the machine was a Sound Blaster XFi notebook sound card. Also the only other peripherals that I ever connect to the machine are the Xbox 360 game controller and a USB mouse - Logitech. Thats about it.

     

    Any advise is recommended.

     

    Before reading this post I assumed together with assistance from Alienware tech support that the Hard Drive was bad and have sent it in for replacement. Please advise as to whether this could be a hardware issue.

    Thursday, April 24, 2008 4:24 PM