locked
Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005 RRS feed

  • Question

  • Windows 10 x 64 Event Log shows following error

    //

    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Toegang geweigerd.  (=accessed denied)
    . This is often caused by incorrect security settings in either the writer or requestor process.

    Bewerking:
       Schrijvergegevens verzamelen (=gathering writer data)

    Context:
       Klasse-id van schrijver: {e8132975-6f93-4464-a53e-1050253ae220}        (=writer class id)
       Naam van schrijver: System Writer                                                        (=writer name)
       Instantie-id van schrijver: {b65f652c-6114-48fc-829c-977f40e6df77}        (=writer instance id)

    //

    (note: this is windows 10 x64 dutch, with English language pack, often translations are 'so-so')

    solution: run services.msc, select volume shadow copy, set to start + automatically = apply

    However . . .

    Question: how to detect what caused VSS to be set to 'manual' in first instance?

    The only other entry in Event Log -source 'VSS' is:

    Volume Shadow Copy Service: Writer with name MSMQ Writer (MSMQ) and ID {7e47b561-971a-46e6-96b9-696eeaa53b2a} attempted to subscribe during setup.

    Bewerking:
       Schrijver initialiseren  (initiliaze writer, or something)

    Context:
       Klasse-id van schrijver: {7e47b561-971a-46e6-96b9-696eeaa53b2a}
       Naam van schrijver: MSMQ Writer (MSMQ)
       Instantienaam van schrijver: MSMQ Writer (MSMQ)

    =

    Thanks

    =

    p.s. Meanwhile I believe this service is set to 'manual' by default..?

    https://technet.microsoft.com/en-us/library/dd364925(v=ws.10).aspx

    If indeed this service is set to 'Manual' by default, why is it causing event log errors?
    and he solution is to set it run automatically.

    =

    Sunday, August 23, 2015 2:46 PM

All replies

  • Mike884

    This error is caused by incorrect or missing COM access permissions and does not affect the use of Image for Windows or the 3rd part security applications.

    If you got any third part security app installed, please disable or temporally remove it to check the issue.

    Then try following steps:

    1. Press and hold the Windows key and press R to pull up the Run dialog. Alternatively, ifRun... is available from the Start Menu you can access it from there.

    2. Type dcomcnfg into the box and click OK. The Component Services window will appear.

    3. In the left portion of the window, expand the Component Services section and then expand the Computers section.

    4. Right-click on My Computer (listed in the Computers section) and select Propertiesfrom the pop-up menu.

    5. Click the COM Security tab. The My Computer Properties dialog will appear.

    6. Click the Edit Default... button in the Access Permissions section. The Access Permission dialog will appear.

    7. Under the Group or user names box, click the Add... button.

    8. Type Network Service into the box and click OK.

    9. Click OK on both the Access Permission and My Computer Properties dialogs to close them.

    10. Restart Windows.
     


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 25, 2015 5:31 AM
  • Thank you so much for your reply. I do appreciate your taking the time to get me an elaborate reply. That said, I am sorry to say... but am afraid I will not be able to tell you if your solution will work: after updating from Windows 7 Ultimate to Windows 10 Pro, the Event Log is showing an ever increasing number of errors and warnings. Warnings/Errors were there right from the start (i.e. after the upgrade), but the number was fairly limited.
    Right now, there are soooo many, I have decided to go for a clean install.

    Thank you again!

    =





    Tuesday, August 25, 2015 7:07 AM