locked
Java 8 181 corrupted message on windows 7 enterprise RRS feed

  • Question

  • Hello!

    Trying to install java on my citrix VDI running windows 7 enterprise(64 bit). When attempting to install Java 8 update 181, I get an error message that provides the file path for the installation followed by is corrupt. I have tried about all the options found on the internet which included running as an admin, downloading the offline version, running the Microsoft utility tool to check for registry errors (nothing listed had java so not too sure of how the tool works).

    Now I know Java will install as I attempted to run the 32 bit version that installed without issue. I am trying to install an application though that requires 64 bit java and will not continue the installation until the 64 bit version is detected.

    I don't really know what else to do or try as I am pretty much stumped at this point.

    Tuesday, September 11, 2018 8:04 PM

All replies

  • Hi,

    you have posted in a forum for questions about internet explorer?

    Java JRT is an activex control in IE... To work on all websites in a managed environment you need to install both the x86 and x64 versions of java JRT from the java.com website.... There are instructions there for installing both versions. (http://java.com )

    Tools>Manage Addons>Show all addons.... locate the Java JRT libraries under the 'Oracle' entry and double click it to display its properties sheet, which will show details of the installed versions and their bitness.

    You may have to Allow the control to run on all sites.

    Outcomes for activeX controls also depend on which IE security zone a host is mapped to. (File>Properties menu will tell you which IE security zone the current host has been mapped to).

    The default IE settings, place the Internet and Restricted zones in Protected mode... meaning that they will only run 64bit activeX controls. The IE ActiveX filtering is enabled in these zones by default also. (see tools>ActiveX filtering)

    The Trusted and Intranet zones by default do not use Protected mode or the ActiveX filtering setting.... and will allow x86 assemblies to run. Clients with an x86 cpu, off coarse cannot run x64 assemblies.

    Have you tried contacting the application vendor for their recommendations about your Java JRT requirements.

    Regards.


    Rob^_^

    Wednesday, September 12, 2018 7:57 PM