locked
Hyper-V integration services Debian guest RRS feed

  • Question

  • Im running hyper-v on windows 10 pro, and i installed Debian as a guest (Hypervisor 1), when i attempt to run install.sh i get a error saying unable to determine Linux distribution .I'm not sure what to do.

    Sorry if my formatting is bad im kinda new to using forums i usually just figure stuff out or use google

    Tuesday, August 4, 2015 6:50 AM

All replies

  • What version of Debian?  https://technet.microsoft.com/en-us/library/dn614985.aspx lists the versions supported and which already have the integration services as part of the distribution.

    . : | : . : | : . tim

    • Proposed as answer by Leo Han Wednesday, August 5, 2015 1:29 AM
    Tuesday, August 4, 2015 1:26 PM
  • The downloadable Linux Integration Services are intended for use only with Red Hat, CentOS, and the Red Hat-Compatible version of the kernel in Oracle Linux. For Debian, Linux Integration Services are inherited from the upstream kernel (I think stable is based on the 3.16 kernel, and unstable is based on the 4.0.8 kernel). Most of what you want is already there, but on Debian, the daemon processes aren't packaged for use.

    Are you having troubles with your Debian installation?


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Wednesday, August 5, 2015 3:33 PM