none
DPM 2016 install fails at "Checking Prerequisites" if running SQL Server 2016 w/ SP1 RRS feed

  • General discussion

  • I'm building a new DPM server running Windows Server 2016.  I saw that DPM 2016 officially supports SQL server 2016 as of UR2, so I decided to go with that.  After installing SQL Server 2016 w/ SP1 on the DPM server, I tried installing DPM but ran into a problem.  At the "Prerequisites Check" stage, the install stopped with an error:

    An Unexpected Error occurred during the installation.  For more details, check the DPM Setup error logs.  ID: 4387

    After the DPMSetup.log file proved to be of little help, I started searching for this error online and found this blog post from someone with the same issue.  According to that post, the problem only occurs when SQL Server 2016 SP1 is installed, so the workaround is to remove SQL 2016 SP1, install SQL 2016 w/o the SP, install DPM 2016, install Update Rollup 2 for DPM 2016, and then install SP1 for SQL 2016.  

    I'm probably going to go ahead and go through that hassle so I can continue building this server, but I thought I'd post here to perhaps save someone else from running into this problem or at least help them find info about the issue once they're experiencing it.  

    Is MS aware of this problem?  If so, is there any fix available or forthcoming?

    If anyone has a better solution to install DPM 2016 with SQL 2016 SP1, please share it!  

    -- Neighborgeek

    Thursday, April 6, 2017 12:11 PM

All replies

  • I tried installing DPM 2016 using our SQL 2016 SP1 server and am seeing the exact same issue. Microsoft please fix ASAP or update your documentation to specify this is a known issue.
    Tuesday, April 11, 2017 1:07 PM
  • I second this. I need a fix for this ASAP. Re-installing SQL w/o SP1 is not really an option when the server is hosting other System Center components.
    Thursday, April 13, 2017 6:31 PM
  • Hi,

    SQL Server 2016 SP1 was released after DPM 2016 was released and the supported SQL server versions for System Center 2016 are documented here:  SQL Server version support   For ensured compatibility please do not deviate from the support matrix.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, April 13, 2017 7:52 PM
    Moderator
  • Same problem. Tried with SQL 2014 on same box and SQL 2016 RTM on a remote server. I think it's a bad installer.  
    Friday, April 28, 2017 6:18 PM