none
Red X (cross) over network drive on startup, Could not reconnect all network drives. RRS feed

  • Question

  • Hello, recently here at work we've been having more and more trouble with the "Could not reconnect all network drives" popup when users log on to their computer. All network drives have a red cross on their icon in explorer. It's a wired network.

    I've tried enabling the "Always wait for the network at computer startup and logon" policy under Computer Configuration/Administrative Templates/System/Logon in the Group Policy Editor, but this didn't help. Updating the driver for the network card also didn't help.

    Once a user clicks on a network drive it instantly becomes available and stays available until the next reboot. The problem is that users have got programs which rely on having connection to certain network folders. So now they first need to open windows explorer and click on each network folder to get it connect before they can open their program.

    I've noticed users getting this error more and more after changing from 3com switches to cisco 2960 switches.

    Anyone any ideas? (Switching back to 3com switches isn't an option)

     

    Sincerely,

     

    Peter 


    Friday, August 26, 2011 11:37 AM

Answers

  • Hello, thanks for your help. I seem to have found the problem. The switches are configured for spanning tree, now after changing the port where I'm connected on to use spanning-tree portfast instead of normal spanning-tree the problem disappeared. It seems the spanning-tree protocol causes a bit of a delay which explains why the network folders don't connect. But it also seems that the GPO

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon.

    Doesn't wait for a logical signal because if you read the GPO description I would expect it to wait for a network connection to our domain but it seems it only waits for a signal and not a domain signal, if you know what I mean.

     

    Thanks again for your help.

     

    Regards,

     

    Peter

    • Marked as answer by pproost Tuesday, August 30, 2011 9:42 AM
    Tuesday, August 30, 2011 9:42 AM

All replies

  • Interesting you mention the Cisco 2960 switches.  We recently rebuilt our wireless network and are supporting it with Cisco 2960 PoE switches.  Home directory mapping in very hit or miss and I had been focusing on the wireless network since desktop users were not experiencing the problem.  However the desktop users are not using the new Cisco 2960 switches either.  Now I wonder if I am looking in the wrong place for a problem/solution. 
    Friday, August 26, 2011 12:24 PM
  • I also wouldn't have considerd the switches if I hadn't noticed the problems didn't start occurring until the switches changed.
    Friday, August 26, 2011 1:09 PM
  • Hello Peter,

    Do you have other clients that not running Windows 7 also encounter the issue?

    What's the version of your server?

    This could help us narrow down to see if it's server related or clients related issue.

    Are those mapped drive can be access in a certain time or always available?

    Are there any auto disconnect settings on your server?

    If the connection time configured on your clients and server doesn't match, this issue could happen.

    And you mentioned:

    "Once a user clicks on a network drive it instantly becomes available and stays available until the next reboot."

    Do you mean when double-click the Red-X network drive, it can be connected immediatly? If so, the red-x might be caused by auto disconnection or third-pary software or offline file feature.

    Try a Clean Boot on both server and clients, check if the issue persists.

    If still happen, try disconnect and re-connect to see the result.

    If all the above not work, please provide us with more details.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 29, 2011 6:56 AM
    Moderator
  •  

     

    * Do you have other clients that not running Windows 7 also encounter the issue?

     We have other clients, Windows XP. They don't have the problem only the Windows 7 clients have the problem

    * What's the version of your server?

     The network drives are located on two servers

     - Server SOV16 which is a Windows Server 2003, Appliance edition SP2

     - Server SOV17 which is a Windows Storage Server 2003 R2 SP2 

    * Are those mapped drive can be access in a certain time or always available?

     

     There is no time restriction. The mapped drives aren't automatically available after booting. If a user then double clicks on a drive it becomes immediately available and stays available. (See the attached images, the first image is the situation after booting, the second image is after double clicking on the T: drive) 

     

     

    * Are there any auto disconnect settings on your server? 

    Is far as I know, NO

    * Try a Clean Boot on both server and clients, check if the issue persists.

     

     

    The issue persisted after clean booting

    * If still happen, try disconnect and re-connect to see the result.

    If I disconnect the mapped drive and reconnect it, it's immediately available. But after rebooting the red cross is back

     


    Monday, August 29, 2011 7:52 AM
  • I also did some further testing and if I let the task scheduler exute the following bat file one minute after logging on, all network drives are available without a red cross. So it seems to me that windows 7 is trying to connect to the network folders before it has a network available

    net use /delete t: /y

     

    net use t: \\sov16\transfer /persistent:yes

    net use /delete f: /y

    net use f: \\sov16\install.net /persistent:yes

    net use /delete o: /y

    net use o: \\sov16\vbsource /persistent:yes

    net use /delete u: /y

    net use u: \\sov16\doclibsrolmat /persistent:yes

    net use /delete v: /y

    net use v: \\sov16\doclibsit /persistent:yes

    net use /delete z: /y

    net use z: \\sov17\install /persistent:yes

    Monday, August 29, 2011 8:25 AM
  • Hi Peter,

    Thanks for the quick update and glad you find a workaround currently.

    How did you map those drives? Using logon script?

    Please configure the Group Policy:

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon.

    And add the following registry: (Note: Backup the registry firstly in case of any risks.)

    Locate: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters

    Name: KeepConn

    Type: DWORD

    Base: decimal

    Value: 65535

    Reboot to check if the issue persists.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 30, 2011 8:25 AM
    Moderator
  • Hello, thanks for your suggestion. I had already tried the GPO, but I've tried it again in combination with the registry setting. But no success, there are still red crosses and the popup telling: "Could not reconnect all network drives"

     

    Any more suggestions?

     

    Regards,

     

    Peter

    Tuesday, August 30, 2011 8:40 AM
  •  So it seems to me that windows 7 is trying to connect to the network folders before it has a network available

    I agree with you on this.

    I think you're using the logon script to map those drives. Right? It seems the scripts run firstly, then the computer connect to the network, therefore it shows the Red X. It's an expected behavior. After the computer connect to internet, try refresh Windows Explorer, will those Red-x disappear?

    I suspect your network connection maybe not stable recently. You can check the Event Viewer to see if there's any connection fail events.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, August 30, 2011 9:08 AM
    Moderator
  • The drives are always mapped. (I've added them locally via windows explorer)

    Refreshing the windows explorer doesn't connect the drives, I do have to click them. The network connection is a wired stable connection. But for the moment I'm looking into the switches because it could have something to do with a spanning-tree configuration at switching level. But I need to do some more tests for that. The problems only started occurring after switching to cisc 2960 switches and spanning tree.

     

    Regards,

     

    Peter

    Tuesday, August 30, 2011 9:17 AM
  • I suggest you also contact Cisco support to further look at this issue. Since I cannot test this on my side, it's hard to troubleshoot the problem.

    Thanks for your understanding and cooperation!

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 30, 2011 9:23 AM
    Moderator
  • Hello, thanks for your help. I seem to have found the problem. The switches are configured for spanning tree, now after changing the port where I'm connected on to use spanning-tree portfast instead of normal spanning-tree the problem disappeared. It seems the spanning-tree protocol causes a bit of a delay which explains why the network folders don't connect. But it also seems that the GPO

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon.

    Doesn't wait for a logical signal because if you read the GPO description I would expect it to wait for a network connection to our domain but it seems it only waits for a signal and not a domain signal, if you know what I mean.

     

    Thanks again for your help.

     

    Regards,

     

    Peter

    • Marked as answer by pproost Tuesday, August 30, 2011 9:42 AM
    Tuesday, August 30, 2011 9:42 AM
  • Glad to hear the issue is solved.

    Cheers:)

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 30, 2011 9:48 AM
    Moderator
  • Hi Guys

    I've tried all these suggestions, but to no avail. I've also tried the following script, which only maps one drive automatically, but if I double click the .vbs file, it maps both of the drives:

    On Error Resume Next

    Set objNetwork = CreateObject("Wscript.Network")
    Set colDrives = objNetwork.EnumNetworkDrives

    For i = 0 to colDrives.Count-1 Step 2
         objNetwork.RemoveNetworkDrive colDrives.Item(i)
    Next

    objNetwork.MapNetworkDrive "G:", "\\servername\sharename" ,true

    objNetwork.MapNetworkDrive "H:", "\\servername\2ndsharename" ,true

    Would anyone mind running their eye over this to see if I've made a mistake?

    Many thanks

    Tony

    Tuesday, April 24, 2012 2:50 PM
    • I found the answer today - and have been looking for months.

    Go to Control Panel - under System settings - GoTo Power Settings

    Then GoTo "Change when the computer sleeps"

    Here is where you find "Change Advanced Power Settings" Click it

    You may need to click on "change settings that are currently unavailable" to make changes below

    1) uncheck Hard disk - and change settings for the hard disk "while plugged in" to 180 minutes. The hard drive will go to sleep after 3 hours of non-use. Make longer if needed.

    2) uncheck Wireless adaptor - and change "Plugged in" to maximum performance

    3) uncheck Sleep - and make sure all "Plugged in" options read Never

    4) uncheck PCI Express and make sure everything is on Maximum

    I don't know if all 4 changes above are needed - but one of these changes seem to be working on five of our new computers that were putting the Red X on the connected Network drives. I hope someone at Microsoft puts this information out to the public –

    ALSO – you need to go into Device Manager – open your Network Card(s) (properties) – GoTo Power Management and uncheck the boxes suggesting the device can go to sleep.

    I can be reached at 973-292-0025

    Scott

    • Proposed as answer by Scotty-Guitar Wednesday, October 17, 2012 11:20 AM
    Wednesday, October 17, 2012 11:20 AM
  • This seemed to fix the issue for me:

    http://support.microsoft.com/kb/2775511/EN-US

    • Proposed as answer by unicastshield Tuesday, May 7, 2013 1:27 PM
    Monday, April 8, 2013 3:33 PM
  • Issue fixed with http://support.microsoft.com/kb/2775511/EN-US     hotfix

    Many thanks to TBone1985 for the link

    We have had this irritating problem on one windows 7 domain client too. 

    - shares marked by red X on logon,

    - program failed at start, becourse connection couldn't be made

    - simple click on shares made connection, and program could run.

    With the 2775511 hotfix, we were rid of the problem. Needed to install on both client and server, as described in the article.


    Tuesday, May 7, 2013 1:34 PM
  • Even after I posted the hotfix post in April, I still had issues.  I ended up having to set my GP setting for 30 sec as described here:

    http://support.microsoft.com/kb/2421599

    This resolved my issue on the RED X thus far.

    unicastshield - if you get a chance, mark my post as proposed answer.

    Friday, May 17, 2013 4:41 PM
  • I've painfully researched this problem for months trying every solution from login scripts, batch files, schedules, mapdrive, net use, group policy drive maps, a Microsoft hotfix  etc but time and again the drives come up with the dreaded red X when I boot up, along with a tray message telling me that it could not reconnect all my network drives.

    Some research told me to ignore it, it wasn't a problem but in my case where I'm copying music to my NAS the software just would not recognise the drives without me going in to explorer and "waking up" the drive first, a time consuming and frustrating exercise. Frankly I was at the point giving in to the problem and waiting for the next service pack.

    This morning however I had an epiphany. I have never used Sync Center, as I had no need, but I thought what if I synchronise one folder / file in each of my mapped drives to force the pc to recognise it at start up.

    I created a folder in each of my mapped drives with a tiny txt file in it (in my case called sync.txt) and enabled Sync Center and set up a partnership with this tiny file in each mapped drive. I then rebooted and hoped.

    Voila, no tray message telling me it couldn't connect and no red X. My audio and video software works perfectly and many reboots later it is still working perfectly.

    I know it is a sort of workaround but I hope this works for you too. This problem has been a constant pain since I first mapped the drives. Time now to move on to the next item in event viewer....

    Saturday, January 25, 2014 2:21 PM
  • Why does microsoft not fix such small things? It's unnecessary annoying.
    Sunday, October 26, 2014 11:24 PM
  • 2015 and this problem still exists. 
    Friday, March 13, 2015 8:17 AM
  • my computer also have this problem ''There is no time restriction. The mapped drives aren't automatically available after booting. If a user then double clicks on a drive it becomes immediately available and stays available.'' originally is windows 7 home premium 64bit, last time free upgrade to windows 10 and computer don't have GPO><
    Tuesday, July 25, 2017 2:17 AM
  • Hey there, it's now 2017 and the problem still persists even in Windows 10. Google brought me to this thread and it seems there is still no real practicable, full working and permanent solution. Moreover the problem occurs on some of my computers and on others not, even if they are on the same Windows build. There is also still no real statement why this actually occurs (just the network timing thing). I really think Microsoft should fix this issue because it's a shame that in 2017 it's still not possible to integrate shares and reconnect them correctly on startup.

    Obviously the default behaviour does not work all the time and I have noticed this on each Windows version to some degree. Also the proposed registry hack(s) available on the internet did not work for me and yes I have tried many of them.

    Long talk short I've now enough and therefore I created a working solution which I will now share with you. I created a Github project which includes a VBS and a Scheduler Task which fixes the issue. To keep the post short and don't duplicate information please visit the project page and read through what it does and how you can use it to never ever bother with manual network share or drive reconnections. It uses basic network commands like ping and net use to reestablish shares. Feel free to test or contribute.

    Network Share Reconnecter or go to Github and search for "network share reconnecter".

    I hope this helps some of you, at least it helps me because I also use it on all of my Windows machines with great success :)

    • Edited by th3x_yz Sunday, October 29, 2017 11:22 AM
    Thursday, October 26, 2017 1:10 PM
  • Actually, if you are a Windows 10 user (this might apply to Windows 7, 8, and 8.1 as well), the best way to address this issue is to simply create the network shares and assign drive letters as normal and THEN temporarily right click on the drive (make sure it is connected first) and then right-click the mapped drive and select "ALWAYS AVAILABLE OFFLINE."  Let Windows start to index and then cancel after a second or two.  Now, simply right-click on the same mapped drive and uncheck "ALWAYS AVAILABLE OFFLINE."  Let it complete and then reboot.  VOILA!!  Problem solved.  The mapped drives with red "X's" are gone and there is no need to click on each drive to reconnect them anymore.  Your welcome!!  :)  No need to edit registries or use scripts.

    Tuesday, November 28, 2017 10:24 PM
  • Carl, you are the Mutt's Nutz!
    I've read through thousands of dead-end, hugely complicated posts, and you have nailed it! Fixed all 4 of my networked red crosses in 60 seconds flat!
    Where do I sent a beer to? You deserve it!;-)
    P.S. How the f*#k did you discover that fix?

    Saturday, May 5, 2018 7:31 AM
  • Thank you on my part as well.  Very elegant.
    Saturday, May 5, 2018 9:02 PM
    • Addresses an issue that may cause mapped drives to fail to reconnect after starting and logging onto a Windows device.


    Reported issue from Microsfot.



    • Edited by fedayn2 Monday, July 1, 2019 11:14 AM
    Monday, July 1, 2019 11:13 AM