none
Prepare Current Forest Error - Deployment Skype for Business RRS feed

  • Question

  • Hi , Guys

    I´ve a problem.

    I´m try install Skype for Business, but i´ve an error with forest preparation .

    Error: An error occurred: "Microsoft.Rtc.Management.ADConnect.ADOperationException" "Active Directory operation failed on "MYSERVER.mydomain.com". You cannot retry this operation: "The parameter is incorrect 00000057: LdapErr: DSID-0C090D87, comment: Error in attribute conversion operation, data 0, v2580""

    I try run Prepare Current Forest wizart and powershell and I get the same error.   

     

    I need your help

    Thanks
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"


    • Edited by JACERMENO Saturday, June 27, 2015 2:16 AM
    Saturday, June 27, 2015 2:15 AM

Answers

  • Hi Jose.

    Please make sure you are following the correct steps as the previous answer in this link: https://social.technet.microsoft.com/Forums/lync/en-US/9fe47e99-cd8a-4269-bac6-69ff3b846f81/lync-rtm-forest-prep-issue-the-parameter-is-incorrect-00000057-ldaperr-dsid0c090b38-comment?forum=ocsplanningdeployment ( Lync RTM Forest prep issue "The parameter is incorrect 00000057: LdapErr: DSID-0C090B38, comment: Error in attribute conversion operat ion, data 0, vece" )

    As the last update that you sent to this question you are wrong. Looks like the issue can be solved executing the following commands:

    ldifde -i -v -k -s DC.domain.local -f C:\schema\ExternalSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\ServerSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\BackCompatSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\VersionSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    Before to do that, please copy the files: "ExternalSchema.ldf"; "ServerSchema.ldf"; "BackCompatSchema.ldf" and "VersionSchema.ldf" from C:\Program Files\Skype for Business Server 2015\Deployment\Setup to a folder created in the domain controller called as "Schema" created in the root for the Local Disk "C".

    After that, let me know the results.

    Regards.


    PLEASE REMEMBER, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answered"

    Wednesday, July 8, 2015 7:06 PM

All replies

  • Error in PS

    Enable-CsAdForest : Prepare Forest Active Directory settings execution failed
    on an unrecoverable error.
    At line:1 char:1
    + Enable-CsAdForest -force -GroupDomain MyDomain.com
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:SourceCollection) [Enable-CsAdForest], ADOperationException
    + FullyQualifiedErrorId : TaskFailed,Microsoft.Rtc.Management.Deployment.PrepareForestCmdlet
    WARNING: Enable-CsAdForest failed.
    WARNING: Detailed results can be found at
    "C:\Users\MyUser\AppData\Local\Temp\2\Enable-CsAdForest-d9941bad-979c-4be8-aaba-a7b798e6e3fd.html".
    Enable-CsAdForest : Command execution failed: Active Directory operation failed on "MyServer.MyDomain.com". You cannot retry this operation:
    "The parameter is incorrect 00000057: LdapErr: DSID-0C090D87, comment: Error in attribute conversion operation, data 0, v2580"
    At line:1 char:1
    + Enable-CsAdForest -force -GroupDomain MyDomain.com
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Enable-CsAdForest], ADOperationException
    + FullyQualifiedErrorId : ProcessingFailed,Microsoft.Rtc.Management.Deployment.PrepareForestCmdlet

    Regards
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Saturday, June 27, 2015 5:41 AM
  • Which version is your Forest?

    You have also to be member of the domain admin.

    Schema update was sucessfull?


    regards Holger Technical Specialist UC



    Saturday, June 27, 2015 1:42 PM
  • Hi!

    Domain and Forest Funtional Level are : Windows Server 2012 R2.

    The User Used are Domain Admin

    Thanks

    Regards
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Monday, June 29, 2015 5:29 AM
  • You should check your AD replication. Maybe the schema update is not replicated to all DC?

    Please check also that you AD site configuration and dns for the IP range of the new Lync server is correct.

    Did you run the PS window in administration mode?

    Try to use:

    Enable-CsAdForest -GlobalSettingsDomainController <FQDN> 

    Here is a good step by step installation

    https://gallery.technet.microsoft.com/office/Lync-Server-2012-9d6fe954

     

    regards Holger Technical Specialist UC

    Monday, June 29, 2015 5:37 AM
  • That error looks to me that you don't have Domain Admin permission on the account that you used to deploy the server. Have a double check the account that you logged in to the server to run the deployment, does have Domain Admin permission and CSAdministrator permission assigned

     

    http://thamaraw.com

    Monday, June 29, 2015 5:59 AM
    Moderator
  • Hi JACERMENO,

     

    There’s a similar case for your reference, You can try to use Ldifde.exe to import the schema files.

    https://social.technet.microsoft.com/Forums/office/en-US/9fe47e99-cd8a-4269-bac6-69ff3b846f81/lync-rtm-forest-prep-issue-the-parameter-is-incorrect-00000057-ldaperr-dsid0c090b38-comment?forum=ocsplanningdeployment

     

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, June 29, 2015 6:24 AM
    Moderator
  • Hi !! Guys

    This is result after run Get-CsAdForest

    I review de privileges user and he has Domain Admin, Shema Admin, Enterprise Administrator, etc...

    Regards
    JAC
     


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Tuesday, June 30, 2015 3:56 AM
  • Hi JACERMENO,

    The image is broken, please try uploading it again.

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, July 1, 2015 9:18 AM
    Moderator

  • Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Wednesday, July 1, 2015 8:11 PM
  • Hi JACERMENO,

    Have you tried using the Ldifde.exe tool to import the schema files ?

    https://technet.microsoft.com/en-us/library/gg398607.aspx

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, July 2, 2015 9:23 AM
    Moderator
  • Hi JACERMENO,

    I’m writing to follow up on this thread. Do you have any updates on this issue? Please post back at your convenience.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, July 6, 2015 8:47 AM
    Moderator
  • Hi, Eric
    Thank for you reply.

    I do not even progress in the case, I'm working on it, I keep informed.

    I try use  Ldifde.exe  and this is the error:


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Monday, July 6, 2015 6:35 PM
  • Hi Jose.

    Please make sure you are following the correct steps as the previous answer in this link: https://social.technet.microsoft.com/Forums/lync/en-US/9fe47e99-cd8a-4269-bac6-69ff3b846f81/lync-rtm-forest-prep-issue-the-parameter-is-incorrect-00000057-ldaperr-dsid0c090b38-comment?forum=ocsplanningdeployment ( Lync RTM Forest prep issue "The parameter is incorrect 00000057: LdapErr: DSID-0C090B38, comment: Error in attribute conversion operat ion, data 0, vece" )

    As the last update that you sent to this question you are wrong. Looks like the issue can be solved executing the following commands:

    ldifde -i -v -k -s DC.domain.local -f C:\schema\ExternalSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\ServerSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\BackCompatSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    ldifde -i -v -k -s DC.domain.local -f C:\schema\VersionSchema.ldf -c DC=X "DC=domain,DC=local" -j C:\schemas

    Before to do that, please copy the files: "ExternalSchema.ldf"; "ServerSchema.ldf"; "BackCompatSchema.ldf" and "VersionSchema.ldf" from C:\Program Files\Skype for Business Server 2015\Deployment\Setup to a folder created in the domain controller called as "Schema" created in the root for the Local Disk "C".

    After that, let me know the results.

    Regards.


    PLEASE REMEMBER, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answered"

    Wednesday, July 8, 2015 7:06 PM
  • Hi,

    those were the steps made by the microsoft support team to provide solution to the error.

    Thaks

    Regards


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    Thursday, July 9, 2015 2:05 PM