none
There are currently no power options available for some Windows users on a domain

    Question

  • In a Windows 2012 active directory domain that had been updated from a Windows SBS 2008 domain some users are not able to shutdown/restart their computers from the Windows 7 or Windows 10 start menus. Instead, when clicking on the Start Menu/Power Button there is a message "There are currently no power options available". Here are a few things I have checked.

    1) Users that do work normally and users that do not work normally are members of the same Active Directory security groups.

    2) With RSOP.msc all users are getting their group policy settings for the "Start Menu and Taskbar"from the same Group Policy (Default Domain).

    3)SecPol reveals that User Right Assignments are same for all users.

    4)I cannot find anything that is different between the users who can shutdown the computer from the start menu and those who cannot.

    5) The same users get have same problem no matter which domain computer they sign on to.

    6)It also does not matter if it is Windows 7, Windows 10 (1607) or Windows 10 (1703).

    7)Work-arounds do work. The affected users can shutdown/restart from the command prompt and they can shutdown/restart after sighing out of Windows.

    I suspect the Windows SBS 2008 origin of the domain has something to do with this only because of the problems that OS has had since 2008.

    Wednesday, May 3, 2017 12:30 PM

Answers

All replies

  • Hi,

    It seems the local settings are overwritten by the GPO or by a security settings, on one of the PC I had this issues and running the command fixed it, can you try this on the affected PC? This can be scripted at the startup if this helps.

    Other option will be to block the GPO settings and move the User to seperate OU to eliminate any conflicting settings

    Open an elevated command prompt, reset your power scheme:

    powercfg -restoredefaultschemes


    Regards, Jim MSCS - MCP Disclaimer: This posting is provided AS IS with no warranties or guarantees , and confers no rights. When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    Wednesday, May 3, 2017 1:10 PM
  • Check this policy first :

    • Security Settings > Local Policies > User Rights Assignment > Shut Down The System

    and take a look at this thread, see if it helps:


    Mahdi Tehrani | | www.mahditehrani.ir
    Make sure to download my free PowerShell scripts:

    Wednesday, May 3, 2017 2:25 PM
    Moderator
  • Hi,
    You could run gpresult /h command on both kinds of users to compare if there is the other group policy settings which might not be different.
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, May 4, 2017 6:10 AM
    Moderator
  • This appears to be another "unadvertised feature:-(" "Bug" that effects domain attached workstations.  In our case there were no dueling GPOs or anything else from a domain perspective.

    I post this for those that may be still suffering through this bug.

    This solution worked for one workstation:

    1. Press
    Win + X
    to select Command Prompt (Admin).

    2. Type sfc /scannow and then hit Enter. (Make sure to put a space between “sfc”
    and the slash.)

    3. Type powercfg –restoredefaultschemes after the sfc
    /scannow command completes and then hit Enter.

    4. Type DISM
    /Online /Cleanup-Image /RestoreHealth
    and hit Enter.

    For the rest, this solution worked:

    run  cmd window with administrative rights:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Logoff and logon.

    Friday, October 27, 2017 9:08 PM
  • How is this is still an issue!<o:p></o:p>

    I used the registry method to resolve it and upon the next windows update we are back to broken. <o:p></o:p>

    I have already done a re-install (not clean install) and the issue remains. After subsequent updates the registry fix is now back to broken and the users are back to missing power options. Terrible world we currently live in. Forced to update everything with all the security issues afoot in the last few years weighed against a barrage of MS updates that have consistently broken things. So its get hacked or have a jacked up MS OS. Pity.. <o:p></o:p>



    IT Manager

    Monday, December 4, 2017 6:26 PM
  • Change your GPO or add a new one for your laptops:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment

    Shut down the system

    Change properties to allow Administrators, Backup Operators and Users

    Then use gpudate and log out and back in, all works then.

    Wednesday, December 6, 2017 4:36 PM
  • We have move users to new there is not any GPO applied and powercfg-restoredefaultschemes but same problem is persist.
    Wednesday, March 21, 2018 5:05 AM