none
SSPR without domain name portion oddity RRS feed

  • Question

  • Hi all,

    I have a customer who's rolling out SSPR, where some of their users are unable to perform password reset without prefixing their domain (i.e. they have to log in to the portal as domain\username) where the majority don't have to.

    I wondered if there was a duplicate identity in the MIM service with the same user name but different domain for the affected users, but this isn't the case.  For good measure, I deleted an affected user from the MIM portal and re-provisioned them but it's still the same.

    Does anyone have any idea of how and when the domain is "assumed" or why this might not be working for some users within the exact environment where it works for others?

    Thanks,

    Paul.

    Wednesday, December 21, 2016 4:52 PM

All replies

  • Just on this, I've configured the following key in the web.config of the password reset portal:

          <add key="DefaultDomainName" value="thedomain" />

    It seems to be ignored!  I've restarted the website, done an IISReset and it still works for a user who's not on the default domain as specified above, doesn't work for another who is, but does work for a third who is, who it's always worked for!

    I haven't rebooted the server yet as it's in use, but I'll try that out of hours.

    Thanks,

    Paul.

    Thursday, December 22, 2016 12:27 PM