Immediate Alerts stopped working after Detach/Attach of Database RRS feed

  • Question

  • Sharepoint Server

    Windows Server 2008 Standard SP2 32bit

    Windows SharePoint Services 3.0 SP1

    SQL Server

    Windows Server 2003 R2 Standard

    Microsoft SQL Server 2005

    Symptom description

    Our SQL Server was running out of harddrive space on the C: Drive where the SharePoint WSS_Content database was stored. So I did the following steps to move the WSS_Content.mdf and WSS_Content_Log.ldf to diffrent partitions on the same disk.

    1. Stopped all SharePoint services and IIS
    2. From SQL Server Management Studio Detached WSS_Content
    3. Moved WSS_Content.mdf to the E: Drive
    4. Moved WSS_Content_Log.ldf to the D: Drive
    5. From SQL Server Management Studio Attached WSS_Content.mdf from the new location
    6. Opened up the WSS_Content Database Properties and pointed WSS_Content_log to the new location
    7. Started all SharePoint Services and IIS

    After doing the above steps Sharepoint appered to be working fine until one of our users reported that Alerts had stopped working.

    In SharePoint Central Administration>Operations>Timer Job Status the Immediate Alerts status is showing as Failed and the time stamp coincides with when I did the above maintenance.

    After a lot of googling and reading Microsoft blogs and KB's I have tried the following steps to fix the issue with no luck.

    • Restart SharePoint Server
    • Restarted Windows SharePoint Services Timer
    • Same as above but left the Services Timer stopped for atleast half an hour before trying again.
    • Checked Windows SharePoint Services Timer credentials and re-entered them 
    • Used STSADM to verify properties which come back correct
    STSADM -o getproperty -url http://YourSiteURL -pn alerts-enabled
    You should see  <Property Exists=”Yes” />
    STSADM -o getproperty -url http://YourSiteURL–pn job-immediate-alerts

    You should see something like the default (but can be changed) <Property Exists=”Yes” Value=”every 5 minutes between 0 and 59” />

    • Used STSADM to reset properties

    stsadm –o setproperty –url http://YourSiteURL –pn alerts-enabled –pv False

    stsadm –o setproperty –url http://YourSiteURL –pn alerts-enabled –pv True
    stsadm –o setproperty -url http://YourSiteURL –pn job-immediate-alerts –pv “Every 5 minutes between 0 and 59"
    • Used STSADM to re-register the alerts template

    stsadm -o updatealerttemplates -url http://YourSiteURL
       -f "c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\XML\alerttemplates.xml"
       -LCID 1033

    • Navigated to C:\ProgramData\Microsoft\SharePoint\Config on our SharePoint Server and deleted all the XML files apart from Cache.ini
    • Open Cache.ini and replaced it's content with 1

    I don't know what else I can try anyideas?

    Kind Regards

    Ryan McMaster

    Tuesday, March 6, 2012 12:54 PM

All replies


    The status for the timer job Immediate Alerts is still failed? How many servers do you have in the farm? All the other timer jobs are working correctly?

    Here you have two links regarding alert troubleshooting steps:



    MCITP|MCTS SharePoint| SharePoint Performance blog

    Tuesday, March 6, 2012 7:25 PM
  • Thank you for getting back to me...

    All the other Timer Job's are Succeeded apart from Immediate Alerts and CEIP Data Collection which show as Failed.

    I believe CEIP Data Collection is showing as Failed because we've opt out sharing error data with Microsoft etc

    It's just one standalone installation of Sharepoint Services 3.0 SP1 using a seperate server with SQL 2005 on for the Database.

    I've already been through all the steps in your first link and I'm sure the second holds no relevance but thankyou.



    Wednesday, March 7, 2012 10:45 AM

    Have you tried to create a new alert or to delete an old one and recreate it again? You have the same issue?

    MCITP|MCTS SharePoint| SharePoint Performance blog

    Wednesday, March 7, 2012 11:05 AM
  • Yes I have tried creating new alerts and modifying old ones etc.

    When you click 'Alert Me' to setup a new alert we recieve the welcome email saying alerts have been setup but after that nothing comes through and Immediate Alerts are still showing as Failed.

    Wednesday, March 7, 2012 11:20 AM

    The issue is present only on this web application that is associated with the migrated content_db? If you create a new web app for tests you have the same issue?

    MCITP|MCTS SharePoint| SharePoint Performance blog

    Wednesday, March 7, 2012 11:53 AM
  • Sorry it's took a while to get back you I've not had chance to touch this again until now...

    I've just moved the WSS_Content database back to it's original location on the C Drive of the SQL Server as a long shot but it still doesn't work!

    I've not had chance to try a new web app... think I'll install Sharepoint Foundation 2010 on another server and migrate the data across. Does this sound ok to you or will I encounter any other problems?


    Tuesday, March 13, 2012 5:24 PM