none
Cannot see Exchange provisioning UI after Update 2 RRS feed

  • Question

  • I recently applied Update 2 and now the Exchange provisioning controls are not being displayed in Active Directory management agents. When I open the Properties of an ADMA and go to the Configure Extensions page, I do not see the "Provision for" label or drop-down menu, but I do see the "RPS URI" label and textbox. If I then swith to another page within the MA and return to the Configure Extensions page, I do not see any of these controls.

    First view of Configure Extensions After clicking away and returning

    One guy at Microsoft has suggested, "I have seen things like this happen when using the client on a virtual machine, or through particular remote desktop tools. I would recommend using the Remote Desktop Client for viewing the FIM Synchronization Service Client." However, we are using the standard MS RDC and MS RDC Manager to connect to the server hosting the synch service. Has anyone else seen this issue? Does anyone know of any fixes or resolutions short of reinstalling FIM?



    • Edited by D. Ozouf Monday, July 16, 2012 10:16 PM
    Monday, July 16, 2012 10:13 PM

Answers

  • I saw something similar happen when I imported my ILM Server Configuration export into FIM 2010 R2, only in my case I never did see the RPS URI box, just the blank area allowing no Exchange configuration.  I found I could export the AD MA configuration from FIM, delete the MA and its connector space, import the MA from the file and then run a full import/full sync to repopulate the connector space.  After the MA configuration was re-imported, the Exchange configuration pieces were back in the UI.  I have not actually tested the Exchange 2010 provisioning after having done this, however.  But this could save you having to rebuild FIM from scratch if it works for you.

    Chris

    • Marked as answer by D. Ozouf Tuesday, July 17, 2012 2:33 PM
    Tuesday, July 17, 2012 1:27 PM

All replies

  • I saw something similar happen when I imported my ILM Server Configuration export into FIM 2010 R2, only in my case I never did see the RPS URI box, just the blank area allowing no Exchange configuration.  I found I could export the AD MA configuration from FIM, delete the MA and its connector space, import the MA from the file and then run a full import/full sync to repopulate the connector space.  After the MA configuration was re-imported, the Exchange configuration pieces were back in the UI.  I have not actually tested the Exchange 2010 provisioning after having done this, however.  But this could save you having to rebuild FIM from scratch if it works for you.

    Chris

    • Marked as answer by D. Ozouf Tuesday, July 17, 2012 2:33 PM
    Tuesday, July 17, 2012 1:27 PM
  • THANK YOU!  I had the exact same issue as described where the Exchange Provisioning UI elements were missing - in a FIM 2010 R2 environment that was upgraded from ILM 2007 with FP1.  Exporting the MA, Deleting the MA and its ConnectorSpace, and then Importing it again fixed the problem.
    Thursday, August 23, 2012 4:58 PM
  • Same issue here when transferring settings from one FIM 2010 R2(hyper v) to another FIM 2010 R2(hyper v). Sometimes the exchange settings are on the page for ~50ms but then they will disappear.

    Fixed when deleting AD MA and re-importing Sync Service Settings (all MA's together).

    This 'fix' must be applied every time I transfer new settings...

    (In AD MA, Exchange provisioning has been changed from 2007 to 2010 and then back to 2007, could this be the cause?)

    Monday, October 15, 2012 9:31 AM
  • I had the same issue after upgrading to build 4.0.3644.2 in my vmware workstation test environment. The strange thing is that if I enable the network connection with NAT the Exchange provision UI returns to normal, but when I enable the network connection back to Host-only, the Exchange UI disappers. This might help others solve the problem.

    However re-importing AD MA resolved my UI problem for now.

    Audun

    Monday, November 12, 2012 11:43 AM
  • I had this same problem today. I entered the credentials again in the 'Connect to Active Directory Forest' and then clicked Configure Extensions, then it showed up the URI text box. Hope this will work for others as well..
    Wednesday, February 6, 2013 9:09 AM
  • Now there is a hotfix for this http://support.microsoft.com/?id=2814853

    Issue 1
    In some cases, the Exchange configuration options on the Active Directory Management Agent do not appear. These options will now always be visible even if Exchange is not detected in the source directory.
    Friday, February 22, 2013 10:59 AM