locked
"Your client does not support opening this list with Windows Explorer" RRS feed

  • Question

  • I'm using IE 9, and SP2010 portal.  I have permissions, but can't open documents, it say's the file name/path doesn't exist.

    Then I tried to open the folder with Explorer and it says the client doesn't support it.  I've seen other posts, but it doesn't cover IE9, only like IE5 or 6

    Thursday, March 7, 2013 4:07 PM

Answers

All replies

  • This can mean a few things.  You can try fiddler to see what the issues is as windows explorer view uses WebDav.  If the web app doesn't have a root site collection you will get errors.  Similar issues when using NetBios.

    Chris


    Chris Givens CEO, Architecting Connected Systems Blog Twitter

    Friday, March 8, 2013 3:22 AM
  • Are you using 32-bit or 64-bit IE?
    Friday, March 8, 2013 4:02 AM
  • Is "Open with Explorer" working for other libraries on site? If not, check you have "WebClient" service in execution. If it is a Windows 2008  server OS, it does not install "Desktop Experience" feature by default. The "Desktop Experience" feature has the "WebClient" service.


    Pradip T. ------------- MCTS(SharePoint 2010/Web)|MCPD(Web Development) https://www.mcpvirtualbusinesscard.com/VBCServer/paddytakate/profile

    Friday, March 8, 2013 4:37 AM
  • Hi Tammy,

    Please try the solutions in the following article. The article covers almost all solutions we generally to fix the issue.
    http://blogs.technet.com/b/asiasupp/archive/2011/06/13/error-message-quot-your-client-does-not-support-opening-this-list-with-windows-explorer-quot-when-you-try-to-quot-open-with-explorer-quot-on-a-sharepoint-document-library-in-office-365-site.aspx

    Thanks,
    Jinchun Chen


    Jinchun Chen(JC)
    TechNet Community Support

    Thursday, March 14, 2013 9:58 AM
  • If the suggestions at the blog listed above do not fix the "Open with Explorer" problem, just forget about Explorer View, and follow the steps below:

    1. If your SPO site is still running in 2010 view mode, download Office Pro Plus 2013 trial 
    2. When you start Office 2013 the first time, log in with your O365 credentials and it will activate Office based off of your O365 license, so you won't have to use the trial key
    3. Open Internet Explorer and navigate to a document library that you would like to use Explorer View in
    4. Click the "Library" tab at the top
    5. Click the "Sync to SharePoint Workspace" button in the ribbon

    Your document library will sync through SkyDrive Pro running on your local computer in the system tray, so now you have a local copy of all the documents in that library that you can work with offline.  Any files you add to the SkyDrive Pro folder will upload to SharePoint as soon as you gain internet access again.  Repeat steps 3-5 for any other libraries you would like to sync.

    Saturday, April 6, 2013 6:06 AM
  • Tammy;

    I've been chasing the solution for this problem for a few weeks with only one good result. 

    I've tried every recommended solution I can find on my Win7 64-bit machine with no success at all.

    On my Win7 32-bit machine I ran Windows Update and installed all available updates including a bump up to IE 10.  In IE I disabled Protected Mode in all security zones and rebooted.  I am now able to open all of my Document Libraries on a SharePoint 2010 server when I select Actions --> Open with Windows Explorer.

    After begging for budget money to upgrade client machines to everything x64 do we have to now beg for money to return to x86 machines to get this menu choice to work?

    Saturday, April 6, 2013 6:37 PM
  • I recently had a user experiencing this issue. Specifically adding *.sharepoint.com as a trusted site temporarily fixed it until the machine was restarted. The permanent solution came when I discovered the user was opening Internet Explorer (64-bit).

    "Hiding" the 64-bit shortcut so the user only opened the 32-bit version, resolved the issue.

    Wednesday, July 17, 2013 4:55 PM
  • We have a user who had a similar issue.  The workstation  is running 32-bit Vista Business with IE 9. We have SP Foundation 2013.

    Adding the domain to the IE trusted sites solved the issue temporarily but after a few days it re appeared.

    Then I found out that MS Silverlight plug-in was installed recently thru Windows update. Disabling this add-on in IE fixed it.

    Friday, August 2, 2013 5:21 PM
  • I struggled finding a solution to the "client doesnt support..." message you receive when trying to open a SP library via the "Open with Explorer" feature.  I tried everything on this blog and others, nothing worked.  A colleague recently suggested the following steps which fixed my issue where I'm now able to open a SP library using the "Open with Explorer" feature.  I'm using IE 8 on a SP 2010 Ent. site. 

    Steps to fix the issue are as follows

    1. Caution: You may want to back up your favorites folder by copying “C:\Users\YourUserName\Favorites” folder to your desktop before starting step 2.
    2. In Internet Explorer menu bar, click on “Tools”
    3. Then click on “Internet Options”
    4. Then click on “Advanced” tab
    5. Click on “Reset” button
    6. Select “Delete personal settings” first
    7. Click on “Reset” button
    8. Restart browser


    • Edited by mcpcoy Wednesday, August 14, 2013 2:40 PM Updated text
    • Proposed as answer by mcpcoy Wednesday, August 14, 2013 2:41 PM
    • Unproposed as answer by mcpcoy Wednesday, August 14, 2013 2:41 PM
    Wednesday, August 14, 2013 2:37 PM
  • I was seeing "Your client does not support opening this list with Windows Explorer" using Windows 7 (32-bit) with IE and SharePoint 2010 Foundation 64-bit (IIS 7.5), but none of the above tips helped.

    It turns out we had URL Scan 3.1 running in the background and it was catching and stopping most of the verbs and headers required by SharePoint to operate the Windows Explorer view.  I commented them out (meaning, I enabled them to pass through) and now everything work fine.

    If you don't have URL Scan utility installed, check IIS's built in Request Filtering rules are not blocking any of these verbs and headers.  A lot of companies block all but the most basic of these HTTP properties nowadays.





    • Edited by David123 Friday, April 18, 2014 9:46 PM
    Tuesday, April 15, 2014 8:21 PM
  • We also ran into this issue on users that had installed a new citrix client.  (As part of hardening the system there are other installations that do this too)  The installer removed the Network provider in the order of opening:  Webclient was removed from the REG_SZ:  HKLM\System\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder

    It took a long time to find it so I figured I would share.

    • Proposed as answer by cmillerLCE Friday, April 10, 2015 4:46 PM
    Thursday, August 21, 2014 11:36 PM
  • We also ran into this issue on users that had installed a new citrix client.  (As part of hardening the system there are other installations that do this too)  The installer removed the Network provider in the order of opening:  Webclient was removed from the REG_SZ:  HKLM\System\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder

    It took a long time to find it so I figured I would share.

    Thanks a ton for sharing this fix - fixed it for me as well.  Stupid Citrix web client. :)
    Friday, April 10, 2015 4:48 PM
  • We got this error while trying  to open an old Sharepoint directory in "Explorer" view instead of "All Documents" view.   Worked around it by adding the sharepoint site to  Compatibility View in IE .
    Wednesday, March 23, 2016 8:36 PM
  • Thank you a TON for this.  I work on this for months with Microsoft support and could not find this answer.  It worked like a charm for me.

    Thank you, thank you, thank you!!!!!

    Wednesday, April 11, 2018 3:24 PM