SBS 2011 Standard, Server Backup Error


  • I am using Windows SBS 2011 Standard and Windows Server Backup.
    I am trying to perform a daily automated backup to an external USB drive.  I have set up the backup job, and it works fine for 15 days, and then it starts to fail.  The USB target drive is only about 10 % full.
     I  get the following error: "There was a failure in updating the backup to remove deleted items. Detailed error: The process cannot access the file because it is being used by another process".
    The only way I have found to get it to run again is to delete the backup job and setting it all up again.  This reinitialized (formats the Hard drive) the USB drive (it's "dedicated" to the backup process), It will run for 15 days again and then we get the same error again.


    Thanks for any help

      - Provider 
       [ Name]  Microsoft-Windows-Backup 
       [ Guid]  {1DB28F2E-8F80-4027-8C5A-A11F7F10F62D} 
       EventID 5 
       Version 2 
       Level 2 
       Task 0 
       Opcode 0 
       Keywords 0x4000000000000000 
      - TimeCreated 
       [ SystemTime]  2011-12-10T10:00:55.995578400Z 
       EventRecordID 267 
      - Execution 
       [ ProcessID]  39860 
       [ ThreadID]  37664 
       Channel Microsoft-Windows-Backup 
       Computer ACCTG1.cenofthegolden1.local 
      - Security 
       [ UserID]  S-1-5-18 
    - EventData 
      BackupTemplateID {23CEC11E-71CA-4F5F-BE32-202AF1408DE5} 
      HRESULT 2155348301 
      BackupState 12 
      BackupTarget ACCTG1 2011_11_11 14:51 DISK_01 
      NumOfVolumes 1 
      BackupTime 2011-12-10T10:00:09.881978400Z 
      HRESULT2 2155348301 
      VolumesInfo <VolumeInfo><VolumeInfoItem Name="C:" OriginalAccessPath="C:" State="7" HResult="-2139619299" DetailedHResult="0" PreviousState="15" IsCritical="1" IsIncremental="0" BlockLevel="0" HasFiles="1" HasSystemState="0" IsCompacted="0" IsPruned="1" IsRecreateVhd="0" FullBackupReason="4" DataTransferred="0" NumUnreadableBytes="0" TotalSize="0" TotalNoOfFiles="0" Flags="1604" BackupTypeDetermined="1" SSBTotalNoOfFiles="0" SSBTotalSizeOnDisk="0" /></VolumeInfo> 
      DetailedHRESULT 2147942432 
      SourceSnapStartTime 2011-12-10T10:00:09.881978400Z 
      SourceSnapEndTime 2011-12-10T10:00:34.061978400Z 
      PrepareBackupStartTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList> 
      PrepareBackupEndTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList> 
      BackupWriteStartTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList> 
      BackupWriteEndTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList> 
      TargetSnapStartTime 1601-01-01T00:00:00.000000000Z 
      TargetSnapEndTime 1601-01-01T00:00:00.000000000Z 
      DVDFormatStartTime <TimesList></TimesList> 
      DVDFormatEndTime <TimesList></TimesList> 
      MediaVerifyStartTime <TimesList></TimesList> 
      MediaVerifyEndTime <TimesList></TimesList> 
      BackupPreviousState 16 
      ComponentStatus <ComponentStatus></ComponentStatus> 
      SSBEnumerateStartTime 1601-01-01T00:00:00.000000000Z 
      SSBEnumerateEndTime 1601-01-01T00:00:00.000000000Z 
      SSBVhdCreationStartTime 1601-01-01T00:00:00.000000000Z 
      SSBVhdCreationEndTime 1601-01-01T00:00:00.000000000Z 
      SSBBackupStartTime 1601-01-01T00:00:00.000000000Z 
      SSBBackupEndTime 1601-01-01T00:00:00.000000000Z 
      SystemStateBackup <SystemState IsPresent="0" HResult="0" DetailedHResult="0" /> 
      BMR false 
      VssFullBackup false 
      UserInputBMR false 
      UserInputSSB false 
      EnumerateBackupStartTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList> 

    Wednesday, December 14, 2011 3:36 AM


All replies

  • Hi, if you are using any third party backup program or antivirus program, please temporarily disable or remove them and see the result.

    You can also follow the solutions in the following article and thread regarding the issue:

    Event ID 5 — Backup Operations

    Backup stopped before completing. The process cannot access the file because it is being used by another process

    You can also take a look at the External Backup Drives Compatibility List:

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, December 15, 2011 8:33 AM
  • I still have not been able to fix this issue. It runs for 15 backups (days) and them fails with the same error code see below


    - System
    - Provider
    [ Name] Microsoft-Windows-Backup
    [ Guid] {1DB28F2E-8F80-4027-8C5A-A11F7F10F62D}
    EventID 517
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x8000000000000000
    - TimeCreated
    [ SystemTime] 2011-12-29T08:01:09.030098100Z
    EventRecordID 97746
    - Execution
    [ ProcessID] 28400
    [ ThreadID] 35536
    Channel Application
    Computer ACCTG1.cenofthegolden1.local
    - Security
    [ UserID] S-1-5-18
    - EventData
    BackupTime 2011-12-29T08:00:13.915298100Z
    ErrorCode 2155348301



    Thanks, for any help!



    Tuesday, January 03, 2012 7:41 PM
  • I'm having a similar problem but the data being backed up in my case is a DFS share.  It keeps failing on e:\system Volume Information\EfaData\SYMEFA.DB which is a DFS file.  I cannot fathom why windows backup is trying to delete this file during it's pruning process (backups shouldn't be deleting data?).  I'll just exclude this directory from the backup as it's not necessary. 
    Monday, April 30, 2012 8:44 PM