none
Prevent a Windows 10 from locking after inactivity?

    Question

  • Is there any GPO setting (or registry, etc.) that will prevent a Windows 10 machine (Surface) from locking after inactivity? Or even extend the amount of inactivity before the automatic lock will happen? 

    On previous OS's in our environment (7 & 8), we have used theGPO settings for the screensaver to extend the time &/or not require a password when waking up...  but even with these settings applied on Windows 10 (the GPO get's applied, and the ScreenSaver settings reflect the GPO config), the screen still locks after 5-10 minutes of inactivity.

    I've manually set both Screen & Sleep settings to "Never", but it still locks after inactivity.

    This setting is for Surface Tablets used like Kiosks which we don't want to lock (auto-logon with a locked-down user).

    Is there any way to prevent it from locking?


    Thanks, DFDavis

    Thursday, February 23, 2017 8:08 PM

Answers

  • Thanks, but I believe that's the exact registry value that the GPO setting sets (UserPolicies/Admin Template/Control Panel/Personalaization/Screen Saver Timeout).

    However, I believe I found the key that does this (I don't think there is a direct GPO correlation, so you just have to set the value directly in the registry). 

    Registry Hive: HKEY_LOCAL_MACHINE 
    Registry Path: \Software\Microsoft\Windows\CurrentVersion\Policies\System\
    Value Name: InactivityTimeoutSecs

    This was set to 300, which is why the machine would auto-lock in 5 minutes.

    I set this to the same value as the Screen Saver Timeout, and the tablet isn't locking anymore until that designated idle time.


    Thanks, DFDavis

    • Marked as answer by DFDavis Friday, February 24, 2017 2:32 PM
    Friday, February 24, 2017 2:32 PM

All replies

  • Hi,
    As far as I know, the following registry could control the timeout for locking inactivity workstations:
    HKEY_CURRENT_USER\Control Panel\Desktop
    ValueName = ScreenSaveTimeout

    strValue = 300(seconds=5 minutes)
    You could have a try modifying this registry. Please note: make sure that you back up the registry before you modify it and you know how to restore the registry if a problem occurs. 
    Best regards,
    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Friday, February 24, 2017 3:16 AM
    Moderator
  • Thanks, but I believe that's the exact registry value that the GPO setting sets (UserPolicies/Admin Template/Control Panel/Personalaization/Screen Saver Timeout).

    However, I believe I found the key that does this (I don't think there is a direct GPO correlation, so you just have to set the value directly in the registry). 

    Registry Hive: HKEY_LOCAL_MACHINE 
    Registry Path: \Software\Microsoft\Windows\CurrentVersion\Policies\System\
    Value Name: InactivityTimeoutSecs

    This was set to 300, which is why the machine would auto-lock in 5 minutes.

    I set this to the same value as the Screen Saver Timeout, and the tablet isn't locking anymore until that designated idle time.


    Thanks, DFDavis

    • Marked as answer by DFDavis Friday, February 24, 2017 2:32 PM
    Friday, February 24, 2017 2:32 PM
  • Thanks, but I believe that's the exact registry value that the GPO setting sets (UserPolicies/Admin Template/Control Panel/Personalaization/Screen Saver Timeout).

    However, I believe I found the key that does this (I don't think there is a direct GPO correlation, so you just have to set the value directly in the registry). 

    Registry Hive: HKEY_LOCAL_MACHINE 
    Registry Path: \Software\Microsoft\Windows\CurrentVersion\Policies\System\
    Value Name: InactivityTimeoutSecs

    This was set to 300, which is why the machine would auto-lock in 5 minutes.

    I set this to the same value as the Screen Saver Timeout, and the tablet isn't locking anymore until that designated idle time.


    Thanks, DFDavis

    There is a GPO setting for the computer-wide setting:

      Computer Configuration->Windows Settings->Security Settings->Local Policies->Security Options->Interactive logon: Machine inactivity limit

    Changing this directly affects the stated registry entry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\InactivityTimeoutSecs

    Its intent is to prevent the effect of individual users setting their own excessively long account-specific ScreenSaveTimeout, enforcing this shorter time if necessary.



    • Edited by Kip-potter Monday, September 10, 2018 3:41 PM
    Monday, September 10, 2018 3:40 PM
  • This did not work for us, even after a reboot. We set the time to 3600 = 1 hour still locks after 5 minutes
    Thursday, September 13, 2018 12:52 PM