locked
" A network operation did not complete in time" when startin Virtualized App RRS feed

  • Question

  • I'm new to APP-V and have been setting up a test setup following the APP-V 4.5 trial guide. Everything worked fine (setting up the Management Server and Desktop Client) and I've managed to publish the default application to a client (The icon is published to the client's desktop). However, when starting the client, the systray icon says it's loading but it stays at 0% returning the following error:

    The Application Virtualization Client could not launch DefaultApp MFC Application 1.0.0.1.

    A network operation did not complete in time. Check your network connection, and then try again. If the problem persists, report the following error code to your System Administrator.

    Error code: 45242F4-19D0810A-10000005

    Nothing is logged on the server side. Firewalls on both server and client have been disabled. Any suggestions would be much appreciated

    Tuesday, April 27, 2010 7:43 AM

Answers

  • Hey man,

    Changed the protocol to rtsp:// in the osd file, and it works now. Thanks a lot for pointing me in the right direction! That MS trial doc doesn't seem to be completely error free ;-)

    Thanks a lot


    Stijn

    • Proposed as answer by znack Wednesday, April 28, 2010 9:28 PM
    • Marked as answer by Aaron.ParkerModerator Monday, December 19, 2011 12:57 PM
    Wednesday, April 28, 2010 1:31 PM

All replies

  • In the OSD file for the DefaultApp, you will see %SFT_SOFTGRIDSERVER%, which I'm presuming doesn't exist on your client. You have two options:

    1. Replace %SFT_SOFTGRIDSERVER% with the hostname of your App-V server
    2. Define the %SFT_SOFTGRIDSERVER% variable on the client with the value of the App-V server. This would be my recommended option
    Tuesday, April 27, 2010 4:31 PM
    Moderator
  • Hello,

     

    I don't have a  %SFT_SOFTGRIDSERVER% in my defaultapp osd  file. I followed the APP-V 4.5 trial guide. The only thing I changed is the CODEBASE HREF parameter. Maybe there's something missing in there? Below is the full osd file.

    I've reinstalled the APP server from scratch, and I still have the same issue... it's driving me nuts.

    <?xml version="1.0" standalone="no"?>
    <SOFTPKG GUID="A1FA0C7D-CC79-403C-AE17-2DABADC9D768" NAME="DefaultApp MFC Application" VERSION="1.0.0.1">
     <IMPLEMENTATION>
      <CODEBASE HREF="RTSPS://[APPVSERVER]:554/DefaultApp.sft" GUID="4F361562-D469-41D8-B6EF-D50538FDB202" PARAMETERS="" FILENAME="defapp\DefaultApp.exe" SYSGUARDFILE="defapp\osguard.cp" SIZE="4720348"/>
      <WORKINGDIR>%SFT_MNT%\defapp</WORKINGDIR>
      <VIRTUALENV TERMINATECHILDREN="FALSE">
       <ENVLIST/>
      </VIRTUALENV>
      <VM VALUE="Win32">
       <SUBSYSTEM VALUE="windows"/>
      </VM>
     </IMPLEMENTATION>
     <DEPENDENCY>
      <CLIENTVERSION VERSION="4.5.0.0"/>
     </DEPENDENCY>
     <PACKAGE NAME="DefaultApp"/>
     <ABSTRACT>This application is provided with Microsoft Application Virtualization as a default application for test purposes.  It is generally deployed as available to the default user on the default server group to enable administrators to prove basic system and network connectivity.</ABSTRACT>
     <MGMT_SHORTCUTLIST>
      <SHORTCUT LOCATION="%CSIDL_STARTMENU%" FILENAME="" OVERRIDDEN="TRUE" DISPLAY="DefaultApp" ICON="%SFT_MIME_SOURCE%/DefaultApp.ico"/>
     </MGMT_SHORTCUTLIST>
     <MGMT_FILEASSOCIATIONS>
      <PROGIDLIST/>
      <FILEEXTENSIONLIST/>
     </MGMT_FILEASSOCIATIONS>
    </SOFTPKG>

     

    Wednesday, April 28, 2010 9:13 AM
  • Have you enabled RTSPS on your managment server? (i.e. You'll need a certificate on the Management Server)
    Wednesday, April 28, 2010 11:54 AM
    Moderator
  • Hello,

    No, I didn't set it up to use a secure connection. Is that a requirement in a test setup?

    Stijn

    Wednesday, April 28, 2010 12:58 PM
  • Hey man,

    Changed the protocol to rtsp:// in the osd file, and it works now. Thanks a lot for pointing me in the right direction! That MS trial doc doesn't seem to be completely error free ;-)

    Thanks a lot


    Stijn

    • Proposed as answer by znack Wednesday, April 28, 2010 9:28 PM
    • Marked as answer by Aaron.ParkerModerator Monday, December 19, 2011 12:57 PM
    Wednesday, April 28, 2010 1:31 PM
  • Hello,

    Page 28 - bullet 19 - says specifically that for the default app - which of course is repated once again when it walks through the sequencing part and allowing you to setup your own package - page 41 step 37 and yet again repeated on page 45 step 24 when sequencing silverlight.

    Of course that setting is changed when setting up the secure environment (or switching distribution mechanism). Everyone keeps complaining about the trial guide - but so far I haven't found anything that is worth bringing to the authors.


    /Znack

    Saturday, May 1, 2010 9:45 PM