TMG rdp stops working after each reboot


  • Hi guys.

    I know TMG is depracted but still I'm keeping my fingers crossed if someone will reply with an useful answer.

    Problematic TMG server with all the patches.

    After each reboot, RDP connection to TMG stops working.

    The only solution (each time) is to log into console and restart TMG firewall service, and after that RDP starts working.

    Any suggestions?

    With best regards


    Sunday, February 11, 2018 4:05 PM

All replies

  • Hi Bostjian,

    Try to enable Ipv6 on the TMG server network card. 

    If this does not work also try this:

    start an MMC and add the RD session host configuration snapin. 
    goto the connection section and look at the properties of the RDP-tcp protocol 
    goto the adapter tab.. 
    enter listening on all adapters and close 
    click on disable connection 
    click on enable connection 
    goto the adapter tab 
    enter listening on internal interface 
    click on disable connection 
    click on enable connection 



    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Sunday, February 11, 2018 8:27 PM
  • Thanks for the hint, will try that...


    Monday, February 12, 2018 8:27 AM