none
Successor will not start immediately after predecessor despite F2S link - Project 2010 RRS feed

  • Question

  • I have an auto-scheduled task (287) that is linked with a F2S dependency on another auto-scheduled task (286) which happens to have a 'Must Start On' constraint on it.

    Task 287 steadfastly refuses to start on 27/01/17 despite task 286 finishing on 26/01/17. I've tried altering the task type, adding resources, hitting F9, hitting 'Respect Links' and just about anything else between. There is no lag - I must be missing something blindingly obvious but I cannot for the life of me understand why task 287 will not start on 27/01/17 and stays put on 01/02/17.

    Any ideas please?

    Thanks

    Peter

    Thursday, October 27, 2016 2:19 PM

Answers

  • Peter,

    Okay, the problem is the manually scheduled task. I'm not sure why you have it set as a manually scheduled task but at some point in time the start date of 01/02/17 was entered for task 287. For an auto-scheduled task, the puts an automatic start-no-earlier-than constraint on the task but for a manually scheduled task no such constraint is attached.

    The solution is simple. Change task 287 to be auto-scheduled and assuming their is no calendar conflict with the assigned resource, the task will automatically move back 3 days.

    John

    • Marked as answer by peterjelliott Friday, October 28, 2016 2:30 PM
    Thursday, October 27, 2016 4:27 PM
  • Hi John

    Tasks 283 and 284 were manually scheduled as I produced the programme after they had been completed but I've now amended them to be auto-scheduled - this has not affected task 287 which still stubbornly refuses to move.

    For the second screenshot I'd changed the task to manually-scheduled in order to 'force' it to start on 27/01/17, immediately after task 286 - that then allowed the subsequent tasks (288 onwards) to auto-schedule......

    To get round the problem I've now changed it back to auto-scheduled but entered a 'Start no Later Than' 27/01/17 constraint on task 287 which, while not ideal, has allowed the subsequent programme to auto-schedule.

    Thanks for your help

    Kind regards

    Peter

    • Marked as answer by peterjelliott Friday, October 28, 2016 2:29 PM
    Friday, October 28, 2016 7:10 AM

All replies

  • peterjelliott,

    Sorry, we can't tell from the data you've provided, but the following Wiki article may help.

    http://social.technet.microsoft.com/wiki/contents/articles/30143.ms-project-why-a-successor-task-s-start-date-may-not-directly-follow-a-predecessor-task-s-finish-date.aspx

    John

    Thursday, October 27, 2016 2:32 PM
  • I've also tried creating a new resource called 'Dave' and allocated him solely to the task in case resource issues were driving the start date. Task inspector is still, however, suggesting that when I manually force a 27/01/16 start date that task 287 may need to move back by 3-days. I just cannot determine what the driver for that 3-days is. There are no constraints ahead of it. It has as 'As Soon As Possible' constraint on it. I'm tearing my hair out......

    Thursday, October 27, 2016 2:39 PM
  • John

    Thanks - I had already seen this article and worked my way through eliminating all the suggested potential causes - to no avail. I've subsequently posted an update illustrating the outcome with Task Inspector on screen with Project still insistent that the task needs to move back by 3-days but I just cannot see why!

    Kind regards

    Peter

    Thursday, October 27, 2016 2:48 PM
  • Peter,

    Okay, the problem is the manually scheduled task. I'm not sure why you have it set as a manually scheduled task but at some point in time the start date of 01/02/17 was entered for task 287. For an auto-scheduled task, the puts an automatic start-no-earlier-than constraint on the task but for a manually scheduled task no such constraint is attached.

    The solution is simple. Change task 287 to be auto-scheduled and assuming their is no calendar conflict with the assigned resource, the task will automatically move back 3 days.

    John

    • Marked as answer by peterjelliott Friday, October 28, 2016 2:30 PM
    Thursday, October 27, 2016 4:27 PM
  • Two things. First, the manually scheduled tasks. If you want the tasks to be scheduled by their predecessors, then they must be auto scheduled.

    Second, go to file, options, and display the time as well as the date.

    Any help?

    Thursday, October 27, 2016 11:48 PM
  • Hi John

    Tasks 283 and 284 were manually scheduled as I produced the programme after they had been completed but I've now amended them to be auto-scheduled - this has not affected task 287 which still stubbornly refuses to move.

    For the second screenshot I'd changed the task to manually-scheduled in order to 'force' it to start on 27/01/17, immediately after task 286 - that then allowed the subsequent tasks (288 onwards) to auto-schedule......

    To get round the problem I've now changed it back to auto-scheduled but entered a 'Start no Later Than' 27/01/17 constraint on task 287 which, while not ideal, has allowed the subsequent programme to auto-schedule.

    Thanks for your help

    Kind regards

    Peter

    • Marked as answer by peterjelliott Friday, October 28, 2016 2:29 PM
    Friday, October 28, 2016 7:10 AM