locked
SharePoint 2007 SP2 - Is it possible to migrate Content-DB including SharePoint Designer Workflows? RRS feed

  • Question

  • Hello,

    I recently migrated a Webapplication into a new SharePoint Farm as the old one is totaly corrupted. I did the migration as follows here:

    1. Backup of Content-DB
    2. Restore previously created backup into new Database
    3. Attach the new database to a Webapplication in the new SharePoint Farm.

    So far so good, everything works quite fine. The only issue is, that all Workflows created via SharePoint Designer are missing in the new farm! Is this a common issue? Is there a way to migrate Workflows?

    I mean, I know that SharePoint Designer Workflows are not reusable - but I do migrate the WHOLE Content-DB with everything in it - I do not try reuse them at another place. Why does those Workflows dissapear?

    Any hints on this? Thanks & BR,J

    Thursday, September 22, 2011 8:44 AM

Answers

  • Can you provide any imformation on why the stsadm job fails?  In 2007 you have the ability to target sub-sites for migration, so you can try on a smaller, more surgical scale to see what happens.

    If that doesn't work, you'll need to rebuild and redploy.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Friday, September 23, 2011 3:57 PM
    Answerer

All replies

  • This is a common issue.  I'm surprised the workflows themselves didn't move over, past experience has shown that items in the workflow process itself won't move.

    If the old application is down, does that mean you can't take an STSADM backup/export, which you can then move into your new application?


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Thursday, September 22, 2011 12:18 PM
    Answerer
  • Hi,

    thanks for feedback..

    well, the problem is that the farm is totaly corrupted - it's suprising that the portal is still working at least 'somehow'. However the stsadm-o backup Job never succeeds.

    Hmm.. so there will very likely be no other way the to re-build all workflows from scratch again into the new environment?! -_-"

     

    Friday, September 23, 2011 3:01 PM
  • Can you provide any imformation on why the stsadm job fails?  In 2007 you have the ability to target sub-sites for migration, so you can try on a smaller, more surgical scale to see what happens.

    If that doesn't work, you'll need to rebuild and redploy.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Friday, September 23, 2011 3:57 PM
    Answerer
  • Hi,

    sorry for the very big delay but just wanted to add information:

    We finally noticed that the workflows do exist in the new farm after migrating the content-db. They just did not showed up because the appropriate DLLs have been missing in GAC.


    • Edited by JHohensinn Wednesday, November 16, 2011 4:39 PM
    Wednesday, November 16, 2011 4:38 PM