locked
Copy to USB Flash Drive INCREDIBLY SLOW... RRS feed

  • Question

  • So I have WIN7 64-bit Home, and when I attempt to copy files to a USB flash drive, I encounter a bizarre problem.  I am greeted with "Discovering items" and "Calculating" messages, and it proceeds to take 15 minutes to transfer a 2MB file, for example.  This happens without fail.

    However, I know the USB port is functional, because all other devices work perfectly in that port, and I know the flash drive is fine, because it works flawlessly with my XP computer.  The odd man out seems to be WIN7.

    Any ideas/solutions?

    Friday, September 17, 2010 3:56 AM

Answers

  • Connect the flash drive on the Windows 7 computer and reformat it using disk manager. For Win and Apple compatibility use Fat32, for Win only NTFS.

    Start, right-click computer, select manage, select disk management, select the flash drive, right-click for options.

    Delete any partitions, create a new simple volume, format. uncheck assign a drive letter, unless you intend to use it as a boot device. If you are, assign a letter at the end, Z,X,Y or such.

    Then test.

    If that doesn't help, then the flash drive's interface is causing the issue. How old is it?

    • Marked as answer by Dale Qiao Thursday, September 23, 2010 1:22 AM
    Friday, September 17, 2010 11:31 AM
  • To verify if the problem is caused by Windows 7, please plug in another USB drive and see how it works. Meanwhile, plug the USB device to other USB port for a test.

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Thursday, September 23, 2010 1:22 AM
    Monday, September 20, 2010 5:30 AM

All replies

  • Connect the flash drive on the Windows 7 computer and reformat it using disk manager. For Win and Apple compatibility use Fat32, for Win only NTFS.

    Start, right-click computer, select manage, select disk management, select the flash drive, right-click for options.

    Delete any partitions, create a new simple volume, format. uncheck assign a drive letter, unless you intend to use it as a boot device. If you are, assign a letter at the end, Z,X,Y or such.

    Then test.

    If that doesn't help, then the flash drive's interface is causing the issue. How old is it?

    • Marked as answer by Dale Qiao Thursday, September 23, 2010 1:22 AM
    Friday, September 17, 2010 11:31 AM
  • To verify if the problem is caused by Windows 7, please plug in another USB drive and see how it works. Meanwhile, plug the USB device to other USB port for a test.

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Thursday, September 23, 2010 1:22 AM
    Monday, September 20, 2010 5:30 AM