none
Mapped drive cannot create files/folders RRS feed

  • Question

  • Mapped drive cannot create files/folders.

    It says Location is not available.

    The mapped drive is done by a policy and users can see the files and edit them. They can copy files to the drive and from it as well.
    They however cannot create new documents on the drive or create folders.

    Using the UNC path or add Network Location, it works fine. Just a problem when it comes to mapped drives.

    none






    • Edited by CoCT_Jody Wednesday, November 4, 2015 12:05 PM
    Wednesday, November 4, 2015 9:17 AM

Answers

All replies

  • Hi CoCT_Jody,

    When did the issue start to occur? Did the issue occur with all the users or the specific machine? Have you tried to update the group policy (gpupdate /force) to have a check?

    First of all, please ensure all the machines have got the latest updates.

    Please try the following command line to reset the tcp/ip stack to have a check.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot

    If the issue persists, we could create a new share and copy all the contents on the old share folder to the new one then deploy the group policy to map the shared folder again to have a check. The old shared folders` ACL permissions may have been corrupted.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.




    Thursday, November 5, 2015 6:09 AM
    Moderator
  • Hi MeipoXu,

    In essence, we migrated shared data from one drive to another. Windows Server 2012 R2.

    This occured after we copied the data from DriveA to DriveB. We then changed the drive letter of DriveB to that of DriveA and applied the permissions we backed up, as well as quota and file screens.

    This is affecting all users on Windows7 machines and intermittently on Windows10 machines.

    In the meantime as a temporary workaround, we are adding Network Location to UNC path, but we would really preferably be using drive letter


    none



    • Edited by CoCT_Jody Thursday, November 5, 2015 2:25 PM
    Thursday, November 5, 2015 7:46 AM
  • Hi CoCT_Jody,

    Have you tried the solutions in my last reply and what is the result?

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, November 6, 2015 5:45 AM
    Moderator
  • Yes i did, but it did not work.

    Its impractical doing that on about 10 000 workstations/laptops though


    none

    Friday, November 6, 2015 6:34 AM
  • Hi CoCT_Jody,

    For the command line, we just need to do it on specific machine to have a check.

    For 10 000 workstations, we could create another share and copy all the contents in the previous shared folder to the new one and deploy the gp to map the new drive. Please run "gpupdate /force" to refresh the gp.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Friday, November 6, 2015 6:38 AM
    Moderator
  • Well that is what we did before this error came up, created another share on new drive and copied the contents of previous share

    none

    Friday, November 6, 2015 1:20 PM
  • Hi CoCT_Jody,

    Have you tried to refresh the gp to have a check? Have you tried to change the shared drive letter to have a check?

    There is a possibility the previous configurations are still presented on the machine, we could refresh the group policy or assign another mapped drive letter to have a check.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, November 9, 2015 2:19 AM
    Moderator
  • Hi MeipoXu,

    tried a gpupdate /force, tried a different drive letter and still getting same error.

    it only works fine through Network Location pointing to the UNC path


    none

    Monday, November 9, 2015 7:06 AM
  • Hi CoCT_Jody,

    "it only works fine through Network Location pointing to the UNC path"

    Do you mean configuring the gp for the UNC path or it is just available to access the shared folder from the Windows Explorer with the UNC path?

    Have you tried to map the drive locally without using the group policy?

    Please disable the offline feature locally to have a test.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Monday, November 9, 2015 7:14 AM
    Moderator
  • Hi MeipoXu,

    Thanks for all the help.

    We decided to reapply the backed up permissions and everything is working fine again.


    none

    Tuesday, November 10, 2015 12:48 PM