none
Backup of fileserver takes ages / very slow in DPM 2010 RRS feed

  • Question

  • My 2008 R2 fileserver is being backed up incrementally to tape daily with a weekly full backup.

    The full backup takes around 50 hrs for 50 GB of data and therefore runs into the incremental backups of the following two days resulting in following error:

    "The incremental backup job was cancelled because the associated full backup for the data source is not available or there is a newer version of the backup on which this job depends.

    This is a non-fatal error. Another backup has been created at approximately the same time as this backup. Use the other backup for recovery. (ID 30127)"

    The transfer rate when backing up other servers (incl exchange) is around 1 GB pr minute. Ethernet speed between all servers is 2 Gb/s.

    I have tried recreating the protection group.

    Is there a detailed log, where I can see how long backup of each file takes ?

     

    Tuesday, April 26, 2011 8:26 AM

All replies

  • Hello,

    You could go to the monitoring tab and fliter out the jobs for this server and\or create a custom filter for this server.
    From there you could reference the "time elapsed" column.   http://technet.microsoft.com/en-us/library/ff399093.aspx 

    There are other questions though that come into play on your problem.
       Are your synch jobs staggered?
       Are you using compression on the wire?
      
    Basically an assessment of "how much of a load is being place on this server"?

    Some DPM performance articles to help optimize the server:
       DPM Managing Performance: http://technet.microsoft.com/en-us/library/ff399471.aspx
       How DPM Operations Affect Performance: http://technet.microsoft.com/en-us/library/ff399315.aspx
       DPM and Memory: http://technet.microsoft.com/en-us/library/ff399244.aspx
       Performance Counters: http://technet.microsoft.com/en-us/library/ff399366.aspx
       Improving Performance: http://technet.microsoft.com/en-us/library/ff399571.aspx
       Managing DPM Performance on a WAN: http://technet.microsoft.com/en-us/library/ff634226.aspx
       How Protection Groups Changes Affect Jobs: http://technet.microsoft.com/en-us/library/ff399316.aspx


    Thanks
    Shane

     

    • Proposed as answer by ShaneB. _ Monday, May 2, 2011 5:06 PM
    Tuesday, April 26, 2011 1:41 PM
  • I'm afraid my issue isn't covered in any of those articles.

     

    The backup is performed in the night, and nothing else is scheduled in this period = 0% CPU activity.

    From the monitoring tab i read Time Elapsed : 57:45:31  Data Transerred: 49.974,44 MB    = 0,2 MB/s

    Other server with same hardware: Time Elapsed : 00:14:26 Data Transerred: 24.656,94 MB = 29 MB/s

     

    The affected server is a fileserver with shared folders and stores all users profiles and documents. Can this be the culprit ?

    Monday, May 23, 2011 1:26 PM
  • Is there a more detailed log that shows the backup duration per file ?
    Tuesday, May 31, 2011 6:40 AM
  • Hello,

    All DPM Server Activity logs are found here: %Program Files%\Microsoft DPM\DPM\Temp .  You would want to look at the MSDPMCurr.errlog

    To copy from a previous forum post in the past:
    "Because the consistency check only shows you number of bytes we have transfered since the CC started.  It may take an hour of CRC checking to discover 1GB of data that has actually changed, so in that 1 hr. you will only see DPM transfer 1GB, that DOES NOT mean that the trasfer rate is 1GB / hr.   It may go several hours and not transfer any data. (actually crc blocks being passed to the DPM server is also displayed as xfered bytes)"

    I'd suggest to follow the articles above to ensure that the server load\data transfer is as optimalized as possible.

    Are there any events on the target server that are more descriptive? Any VSS or volsnap related errors?

    Thanks
    Shane

    Wednesday, June 8, 2011 1:12 PM
  • Hi Shane,

    I never found a solution to this problem, and since summer the time to backup our file server has only been growing. Now taking almost two hours to backup one gigabyte of data.

    Problem is that the speed when backing up users profile files is aroung 100 KB/s. I have checked all the guides, and I'm still stuck.

    Both servers are idling during the backup (1% CPU and 0,03% of 2gb/s network). The network traffic stays very firmly around 0,03%. This confirms that the transfer rate is very low.

    I've tried disabling System Center Agent and Indexingservice with no luck on the server being backed up.

     

    Any clues what can be causing this ???

     



    • Edited by HN_Andrzej Wednesday, November 23, 2011 3:07 PM
    Wednesday, November 23, 2011 3:06 PM
  • I was having the same problem on and off for the past few months. As of about 45 minutes ago it looks like I have my DPM server backing up at a rate of approximately 1.5GB per minute again.

    Here is what I did:

    1. Made sure all Windows Server 2008 R2 SP1 updates were applied.
    2. Installed manufacturer latest tape/library driver (I have a HP MSL 2024 LTO-4 library)
    3. Uninstalled Microsoft FEP 2010
    4. Restarted the server.

    Prior to these changes my DPM server was in the middle of backup to tape which was running at approximately 50MB per minute since 8:00PM last night.

     

    Kirk

    Update: I'm actually getting anywhere from 2GB to 3GB per minute.

     

    • Edited by Kirk4Life Monday, November 28, 2011 1:26 AM
    Monday, November 28, 2011 12:12 AM
  • Hello,

    Most likely the antivirus change was your cause in that case. http://technet.microsoft.com/en-us/library/ff399439.aspx
    I personally ask to NOT scan the DPM directory altogether. 


    Shane

    Monday, November 28, 2011 9:36 PM
  • It turned out to be a really long day, in the middle of the night during an Exchange backup, DPM encountered an error. Jobs failed again!

    It was more involved than anti-virus, though that probably wasn't helping much. It turns out there was a hardware issue between DPM and my library, this time I was fortunate enough to get some event log message to help track down the problem. It was suggested that I check all the connections between the server and the library and run a "Drive Cleaning" job.

    I ran a Drive cleaning job first, then I ended up peforming a firmware upgrade on my library changer/tape drive. After the firmware upgrade I shut down both the server and the library.

    Next I disconnected the SCSI cable on both ends and verified all the pins were straight and not broken. After reconnecting the SCSI cable, I started the library up first and waiting until it was at a "Ready" status. Then I started my server up and restarted the failed jobs from last night.

    I am happy to say that all the jobs re-ran without incident and now I'm getting throughput speeds of up to 7GB to my tape drive.

    Long story short for anyone else having this issue:

    1. Check the cabling between the server and the library/tape drive.
    2. Update the firmware on your hardware.
    3. Run a "Drive Cleaning" job.

     

    Kirk

     


    • Edited by Kirk4Life Monday, November 28, 2011 10:15 PM fix typos
    Monday, November 28, 2011 10:14 PM
  • Hi,

    I am getting this speed while creating SQL replica using DPM 2010. Please suggest ... Is there any settings required to fix this. SQL is locally installed on the same server but it has multiple databases which was previously installed with SCCM. Yes have MS-SCCM Installed on the same server, Does it matter?. If yes then why backup not showing any error?

     

    Help on this highly appreciated.

    (This server is on cloud and all hardware configuration meet the ms-dpm requirement, Backup type disk iscsi).

    Regards

    Thursday, July 19, 2012 4:58 PM